diff --git a/extra/calligra/PKGBUILD b/extra/calligra/PKGBUILD
index 5373c3edc..89111ea14 100644
--- a/extra/calligra/PKGBUILD
+++ b/extra/calligra/PKGBUILD
@@ -34,7 +34,7 @@ groups=('calligra')
 source=("http://download.kde.org/stable/${pkgbase}-${pkgver}/${pkgbase}-${pkgver}.tar.xz"
         "arm.patch")
 md5sums=('9cf909ddf57ecb16d4370cc1062d0f7f'
-         '03b3eb02a50239abb31067f08ca537c2')
+         '07d60efe2cdd472cb8860ea1ae157976')
 
 prepare() {
   cd $pkgbase-$pkgver
diff --git a/extra/calligra/arm.patch b/extra/calligra/arm.patch
index 372c192fc..cab684288 100644
--- a/extra/calligra/arm.patch
+++ b/extra/calligra/arm.patch
@@ -1,6 +1,18 @@
+diff -urN a/krita/image/kis_fixed_point_maths.h b/krita/image/kis_fixed_point_maths.h
+--- a/krita/image/kis_fixed_point_maths.h	2013-07-29 00:27:14.000000000 -0600
++++ b/krita/image/kis_fixed_point_maths.h	2013-08-07 11:11:37.025564690 -0600
+@@ -34,7 +34,7 @@
+         d = iValue << 8;
+     }
+ 
+-    KisFixedPoint(qreal fValue) {
++    KisFixedPoint(double fValue) {
+         d = fValue * (1 << 8);
+     }
+ 
 diff -urN a/krita/image/tests/kis_filter_weights_buffer_test.cpp b/krita/image/tests/kis_filter_weights_buffer_test.cpp
 --- a/krita/image/tests/kis_filter_weights_buffer_test.cpp	2013-07-29 00:27:14.000000000 -0600
-+++ b/krita/image/tests/kis_filter_weights_buffer_test.cpp	2013-08-05 11:57:02.906735729 -0600
++++ b/krita/image/tests/kis_filter_weights_buffer_test.cpp	2013-08-07 10:44:47.563284702 -0600
 @@ -38,7 +38,7 @@
      KisFixedPoint fp2;
  
@@ -12,7 +24,7 @@ diff -urN a/krita/image/tests/kis_filter_weights_buffer_test.cpp b/krita/image/t
      fp2.from256Frac(endIndex);
 diff -urN a/krita/ui/kis_image_view_converter.cpp b/krita/ui/kis_image_view_converter.cpp
 --- a/krita/ui/kis_image_view_converter.cpp	2013-07-29 00:27:15.000000000 -0600
-+++ b/krita/ui/kis_image_view_converter.cpp	2013-08-05 11:55:36.212128142 -0600
++++ b/krita/ui/kis_image_view_converter.cpp	2013-08-07 10:44:47.563284702 -0600
 @@ -40,7 +40,7 @@
  
  // remember here; document is postscript points;  view is krita pixels.
@@ -24,7 +36,7 @@ diff -urN a/krita/ui/kis_image_view_converter.cpp b/krita/ui/kis_image_view_conv
      Q_ASSERT(zoomY);
 diff -urN a/krita/ui/kis_image_view_converter.h b/krita/ui/kis_image_view_converter.h
 --- a/krita/ui/kis_image_view_converter.h	2013-07-29 00:27:15.000000000 -0600
-+++ b/krita/ui/kis_image_view_converter.h	2013-08-05 11:55:36.212128142 -0600
++++ b/krita/ui/kis_image_view_converter.h	2013-08-07 10:44:47.563284702 -0600
 @@ -52,7 +52,7 @@
      using KoViewConverter::viewToDocument;
  
@@ -36,7 +48,7 @@ diff -urN a/krita/ui/kis_image_view_converter.h b/krita/ui/kis_image_view_conver
      qreal documentToViewY(qreal documentY) const;
 diff -urN a/krita/ui/tests/kis_zoom_and_pan_test.cpp b/krita/ui/tests/kis_zoom_and_pan_test.cpp
 --- a/krita/ui/tests/kis_zoom_and_pan_test.cpp	2013-07-29 00:27:15.000000000 -0600
-+++ b/krita/ui/tests/kis_zoom_and_pan_test.cpp	2013-08-05 11:55:36.212128142 -0600
++++ b/krita/ui/tests/kis_zoom_and_pan_test.cpp	2013-08-07 10:44:47.568284679 -0600
 @@ -218,7 +218,7 @@
      qreal oldPreferredCenterFractionY = 1.0 * oldPreferredCenter.y() / oldDocumentSize.height();