mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/samba to 4.16.2-1
This commit is contained in:
parent
efa9c5e7f5
commit
fb886437ae
2 changed files with 5 additions and 56 deletions
|
@ -1,43 +0,0 @@
|
|||
From 34771e1931587807d0395c7ac7f4be18654997f4 Mon Sep 17 00:00:00 2001
|
||||
From: Elia Geretto <elia.f.geretto@gmail.com>
|
||||
Date: Fri, 11 Mar 2022 19:32:30 +0100
|
||||
Subject: [PATCH] s3:libsmb: Fix errno for failed authentication in
|
||||
SMBC_server_internal()
|
||||
|
||||
In SMBC_server_internal(), when authentication fails, the errno value is
|
||||
currently hard-coded to EPERM, while it should be EACCES instead. Use the
|
||||
NT_STATUS map to set the appropriate value.
|
||||
|
||||
This bug was found because it breaks listing printers protected by
|
||||
authentication in GNOME Control Panel.
|
||||
|
||||
BUG: https://bugzilla.samba.org/show_bug.cgi?id=14983
|
||||
|
||||
Signed-off-by: Elia Geretto <elia.f.geretto@gmail.com>
|
||||
Reviewed-by: Jeremy Allison <jra@samba.org>
|
||||
Reviewed-by: Volker Lendecke <vl@samba.org>
|
||||
|
||||
Autobuild-User(master): Jeremy Allison <jra@samba.org>
|
||||
Autobuild-Date(master): Wed Mar 16 19:44:18 UTC 2022 on sn-devel-184
|
||||
|
||||
(cherry picked from commit 70b9977a46e5242174b4461a7f49d5f640c1db62)
|
||||
---
|
||||
source3/libsmb/libsmb_server.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/source3/libsmb/libsmb_server.c b/source3/libsmb/libsmb_server.c
|
||||
index b92477c88fe..09d27868c0e 100644
|
||||
--- a/source3/libsmb/libsmb_server.c
|
||||
+++ b/source3/libsmb/libsmb_server.c
|
||||
@@ -572,7 +572,7 @@ SMBC_server_internal(TALLOC_CTX *ctx,
|
||||
!NT_STATUS_IS_OK(cli_session_setup_anon(c))) {
|
||||
|
||||
cli_shutdown(c);
|
||||
- errno = EPERM;
|
||||
+ errno = map_errno_from_nt_status(status);
|
||||
return NULL;
|
||||
}
|
||||
}
|
||||
--
|
||||
GitLab
|
||||
|
|
@ -13,8 +13,8 @@
|
|||
|
||||
pkgbase=samba
|
||||
pkgname=('smbclient' 'samba')
|
||||
pkgver=4.16.1
|
||||
pkgrel=5
|
||||
pkgver=4.16.2
|
||||
pkgrel=1
|
||||
arch=(x86_64)
|
||||
url="https://www.samba.org"
|
||||
license=('GPL3')
|
||||
|
@ -31,23 +31,15 @@ optdepends=(
|
|||
source=(https://us1.samba.org/samba/ftp/stable/${pkgbase}-${pkgver}.tar{.gz,.asc}
|
||||
samba.logrotate
|
||||
samba.pam
|
||||
samba.conf
|
||||
34771e1931587807d0395c7ac7f4be18654997f4.patch)
|
||||
samba.conf)
|
||||
validpgpkeys=('81F5E2832BD2545A1897B713AA99442FB680B620') #Samba Distribution Verification Key <samba-bugs@samba.org>
|
||||
sha512sums=('d82ab250e87cb64b083345b61da8c4edbb2185a13f8cef33232f823fd510822570ed27c7b260a1fefd3af3b2fc4b271257c2c3e6ab3241c8c147bebae6ab39fc'
|
||||
sha512sums=('ed85acca0f23f9166530b600ae569f3259c2122d15e361fd3fe48a82921cd53bbb459d6c102bb60cc40b2dd811cde1262a3fb17ed6015a260432bffe5af83366'
|
||||
'SKIP'
|
||||
'2ba0691ded467e4d6e40821f6de58c00f8962209efe2e60284c0c87756ab471c22c3d63b77d506e48c90ed0d852a2a24e41be1d499cf74a73cb99da0b503c858'
|
||||
'1e6183ab0eb812b3ef687ac2c26ce78f7cb30540f606d20023669ac00ba04075487fb72e4dc89cc05dab0269ff6aca98fc1167cc75669c225b88b592482fbf67'
|
||||
'e46ee848baabb261e7468ecee43aba4d001a24f86f5322ae522abdb75030fd0ebd9063b9df0be3576c4d1654d81331f5e389aee16ec2fa138259ae4728e94efc'
|
||||
'ee60e1d16241698fa4e66fbb97d4a08c6ccf8f03a1ce17b855bd0ca47b546747d67a01c89330072833949ec1ab8d7fd713c7370613b24e777f158c141195cd53')
|
||||
'e46ee848baabb261e7468ecee43aba4d001a24f86f5322ae522abdb75030fd0ebd9063b9df0be3576c4d1654d81331f5e389aee16ec2fa138259ae4728e94efc')
|
||||
### UNINSTALL dmapi package before building!!!
|
||||
|
||||
prepare () {
|
||||
# Fix 74259
|
||||
cd samba-${pkgver}
|
||||
patch -Rp1 -i ../34771e1931587807d0395c7ac7f4be18654997f4.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
# Use samba-pkg as a staging directory for the split packages
|
||||
# (This is so RPATHS and symlinks are generated correctly via
|
||||
|
|
Loading…
Reference in a new issue