mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
community/blender to 3.5.0-1
This commit is contained in:
parent
d68a09cf63
commit
fbac8fb4e8
4 changed files with 6 additions and 127 deletions
|
@ -17,8 +17,8 @@ buildarch=8
|
|||
# fine with them.
|
||||
|
||||
pkgname=blender
|
||||
pkgver=3.4.1
|
||||
pkgrel=23
|
||||
pkgver=3.5.0
|
||||
pkgrel=1
|
||||
epoch=17
|
||||
pkgdesc="A fully integrated 3D graphics creation suite"
|
||||
arch=('x86_64')
|
||||
|
@ -30,66 +30,34 @@ depends=('libpng' 'libtiff' 'openexr' 'python' 'desktop-file-utils' 'python-requ
|
|||
'openimageio' 'libsndfile' 'jack' 'opencolorio' 'openshadinglanguage'
|
||||
'jemalloc' 'libspnav' 'ptex' 'opensubdiv' 'openvdb' 'log4cplus' 'sdl2' 'libharu'
|
||||
'draco')
|
||||
makedepends=('cmake' 'boost' 'mesa' 'git' 'llvm' 'ninja' 'libepoxy' 'wayland-protocols'
|
||||
makedepends=('cmake' 'boost' 'mesa' 'git' 'svn' 'llvm' 'ninja' 'libepoxy' 'wayland-protocols'
|
||||
'libxkbcommon' 'libdecor')
|
||||
optdepends=('libdecor: wayland support')
|
||||
# We're using !buildflags here as otherwise we get stuff such as FS#77557
|
||||
# It'd be better to figure out exactly which of the flags is the culprit which I attempted but without any success.
|
||||
options=('!buildflags')
|
||||
source=("git+https://projects.blender.org/blender/blender.git#tag=v$pkgver"
|
||||
"git+https://projects.blender.org/blender/blender-addons.git"
|
||||
"git+https://projects.blender.org/blender/blender-addons-contrib.git"
|
||||
"git+https://projects.blender.org/blender/blender-translations.git"
|
||||
"git+https://projects.blender.org/blender/blender-dev-tools.git"
|
||||
https://developer.download.nvidia.com/redist/optix/v7.6/OptiX-7.6-Include.zip
|
||||
blender-sycl-path.patch
|
||||
blender-oneapi-escape.patch
|
||||
blender-numpy.patch
|
||||
blender-ffmpeg6.patch
|
||||
force-draco1.patch
|
||||
force-draco2.patch)
|
||||
sha512sums=('SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'dfe86de395dd298fb9feae73bff06a26742efa06a25bb5a4f78ffb1ba4c78f555d1af927efea98af281715cce01db219aa2adfd6bd323bf0d766c1c70ce03532'
|
||||
'bc9a80941a18aaddc3e8f2d9963e4f6b7eb1cf9f098418adb236771c3bedcab7b7a06121178f7498caba1af67116cd0ea549382e14a707163cdd5d8fbf3ee824'
|
||||
'1898af42ac10e9fc61c6fb979c1a3c6c91981c0c9790bf954e9425b5e7db897399d0ba6757f006f4ee1d6125ae0619b2e2a7ea5cf77cc36b91f3192873b66d9f'
|
||||
'a39d9a13515b71d3b686d8f011b3eb9ee45de04f716627d711c5119317cb130c587da1b806f276f97064f814cfce3790b201731f047e5ec01e7d6f65acd04b3b'
|
||||
'34a2e2a344e851858fc8408ca9fd31d1d4a40083b2a1b2c01cabf48c2728c0b97226cf22c4224f93eda383b4690ff57e98291ad4fa81b960f0531067b40f78f7'
|
||||
'e239da4f3906f1b54265435181cf770bae3d269c8d915df9a73861e6ee71ec70bf2339426e7c81a91e5a567273b3b3742d7a99feefd3398d821b26e1ff3a56d0'
|
||||
'c162646eba42ea7112cfb615466c2cbaddac8d254d4a9e91cf887c5bffef1325a983701163223a1fdee091310ac5574a400347aab7f52321825b5fa3d5a9036f')
|
||||
|
||||
prepare() {
|
||||
cd "$pkgname"
|
||||
|
||||
git submodule init
|
||||
git config submodule."release/scripts/addons".url "${srcdir}/blender-addons"
|
||||
git config submodule."release/scripts/addons_contrib".url "${srcdir}/blender-addons-contrib"
|
||||
git config submodule."release/datafiles/locale".url "${srcdir}/blender-translations"
|
||||
git config submodule."source/tools".url "${srcdir}/blender-dev-tools"
|
||||
git -c protocol.file.allow=always submodule update
|
||||
git submodule foreach git checkout v${pkgver}
|
||||
|
||||
# fix build with boost 1.81.0
|
||||
git format-patch -1 --stdout 79837c5ed4b5 | patch -Np1
|
||||
make update
|
||||
|
||||
# fix draco
|
||||
patch -p1 -i "$srcdir"/force-draco1.patch
|
||||
patch -p1 -d release/scripts/addons -i "$srcdir"/force-draco2.patch
|
||||
|
||||
# fix for FS#77376
|
||||
patch -p1 -d release/scripts/addons -i "$srcdir"/blender-numpy.patch
|
||||
patch -p1 -d scripts/addons -i "$srcdir"/force-draco2.patch
|
||||
|
||||
# fix SYCL include dir
|
||||
patch -p1 -i "$srcdir"/blender-sycl-path.patch
|
||||
|
||||
# fix oneapi escapes
|
||||
patch -p1 -i "$srcdir"/blender-oneapi-escape.patch
|
||||
|
||||
# ffmpeg 6
|
||||
patch -p1 -i "$srcdir"/blender-ffmpeg6.patch
|
||||
}
|
||||
|
||||
get_pyver() {
|
||||
|
@ -130,7 +98,7 @@ package() {
|
|||
install -Dm644 release/freedesktop/org.blender.Blender.appdata.xml "${pkgdir}/usr/share/metainfo/org.blender.Blender.appdata.xml"
|
||||
|
||||
# Manually install additional scripts (See FS#69351)
|
||||
cp -r release/scripts/addons_contrib/* "${pkgdir}"/usr/share/blender/3*/scripts/addons_contrib/
|
||||
cp -r scripts/addons_contrib/* "${pkgdir}"/usr/share/blender/3*/scripts/addons_contrib/
|
||||
|
||||
# Manually install draco bindings (See FS#73415)
|
||||
mkdir -p "${pkgdir}/usr/lib/python$(get_pyver)"/
|
||||
|
|
|
@ -1,63 +0,0 @@
|
|||
diff --git a/intern/ffmpeg/ffmpeg_compat.h b/intern/ffmpeg/ffmpeg_compat.h
|
||||
index f311e04d8e0..4f474d0c267 100644
|
||||
--- a/intern/ffmpeg/ffmpeg_compat.h
|
||||
+++ b/intern/ffmpeg/ffmpeg_compat.h
|
||||
@@ -36,6 +36,10 @@
|
||||
# define FFMPEG_INLINE static inline
|
||||
#endif
|
||||
|
||||
+#if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(58,132,100)
|
||||
+# define AV_CODEC_CAP_OTHER_THREADS AV_CODEC_CAP_AUTO_THREADS
|
||||
+#endif
|
||||
+
|
||||
#if (LIBAVFORMAT_VERSION_MAJOR < 58) || \
|
||||
((LIBAVFORMAT_VERSION_MAJOR == 58) && (LIBAVFORMAT_VERSION_MINOR < 76))
|
||||
# define FFMPEG_USE_DURATION_WORKAROUND 1
|
||||
diff --git a/source/blender/blenkernel/intern/writeffmpeg.c b/source/blender/blenkernel/intern/writeffmpeg.c
|
||||
index 1d4cbc48833..c812c2e8f26 100644
|
||||
--- a/source/blender/blenkernel/intern/writeffmpeg.c
|
||||
+++ b/source/blender/blenkernel/intern/writeffmpeg.c
|
||||
@@ -855,7 +855,7 @@ static AVStream *alloc_video_stream(FFMpegContext *context,
|
||||
255);
|
||||
st->avg_frame_rate = av_inv_q(c->time_base);
|
||||
|
||||
- if (codec->capabilities & AV_CODEC_CAP_AUTO_THREADS) {
|
||||
+ if (codec->capabilities & AV_CODEC_CAP_OTHER_THREADS) {
|
||||
c->thread_count = 0;
|
||||
}
|
||||
else {
|
||||
diff --git a/source/blender/imbuf/intern/anim_movie.c b/source/blender/imbuf/intern/anim_movie.c
|
||||
index 94c0555dcf0..52314c2ca21 100644
|
||||
--- a/source/blender/imbuf/intern/anim_movie.c
|
||||
+++ b/source/blender/imbuf/intern/anim_movie.c
|
||||
@@ -554,7 +554,7 @@ static int startffmpeg(struct anim *anim)
|
||||
avcodec_parameters_to_context(pCodecCtx, video_stream->codecpar);
|
||||
pCodecCtx->workaround_bugs = FF_BUG_AUTODETECT;
|
||||
|
||||
- if (pCodec->capabilities & AV_CODEC_CAP_AUTO_THREADS) {
|
||||
+ if (pCodec->capabilities & AV_CODEC_CAP_OTHER_THREADS) {
|
||||
pCodecCtx->thread_count = 0;
|
||||
}
|
||||
else {
|
||||
diff --git a/source/blender/imbuf/intern/indexer.c b/source/blender/imbuf/intern/indexer.c
|
||||
index 63836690ee4..fb0dd4f3e3e 100644
|
||||
--- a/source/blender/imbuf/intern/indexer.c
|
||||
+++ b/source/blender/imbuf/intern/indexer.c
|
||||
@@ -559,7 +559,7 @@ static struct proxy_output_ctx *alloc_proxy_output_ffmpeg(
|
||||
av_dict_set(&codec_opts, "preset", "veryfast", 0);
|
||||
av_dict_set(&codec_opts, "tune", "fastdecode", 0);
|
||||
|
||||
- if (rv->codec->capabilities & AV_CODEC_CAP_AUTO_THREADS) {
|
||||
+ if (rv->codec->capabilities & AV_CODEC_CAP_OTHER_THREADS) {
|
||||
rv->c->thread_count = 0;
|
||||
}
|
||||
else {
|
||||
@@ -872,7 +872,7 @@ static IndexBuildContext *index_ffmpeg_create_context(struct anim *anim,
|
||||
avcodec_parameters_to_context(context->iCodecCtx, context->iStream->codecpar);
|
||||
context->iCodecCtx->workaround_bugs = FF_BUG_AUTODETECT;
|
||||
|
||||
- if (context->iCodec->capabilities & AV_CODEC_CAP_AUTO_THREADS) {
|
||||
+ if (context->iCodec->capabilities & AV_CODEC_CAP_OTHER_THREADS) {
|
||||
context->iCodecCtx->thread_count = 0;
|
||||
}
|
||||
else {
|
|
@ -1,13 +0,0 @@
|
|||
diff --git a/io_scene_gltf2/blender/imp/gltf2_blender_mesh.py b/io_scene_gltf2/blender/imp/gltf2_blender_mesh.py
|
||||
index 41dd4d03..a97f9d38 100755
|
||||
--- a/io_scene_gltf2/blender/imp/gltf2_blender_mesh.py
|
||||
+++ b/io_scene_gltf2/blender/imp/gltf2_blender_mesh.py
|
||||
@@ -572,7 +572,7 @@ def set_poly_smoothing(gltf, pymesh, mesh, vert_normals, loop_vidxs):
|
||||
# Try to guess which polys should be flat based on the fact that all the
|
||||
# loop normals for a flat poly are = the poly's normal.
|
||||
|
||||
- poly_smooths = np.empty(num_polys, dtype=np.bool)
|
||||
+ poly_smooths = np.empty(num_polys, dtype=np.bool_)
|
||||
|
||||
poly_normals = np.empty(num_polys * 3, dtype=np.float32)
|
||||
mesh.polygons.foreach_get('normal', poly_normals)
|
|
@ -1,13 +0,0 @@
|
|||
diff --git a/intern/cycles/kernel/CMakeLists.txt b/intern/cycles/kernel/CMakeLists.txt
|
||||
index 39edb561ad4..20b0e579056 100644
|
||||
--- a/intern/cycles/kernel/CMakeLists.txt
|
||||
+++ b/intern/cycles/kernel/CMakeLists.txt
|
||||
@@ -715,7 +715,7 @@ if(WITH_CYCLES_DEVICE_ONEAPI)
|
||||
|
||||
# Set defaults for spir64 and spir64_gen options
|
||||
if (NOT DEFINED CYCLES_ONEAPI_SYCL_OPTIONS_spir64)
|
||||
- set(CYCLES_ONEAPI_SYCL_OPTIONS_spir64 "-options '-ze-opt-large-register-file -ze-opt-regular-grf-kernel integrator_intersect'")
|
||||
+ set(CYCLES_ONEAPI_SYCL_OPTIONS_spir64 "-options \\\'-ze-opt-large-register-file -ze-opt-regular-grf-kernel integrator_intersect\\\'")
|
||||
endif()
|
||||
if (NOT DEFINED CYCLES_ONEAPI_SYCL_OPTIONS_spir64_gen)
|
||||
SET (CYCLES_ONEAPI_SYCL_OPTIONS_spir64_gen "${CYCLES_ONEAPI_SYCL_OPTIONS_spir64}" CACHE STRING "Extra build options for spir64_gen target")
|
Loading…
Reference in a new issue