extra/qt5-webengine to 5.13.0-4

This commit is contained in:
Kevin Mihelich 2019-08-10 01:30:04 +00:00
parent 5364ba38e5
commit fbacd77739
2 changed files with 16 additions and 2 deletions

View file

@ -11,24 +11,26 @@ highmem=1
pkgname=qt5-webengine
_qtver=5.13.0
pkgver=${_qtver/-/}
pkgrel=3
pkgrel=4
arch=('x86_64')
url='https://www.qt.io'
license=('LGPL3' 'LGPL2.1' 'BSD')
pkgdesc='Provides support for web applications using the Chromium browser project'
depends=('qt5-webchannel' 'qt5-location' 'libxcomposite' 'libxrandr' 'pciutils' 'libxss'
'libevent' 'snappy' 'nss' 'protobuf' 'libxslt' 'minizip' 'ffmpeg' 're2' 'libvpx')
'libevent' 'snappy' 'nss' 'protobuf' 'libxslt' 'minizip' 'ffmpeg' 're2' 'libvpx' 'libpulse')
makedepends=('python2' 'gperf' 'jsoncpp' 'ninja' 'qt5-tools' 'poppler')
groups=('qt' 'qt5')
_pkgfqn="${pkgname/5-/}-everywhere-src-${_qtver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
qtwebengine-glibc-2.29.patch
qtbug-77037-workaround.patch
qtbug-76913.patch::"https://code.qt.io/cgit/qt/qtwebengine.git/patch/?id=4746bb90"
qtbug-76958.patch
0001-ARM-toolchain-fixes.patch
0002-Fix-ARM-skia-ICE.patch)
sha256sums=('e0af82ecee1ab41b6732697f667b98b7b0c53164bebcfaad8070e88b2e064efe'
'dd791f154b48e69cd47fd94753c45448655b529590995fd71ac1591c53a3d60c'
'3e3bb8ecf292e7f249d001db4a4a072ca4ba38f713f496122bd7c73d93d5def9'
'5771af2442d7743ef7c59f0d3716a23985383e2b69ecb4fa9d4ea8e8f7c551fa'
'eef55340b3ec5f8d1020b7327eda67f86729aaf70107c688deb15083f5ca8fbc'
'f03455dd16275f8abb432278abb908ebdd5f8cf83db73ae63de7a105bbf47109'
@ -40,6 +42,7 @@ prepare() {
cd ${_pkgfqn}
patch -p1 -i ../qtbug-76913.patch # Fix crashes on media-heavy sites
patch -p1 -i ../qtbug-76958.patch # Fix crash when loading tabs on the background
patch -p1 -i ../qtbug-77037-workaround.patch # Link to pulseaudio to avoid header mismatch
cd src/3rdparty/chromium
patch -p1 -i "$srcdir"/qtwebengine-glibc-2.29.patch # Fix PPAPI plugins with glibc 2.29

View file

@ -0,0 +1,11 @@
--- qtwebengine-everywhere-src-5.13.0/src/core/config/linux.pri.orig 2019-08-06 08:23:45.385072740 +0300
+++ qtwebengine-everywhere-src-5.13.0/src/core/config/linux.pri 2019-08-06 08:23:51.085237082 +0300
@@ -162,7 +162,7 @@ host_build {
qtConfig(webengine-system-harfbuzz): gn_args += use_system_harfbuzz=true
!qtConfig(webengine-system-glib): gn_args += use_glib=false
qtConfig(webengine-pulseaudio) {
- gn_args += use_pulseaudio=true
+ gn_args += use_pulseaudio=true link_pulseaudio=true
} else {
gn_args += use_pulseaudio=false
}