core/linux-utilite to 3.0.35-14

This commit is contained in:
Kevin Mihelich 2014-04-24 23:01:45 +00:00
parent 66913ad46f
commit fbb93519f5
2 changed files with 5 additions and 30 deletions

View file

@ -3,12 +3,12 @@
buildarch=4
pkgbase=linux-utilite
_commit=4eb7ef5fe9b4136d4f87412d7cb0b6fdbf7291cd
_commit=a6300fb8bc7a35db57b53644d19165633787cff7
_srcname=utilite-${_commit}
_kernelname=${pkgbase#linux}
_desc="CompuLab Utilite alternate kernel"
pkgver=3.0.35
pkgrel=13
pkgrel=14
arch=('armv7h')
url="https://gitorious.org/utilite/utilite"
license=('GPL2')
@ -16,12 +16,10 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'uboot-mkimage')
options=('!strip')
source=("https://github.com/wolfgar/utilite/archive/${_commit}.tar.gz"
'config'
'https://raw.github.com/Freescale/meta-fsl-arm/46de5ee9dec3486c3e081f9f39ac1a0f967afd54/recipes-kernel/linux/linux-imx-3.0.35/ENGR00278350-gpu-viante-4.6.9p13-kernel-part-integra.patch'
'disable-smarteee.patch')
md5sums=('aab25227213c7541648312740bde3ae6'
'https://raw.github.com/Freescale/meta-fsl-arm/46de5ee9dec3486c3e081f9f39ac1a0f967afd54/recipes-kernel/linux/linux-imx-3.0.35/ENGR00278350-gpu-viante-4.6.9p13-kernel-part-integra.patch')
md5sums=('3e3d403ab7cc3bfffbd7a120b946c4ce'
'10ef3a2bc67d15b46f5ce9b20b689568'
'41941771adfed8b55574a7434d2c3393'
'8e592f455c2ecbf83fddfac5f6691c0f')
'41941771adfed8b55574a7434d2c3393')
prepare() {
cd "${srcdir}/${_srcname}"
@ -31,9 +29,6 @@ prepare() {
# allow use of 3.10.17 gpu binaries
patch --ignore-whitespace -p1 < ../ENGR00278350-gpu-viante-4.6.9p13-kernel-part-integra.patch
# Disable SmartEEE which causes ethernet link down/up issue
patch -Np1 -i ../disable-smarteee.patch
# add pkgrel to extraversion
sed -ri "s|^(EXTRAVERSION =)(.*)|\1 \2-${pkgrel}|" Makefile

View file

@ -1,20 +0,0 @@
diff -rupN utilite-a/arch/arm/mach-mx6/board-cm-fx6.c utilite-b/arch/arm/mach-mx6/board-cm-fx6.c
--- utilite-a/arch/arm/mach-mx6/board-cm-fx6.c 2014-02-24 21:35:41.000000000 +0000
+++ utilite-b/arch/arm/mach-mx6/board-cm-fx6.c 2014-04-16 20:33:04.473660149 +0000
@@ -200,6 +200,16 @@ static int cm_fx6_fec_phy_init(struct ph
{
unsigned short val;
+ /* Ar8031 phy SmartEEE feature cause link status generates glitch,
+ * which cause ethernet link down/up issue, so disable SmartEEE
+ */
+ phy_write(phydev, 0xd, 0x3);
+ phy_write(phydev, 0xe, 0x805d);
+ phy_write(phydev, 0xd, 0x4003);
+ val = phy_read(phydev, 0xe);
+ val &= ~(0x1 << 8);
+ phy_write(phydev, 0xe, val);
+
/* To enable AR8031 ouput a 125MHz clk from CLK_25M */
phy_write(phydev, 0xd, 0x7);
phy_write(phydev, 0xe, 0x8016);