mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
aur updates
This commit is contained in:
parent
8094d4c84a
commit
fbc8c8a746
10 changed files with 50 additions and 218 deletions
|
@ -2,7 +2,7 @@
|
||||||
|
|
||||||
pkgname=couchpotato-git
|
pkgname=couchpotato-git
|
||||||
_gitname=CouchPotatoServer
|
_gitname=CouchPotatoServer
|
||||||
pkgver=2358.324415b
|
pkgver=2993.b69f8b7
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
pkgdesc="Automatic Movie Downloading via NZBs & Torrent"
|
pkgdesc="Automatic Movie Downloading via NZBs & Torrent"
|
||||||
arch=('any')
|
arch=('any')
|
||||||
|
|
|
@ -1,30 +1,24 @@
|
||||||
|
# Maintainer: Brice Waegeneire < brice dot wge at gmail dot com >
|
||||||
# Contributor: Alexander Lam <lambchop468 *AT* gmail.com>
|
# Contributor: Alexander Lam <lambchop468 *AT* gmail.com>
|
||||||
plugrel=1
|
|
||||||
pkgname=devmem
|
pkgname=devmem
|
||||||
pkgver=2
|
pkgver=2
|
||||||
pkgrel=1
|
pkgrel=2
|
||||||
pkgdesc="A small utility to access /dev/mem and read/write to any memory location"
|
pkgdesc="A small utility to access /dev/mem and read/write to any memory location"
|
||||||
arch=('any')
|
arch=('any')
|
||||||
url="http://free-electrons.com/pub/mirror/devmem2.c"
|
url="http://free-electrons.com/pub/mirror/devmem2.c"
|
||||||
license=('GPL2')
|
license=('GPL2')
|
||||||
groups=()
|
|
||||||
depends=()
|
|
||||||
makedepends=()
|
|
||||||
optdepends=()
|
|
||||||
provides=()
|
|
||||||
conflicts=()
|
|
||||||
replaces=()
|
|
||||||
backup=()
|
|
||||||
options=()
|
|
||||||
install=
|
|
||||||
source=("http://free-electrons.com/pub/mirror/${pkgname}${pkgver}.c")
|
source=("http://free-electrons.com/pub/mirror/${pkgname}${pkgver}.c")
|
||||||
noextract=()
|
|
||||||
md5sums=('e23f236e94be4c429aa1ceac0f01544b')
|
sha256sums=('3b15515693bae1ebd14d914e46d388edfec2175829ea1576a7a0c8606ebbe639')
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "$srcdir/"
|
cd "$srcdir/"
|
||||||
gcc devmem2.c -o devmem2
|
gcc devmem2.c -o devmem2
|
||||||
install -D -m755 devmem2 ${pkgdir}/usr/sbin/devmem2
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
install -D -m755 ${srcdir}/devmem2 ${pkgdir}/usr/bin/devmem2
|
||||||
}
|
}
|
||||||
|
|
||||||
# vim:set ts=2 sw=2 et:
|
# vim:set ts=2 sw=2 et:
|
||||||
|
|
|
@ -1,43 +1,41 @@
|
||||||
# Maintainer: SJ_UnderWater
|
# Maintainer: Denis Yantarev <denis dot yantarev at gmail dot com>
|
||||||
# Based on netatalk package :
|
# Contributor: SJ_UnderWater
|
||||||
# Maintainer: Dominik Dingel <mail at wodar dot de>
|
# Contributor: Dominik Dingel <mail at wodar dot de>
|
||||||
# Contributor: William Udovich <nerdzrule7 at earthlink dot net>
|
# Contributor: William Udovich <nerdzrule7 at earthlink dot net>
|
||||||
# Contributor: Farhan Yousaf <farhany at xaviya dot com>
|
# Contributor: Farhan Yousaf <farhany at xaviya dot com>
|
||||||
|
|
||||||
pkgname=netatalk
|
pkgname=netatalk
|
||||||
pkgver=3.1.0
|
pkgver=3.1.1
|
||||||
pkgrel=1.1
|
pkgrel=1
|
||||||
pkgdesc='A kernel-level implementation of AFP services'
|
pkgdesc='A kernel-level implementation of AFP services'
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
url='http://netatalk.sourceforge.net'
|
url='http://netatalk.sourceforge.net'
|
||||||
license=('GPL')
|
license=('GPL')
|
||||||
depends=('avahi>=0.6' 'libldap' 'libgcrypt>=1.2.3' 'libevent' 'python' 'dbus-glib')
|
depends=('avahi>=0.6' 'libldap' 'libgcrypt>=1.2.3' 'libevent' 'python2' 'dbus-glib' 'python2-dbus')
|
||||||
replaces=('netatalk-git' 'netatalk2')
|
replaces=('netatalk-git' 'netatalk2')
|
||||||
backup=('etc/afp.conf'
|
backup=('etc/afp.conf'
|
||||||
'etc/extmap.conf')
|
'etc/extmap.conf')
|
||||||
options=('!libtool')
|
|
||||||
install=$pkgname.install
|
install=$pkgname.install
|
||||||
changelog=$pkgname.changelog
|
source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2
|
||||||
source=(http://softlayer-dal.dl.sourceforge.net/project/$pkgname/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2)
|
python2.patch)
|
||||||
md5sums=('30ae75457ed4d28ae1c8620d5579cd60')
|
md5sums=('1d9ed08871655776ec0e946f88749076'
|
||||||
|
'97bc0467dd8a866d9f0835d6440e3c19')
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
cd "$srcdir/$pkgname-$pkgver"
|
||||||
|
patch -p0 < "$srcdir/python2.patch"
|
||||||
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd $pkgname-$pkgver
|
cd "$srcdir/$pkgname-$pkgver"
|
||||||
msg2 'Fixing...'
|
CFLAGS="-Wno-unused-result -O2" \
|
||||||
: | tee test/afpd/Make*
|
./configure --prefix=/usr --localstatedir=/var/state --sysconfdir=/etc \
|
||||||
sed -i -e 's:AX_CHECK_DOCBOOK:[AX_CHECK_DOCBOOK]:' -e 's:"/lib/systemd:"/usr/lib/systemd:' -e 's/x"linux/x"generic/' macros/netatalk.m4
|
--sbindir=/usr/bin --with-init-style=systemd \
|
||||||
sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' {configure.ac,libevent/configure.in}
|
|
||||||
cp /usr/share/automake*/missing .
|
|
||||||
autoreconf -i >/dev/null
|
|
||||||
msg2 'Configuring...'
|
|
||||||
CFLAGS="-Wno-unused-result -O2" ./configure --prefix=/usr --localstatedir=/var/state --sysconfdir=/etc --sbindir=/usr/bin --with-init-style=systemd \
|
|
||||||
--with-cracklib --with-cnid-cdb-backend --enable-pgp-uam --with-libevent=no
|
--with-cracklib --with-cnid-cdb-backend --enable-pgp-uam --with-libevent=no
|
||||||
sed -i -e s/-Ino// -e s/-Lno// etc/netatalk/Makefile
|
make
|
||||||
msg2 'Making...'
|
|
||||||
make >/dev/null
|
|
||||||
}
|
}
|
||||||
|
|
||||||
package() {
|
package() {
|
||||||
cd $pkgname-$pkgver
|
cd "$srcdir/$pkgname-$pkgver"
|
||||||
msg2 'Building...'
|
make DESTDIR="$pkgdir" install
|
||||||
make DESTDIR="$pkgdir" install >/dev/null
|
|
||||||
}
|
}
|
||||||
|
|
|
@ -1,148 +0,0 @@
|
||||||
2013-11-06 SJ_UnderWater
|
|
||||||
|
|
||||||
* 3.1.0-1:
|
|
||||||
package update
|
|
||||||
|
|
||||||
2013-08-15 SJ_UnderWater
|
|
||||||
|
|
||||||
* 3.0.5-1:
|
|
||||||
package update
|
|
||||||
|
|
||||||
2013-06-03 SJ_UnderWater
|
|
||||||
|
|
||||||
* 3.0.4-2:
|
|
||||||
move sbindir
|
|
||||||
|
|
||||||
2013-05-26 SJ_UnderWater
|
|
||||||
|
|
||||||
* 3.0.4-1:
|
|
||||||
package update
|
|
||||||
minor fixes
|
|
||||||
dbus-glib dependency
|
|
||||||
|
|
||||||
2013-03-27 SJ_UnderWater
|
|
||||||
|
|
||||||
* 3.0.3-1:
|
|
||||||
package update
|
|
||||||
minor fixes
|
|
||||||
python dependency
|
|
||||||
|
|
||||||
2013-01-27 SJ_UnderWater
|
|
||||||
|
|
||||||
* 3.0.2-1:
|
|
||||||
package update
|
|
||||||
libevent fix
|
|
||||||
copy newer ./missing
|
|
||||||
|
|
||||||
2013-01-05 SJ_UnderWater
|
|
||||||
|
|
||||||
* 3.0.1-5:
|
|
||||||
fixed AM deprecations
|
|
||||||
minor install fix
|
|
||||||
|
|
||||||
2012-11-28 SJ_UnderWater
|
|
||||||
|
|
||||||
* 3.0.1-4 :
|
|
||||||
fixed mimic model
|
|
||||||
|
|
||||||
2012-10-08 SJ_UnderWater
|
|
||||||
|
|
||||||
* 3.0.1-3 :
|
|
||||||
moved systemd from /etc
|
|
||||||
better rc.d install test
|
|
||||||
|
|
||||||
2012-10-05 SJ_UnderWater
|
|
||||||
|
|
||||||
* 3.0.1-2 :
|
|
||||||
removed rc.d references
|
|
||||||
|
|
||||||
2012-10-04 SJ_UnderWater
|
|
||||||
|
|
||||||
* 3.0.1-1 :
|
|
||||||
new version
|
|
||||||
moved to systemd
|
|
||||||
moved state to /var/db
|
|
||||||
|
|
||||||
2012-07-14 SJ_UnderWater
|
|
||||||
|
|
||||||
* 3.0-3 :
|
|
||||||
moved localstate dir
|
|
||||||
to /etc for historical
|
|
||||||
reasons
|
|
||||||
|
|
||||||
2012-07-12 SJ_UnderWater
|
|
||||||
|
|
||||||
* 3.0-2 :
|
|
||||||
disable bundled libevent
|
|
||||||
|
|
||||||
2012-07-11 SJ_UnderWater
|
|
||||||
|
|
||||||
* 3.0-1 :
|
|
||||||
updated to new release
|
|
||||||
DDP moved to new pkg
|
|
||||||
|
|
||||||
2012-06-12 SJ_UnderWater
|
|
||||||
|
|
||||||
* 2.2.3-4 :
|
|
||||||
added kill timing
|
|
||||||
|
|
||||||
2012-06-04 SJ_UnderWater
|
|
||||||
|
|
||||||
* 2.2.3-3 :
|
|
||||||
removed conflicting files
|
|
||||||
|
|
||||||
2012-06-02 SJ_UnderWater
|
|
||||||
|
|
||||||
* 2.2.3-2 :
|
|
||||||
Missing UAM links
|
|
||||||
|
|
||||||
2012-05-29 SJ_UnderWater
|
|
||||||
|
|
||||||
* 2.2.3-1 :
|
|
||||||
updated package version
|
|
||||||
allowing headers and m4
|
|
||||||
|
|
||||||
2012-05-01 SJ_UnderWater
|
|
||||||
|
|
||||||
* 2.2.2-6 :
|
|
||||||
moved to .rc files
|
|
||||||
refactored PKGBUILD
|
|
||||||
install rc.d files
|
|
||||||
|
|
||||||
2012-04-25 SJ_UnderWater
|
|
||||||
|
|
||||||
* 2.2.2-5 :
|
|
||||||
init rebuild
|
|
||||||
fix dep check
|
|
||||||
fix get_pid
|
|
||||||
function relocation
|
|
||||||
|
|
||||||
2012-04-21 SJ_UnderWater
|
|
||||||
|
|
||||||
* 2.2.2-4 :
|
|
||||||
moved to package()
|
|
||||||
added backup
|
|
||||||
split backup
|
|
||||||
moved depends
|
|
||||||
|
|
||||||
2012-04-08 SJ_UnderWater
|
|
||||||
|
|
||||||
* 2.2.2-3 :
|
|
||||||
fixed extra dependencies
|
|
||||||
FHS compliance
|
|
||||||
NAMCAP checking
|
|
||||||
moved cups to optdepends
|
|
||||||
|
|
||||||
2012-04-07 SJ_UnderWater
|
|
||||||
|
|
||||||
* 2.2.2-2 :
|
|
||||||
added Install
|
|
||||||
changed "conflicts" with "replace"
|
|
||||||
cleaned up PKGBUILD
|
|
||||||
|
|
||||||
* 2.2.2-1 :
|
|
||||||
added ChangeLog.
|
|
||||||
moved to split package format
|
|
||||||
bidirectional dependency-checking
|
|
||||||
moved to release package format
|
|
||||||
PKGBUILD compliance
|
|
8
aur/netatalk/python2.patch
Normal file
8
aur/netatalk/python2.patch
Normal file
|
@ -0,0 +1,8 @@
|
||||||
|
--- contrib/shell_utils/afpstats.orig 2014-03-04 09:56:31.000000000 +0400
|
||||||
|
+++ contrib/shell_utils/afpstats 2014-03-04 09:57:23.000000000 +0400
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/bin/env python
|
||||||
|
+#!/usr/bin/env python2
|
||||||
|
|
||||||
|
usage = """Usage:
|
||||||
|
python afpstats.py
|
|
@ -1,19 +1,19 @@
|
||||||
# Maintainer: Kyle Keen <keenerd@gmail.com>
|
# Maintainer: Kyle Keen <keenerd@gmail.com>
|
||||||
# Contributor: Ali Gündüz <gndz.ali@gmail.com>
|
# Contributor: Ali Gündüz <gndz.ali@gmail.com>
|
||||||
pkgname=ps_mem
|
pkgname=ps_mem
|
||||||
pkgver=3.1
|
pkgver=3.2
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
pkgdesc="List processes by memory usage"
|
pkgdesc="List processes by memory usage"
|
||||||
arch=(any)
|
arch=('any')
|
||||||
url="http://www.pixelbeat.org/scripts/"
|
url="http://www.pixelbeat.org/scripts/"
|
||||||
license=('GPL')
|
license=('GPL')
|
||||||
# compatible with both py2 and py3
|
# compatible with both py2 and py3
|
||||||
depends=('python')
|
depends=('python')
|
||||||
#source=("https://raw.github.com/pixelb/scripts/master/scripts/$pkgname.py")
|
#source=("https://raw.github.com/pixelb/scripts/master/scripts/$pkgname.py")
|
||||||
source=("http://www.pixelbeat.org/scripts/$pkgname.py")
|
source=("http://www.pixelbeat.org/scripts/$pkgname.py")
|
||||||
md5sums=('536c0e561f27fb80cd11a8309946259a')
|
md5sums=('e1a18bfd753914632c107d51c2a6b09f')
|
||||||
|
|
||||||
build() {
|
package() {
|
||||||
cd "$srcdir"
|
cd "$srcdir"
|
||||||
install -Dm755 ps_mem.py "$pkgdir/usr/bin/$pkgname"
|
install -Dm755 ps_mem.py "$pkgdir/usr/bin/$pkgname"
|
||||||
}
|
}
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
# Contributor: Johannes Dewender arch at JonnyJD dot net
|
# Contributor: Johannes Dewender arch at JonnyJD dot net
|
||||||
pkgname=python2-configshell-fb
|
pkgname=python2-configshell-fb
|
||||||
_pkgname=configshell-fb
|
_pkgname=configshell-fb
|
||||||
pkgver=1.1.fb12
|
pkgver=1.1.fb13
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
epoch=
|
epoch=
|
||||||
pkgdesc="python framework for building simple CLI applications (free branch)"
|
pkgdesc="python framework for building simple CLI applications (free branch)"
|
||||||
|
@ -14,7 +14,7 @@ provides=('python2-configshell')
|
||||||
conflicts=('python2-configshell')
|
conflicts=('python2-configshell')
|
||||||
options=()
|
options=()
|
||||||
source=(https://fedorahosted.org/releases/t/a/targetcli-fb/$_pkgname-$pkgver.tar.gz)
|
source=(https://fedorahosted.org/releases/t/a/targetcli-fb/$_pkgname-$pkgver.tar.gz)
|
||||||
md5sums=('fc399f43f738d4f166b79a57128890ea')
|
md5sums=('a10cdd7bc418bb86c71aebff112bc63a')
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "$srcdir/$_pkgname-$pkgver"
|
cd "$srcdir/$_pkgname-$pkgver"
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
pkgname=sabnzbd
|
pkgname=sabnzbd
|
||||||
_pkgname=SABnzbd
|
_pkgname=SABnzbd
|
||||||
pkgver=0.7.16
|
pkgver=0.7.17
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
pkgdesc="A web-interface based binary newsgrabber with NZB file support"
|
pkgdesc="A web-interface based binary newsgrabber with NZB file support"
|
||||||
url="http://www.sabnzbd.org"
|
url="http://www.sabnzbd.org"
|
||||||
|
@ -14,7 +14,7 @@ install="${pkgname}.install"
|
||||||
backup=("etc/conf.d/sabnzbd" "opt/${pkgname}/${pkgname}.ini")
|
backup=("etc/conf.d/sabnzbd" "opt/${pkgname}/${pkgname}.ini")
|
||||||
source=("http://downloads.sourceforge.net/sabnzbdplus/${_pkgname}-${pkgver}-src.tar.gz"
|
source=("http://downloads.sourceforge.net/sabnzbdplus/${_pkgname}-${pkgver}-src.tar.gz"
|
||||||
"${pkgname}" "${pkgname}.desktop" "addnzb.sh" "nzb-2.png" "sab2_64.png" "x-nzb.xml" "${pkgname}.service" "${pkgname}.confd")
|
"${pkgname}" "${pkgname}.desktop" "addnzb.sh" "nzb-2.png" "sab2_64.png" "x-nzb.xml" "${pkgname}.service" "${pkgname}.confd")
|
||||||
md5sums=('13f7ff753e22e81fa6f7efab8c3c7213'
|
md5sums=('5056006fb15d6e62654af9f80955eba3'
|
||||||
'48d60a1c626503c7fef1bc5374390513'
|
'48d60a1c626503c7fef1bc5374390513'
|
||||||
'f9bd5485072714b11f8c30a28024dc4d'
|
'f9bd5485072714b11f8c30a28024dc4d'
|
||||||
'69b9bcbcf67ff3e7a4cdd9f26e001341'
|
'69b9bcbcf67ff3e7a4cdd9f26e001341'
|
||||||
|
|
|
@ -1,20 +0,0 @@
|
||||||
# Systemd configuration file for SABnzbd
|
|
||||||
# NOTE: Change user, group and port in sabnzbd.service as well.
|
|
||||||
# Due to a bug these cannot be loaded from this config file
|
|
||||||
|
|
||||||
# Set the protocol, IP and port
|
|
||||||
SABNZBD_PROTOCOL=http
|
|
||||||
SABNZBD_IP=127.0.0.1
|
|
||||||
SABNZBD_PORT=8080
|
|
||||||
|
|
||||||
# Set your default user/group(id), startarguments and your configfile
|
|
||||||
SABNZBD_DIR=/opt/sabnzbd
|
|
||||||
SABNZBD_ARGS=-f /opt/sabnzbd/sabnzbd.ini -s ${SABNZBD_IP}:${SABNZBD_PORT} -d
|
|
||||||
|
|
||||||
# Put the session keys from Config > General here
|
|
||||||
SABNZBD_KEY=
|
|
||||||
NZB_KEY=
|
|
||||||
|
|
||||||
# If you use a username and password, change the following variable to
|
|
||||||
# "user:pass@"
|
|
||||||
SABNZBD_USPW=
|
|
|
@ -5,7 +5,7 @@
|
||||||
|
|
||||||
pkgname=shairplay-git
|
pkgname=shairplay-git
|
||||||
_gitname=shairplay
|
_gitname=shairplay
|
||||||
pkgver=110.6e521c7
|
pkgver=120.193138f
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
pkgdesc='Apple airplay and raop protocol server'
|
pkgdesc='Apple airplay and raop protocol server'
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
|
|
Loading…
Reference in a new issue