mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
alarm/omxplayer-git to 397.cc646a4-1
This commit is contained in:
parent
432a4d9390
commit
fbcaf28fcd
3 changed files with 6 additions and 36 deletions
|
@ -1,7 +1,7 @@
|
|||
From cb18af829d01cbd89b2bb8785ee86f29b8659959 Mon Sep 17 00:00:00 2001
|
||||
From d2eb946d05e0a7a58c5d3a7b8ec4e1d1a836c2a8 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Wed, 24 Sep 2014 08:47:14 -0600
|
||||
Subject: [PATCH 1/2] alarm fixes
|
||||
Subject: [PATCH] alarm fixes
|
||||
|
||||
---
|
||||
Makefile | 30 ++++++++++--------------------
|
||||
|
@ -118,5 +118,5 @@ index 58e9560..4789f10 100644
|
|||
+LDFLAGS += -L/opt/vc/lib/
|
||||
+INCLUDES += -I/opt/vc/include -I/opt/vc/include/interface/vmcs_host/linux -I/opt/vc/include/interface/vcos/pthreads -I/usr/include/freetype2 -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include
|
||||
--
|
||||
2.1.0
|
||||
2.2.1
|
||||
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
From 0cc831816f5b242e0ad139d363685149b6464091 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Wed, 24 Sep 2014 08:47:43 -0600
|
||||
Subject: [PATCH 2/2] ffmpeg 2.4 fix
|
||||
|
||||
---
|
||||
DllAvFilter.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/DllAvFilter.h b/DllAvFilter.h
|
||||
index 8149274..313e078 100644
|
||||
--- a/DllAvFilter.h
|
||||
+++ b/DllAvFilter.h
|
||||
@@ -124,7 +124,7 @@ public:
|
||||
}
|
||||
virtual int avfilter_graph_parse(AVFilterGraph *graph, const char *filters, AVFilterInOut **inputs, AVFilterInOut **outputs, void *log_ctx)
|
||||
{
|
||||
- return ::avfilter_graph_parse(graph, filters, inputs, outputs, log_ctx);
|
||||
+ return ::avfilter_graph_parse(graph, filters, *inputs, *outputs, log_ctx);
|
||||
}
|
||||
virtual int avfilter_graph_config(AVFilterGraph *graphctx, void *log_ctx)
|
||||
{
|
||||
--
|
||||
2.1.0
|
||||
|
|
@ -5,7 +5,7 @@
|
|||
buildarch=16
|
||||
|
||||
pkgname=omxplayer-git
|
||||
pkgver=380.6ee9a0a
|
||||
pkgver=397.cc646a4
|
||||
pkgrel=1
|
||||
pkgdesc="omxplayer is a command line media player for the RaspberryPi"
|
||||
arch=('arm' 'armv6h')
|
||||
|
@ -17,11 +17,9 @@ optdepends=('ttf-freefont')
|
|||
provides=(omxplayer)
|
||||
conflicts=('omxplayer' 'omxplayer-bin')
|
||||
source=('git://github.com/popcornmix/omxplayer.git'
|
||||
'0001-alarm-fixes.patch'
|
||||
'0002-ffmpeg-2.4-fix.patch')
|
||||
'0001-alarm-fixes.patch')
|
||||
md5sums=('SKIP'
|
||||
'825bb619d32a3ba9f8aff81fa329d87e'
|
||||
'c80b6c4578dd6a48b7d5bd0da650843e')
|
||||
'ecf5782b2a3bffd4000f083e98a21478')
|
||||
|
||||
pkgver() {
|
||||
cd omxplayer
|
||||
|
@ -32,9 +30,6 @@ prepare() {
|
|||
cd "${srcdir}/omxplayer"
|
||||
|
||||
git apply ../0001-alarm-fixes.patch
|
||||
git apply ../0002-ffmpeg-2.4-fix.patch
|
||||
|
||||
sed 's|truetype/freefont|TTF|g' -i omxplayer.cpp
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue