mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/digikam to 5.1.0-1
This commit is contained in:
parent
853790255a
commit
fc286ef64a
2 changed files with 31 additions and 19 deletions
|
@ -9,29 +9,32 @@
|
|||
|
||||
pkgbase=digikam
|
||||
pkgname=('digikam' 'kipi-plugins')
|
||||
_pkgver=5.0.0
|
||||
_pkgver=5.1.0
|
||||
pkgver=${_pkgver//-/_}
|
||||
pkgrel=1
|
||||
pkgdesc="Digital photo management application for KDE"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('GPL')
|
||||
url="http://www.digikam.org/"
|
||||
makedepends=('extra-cmake-modules' 'libkipi' 'libksane' 'liblqr' 'opencv' 'boost' 'grantlee-qt5'
|
||||
'libgpod' 'hugin' 'opencv' 'doxygen' 'lensfun' 'imagemagick' 'eigen' 'libusb' 'kio' 'kdoctools' 'marble'
|
||||
'kfilemetadata' 'akonadi-contact' 'qt5-multimedia' 'kdesignerplugin' 'threadweaver' 'kcalcore'
|
||||
'knotifyconfig' 'kdelibs4support' 'qt5-xmlpatterns' 'libmediawiki' 'libkvkontakte' 'kqoauth')
|
||||
source=("http://download.kde.org/stable/${pkgname}/${pkgname}-${_pkgver}.tar.xz"
|
||||
makedepends=('extra-cmake-modules' 'libkipi' 'libksane' 'liblqr' 'opencv' 'boost'
|
||||
'opencv' 'doxygen' 'lensfun' 'eigen' 'kdoctools' 'marble' 'kdesignerplugin'
|
||||
'kfilemetadata' 'akonadi-contact' 'qt5-multimedia' 'threadweaver' 'kcalcore'
|
||||
'knotifyconfig' 'libmediawiki' 'libkvkontakte')
|
||||
source=("http://download.kde.org/stable/${pkgname}/${pkgname}-${_pkgver}.tar.xz" digikam-5.1-fix-build.patch
|
||||
'0001-optionally-enable-OpenGL.patch')
|
||||
sha1sums=('e0dec2eba9ab3a51d632b69b3dd6daf8dca64a45'
|
||||
sha1sums=('87a843c39f45b8704ead6e6029e52fb03ee44680'
|
||||
'5b6644c8b5534a1712f46fc84948de9a0039a601'
|
||||
'2711c73bdecbf355d4b8be1fa0c46be2e0e22df8')
|
||||
|
||||
prepare() {
|
||||
mkdir -p build
|
||||
|
||||
# Build fails
|
||||
sed -e '/add_subdirectory(showfoto)/d' -i $pkgname-${_pkgver}/doc-translated/digikam/CMakeLists.txt
|
||||
cd $pkgname-$pkgver
|
||||
# Fix build on i686
|
||||
patch -p1 -i ../digikam-5.1-fix-build.patch
|
||||
|
||||
patch -p1 -d ${pkgname}-${_pkgver}/core -i ${srcdir}/0001-optionally-enable-OpenGL.patch
|
||||
# OpenGL switch
|
||||
patch -p1 -d core -i ${srcdir}/0001-optionally-enable-OpenGL.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -56,7 +59,8 @@ package_digikam() {
|
|||
pkgdesc="Digital photo management application for KDE"
|
||||
depends=('liblqr' 'libkipi' 'lensfun' 'opencv' 'akonadi-contact'
|
||||
'knotifyconfig' 'libksane' 'kfilemetadata' 'qt5-multimedia' 'marble' 'threadweaver' 'kcalcore')
|
||||
optdepends=('kipi-plugins: more tools and plugins')
|
||||
optdepends=('kipi-plugins: export to various online services'
|
||||
'hugin: panorama tool')
|
||||
|
||||
cd build/core
|
||||
make DESTDIR="$pkgdir" install
|
||||
|
@ -75,14 +79,7 @@ package_kipi-plugins() {
|
|||
pkgdesc="A collection of plugins extending the KDE graphics and image applications as digiKam"
|
||||
depends=('kio' 'libkipi')
|
||||
optdepends=('libmediawiki: MediaWiki Export plugin'
|
||||
'libkvkontakte: VKontakte.ru Exporter plugin'
|
||||
'libgpod: iPodExport plugin'
|
||||
'opencv: Remove Red Eyes plugin'
|
||||
'imagemagick: Video SlideShow plugin'
|
||||
'qt5-gstreamer: Video SlideShow plugin'
|
||||
'threadweaver: panorama plugin'
|
||||
'hugin: panorama plugin'
|
||||
'kqoauth: OAuth authentication for imgur')
|
||||
'libkvkontakte: VKontakte.ru Exporter plugin')
|
||||
|
||||
cd build/extra
|
||||
make DESTDIR="$pkgdir" install
|
||||
|
|
15
extra/digikam/digikam-5.1-fix-build.patch
Normal file
15
extra/digikam/digikam-5.1-fix-build.patch
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- digikam-5.1.0/core/libs/rawengine/libraw/libraw/libraw_types.h.orig 2016-08-09 15:05:10.449224741 +0000
|
||||
+++ digikam-5.1.0/core/libs/rawengine/libraw/libraw/libraw_types.h 2016-08-09 15:05:50.725789944 +0000
|
||||
@@ -618,10 +618,10 @@
|
||||
#elif defined(_M_X64) || defined(__amd64__)
|
||||
#define LibRawBigEndian 0
|
||||
|
||||
-#elif defined(__LITTLE_ENDIAN__)
|
||||
+#elif __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__
|
||||
#define LibRawBigEndian 0
|
||||
|
||||
-#elif defined(__BIG_ENDIAN__)
|
||||
+#elif __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__
|
||||
#define LibRawBigEndian 1
|
||||
#elif defined(_ARM_)
|
||||
#define LibRawBigEndian 0
|
Loading…
Reference in a new issue