extra/chromium to 44.0.2403.157-1

This commit is contained in:
David Beauchamp 2015-08-21 09:01:40 -04:00
parent 2f73d444a0
commit fcab7194b9
2 changed files with 43 additions and 2 deletions

View file

@ -0,0 +1,36 @@
From 241364c6f4d44165ce2dc707b9ad141dcc880d1b Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Sat, 27 Jun 2015 13:29:52 -0700
Subject: [PATCH] Demand for newer POSIX macro
Reason for change: Define _POSIX_C_SOURCE such that it demands correct
posix interfaces, netdb.h declares interfaces such as
getaddrinfo if __USE_POSIX, i.e. POSIX.1:1990 or later.
However, these interfaces were new in the 2001 edition of POSIX
therefore ask for Extension from POSIX.1:2001 since we use addrinfo
structure here.
Change-Id: Icb1c92745d1a0ca958108ae80c270c630628729e
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Reviewed-on: https://boringssl-review.googlesource.com/5253
Reviewed-by: Adam Langley <agl@google.com>
---
crypto/bio/socket_helper.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/crypto/bio/socket_helper.c b/crypto/bio/socket_helper.c
index b1cdd1a..481278f 100644
--- a/crypto/bio/socket_helper.c
+++ b/crypto/bio/socket_helper.c
@@ -12,7 +12,7 @@
* OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
* CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. */
-#define _POSIX_SOURCE
+#define _POSIX_C_SOURCE 200112L
#include <openssl/bio.h>
#include <openssl/err.h>
--
2.5.0

View file

@ -21,7 +21,7 @@
buildarch=4
pkgname=chromium
pkgver=44.0.2403.155
pkgver=44.0.2403.157
pkgrel=1
_launcher_ver=2
pkgdesc="The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser"
@ -48,8 +48,9 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
arm-webrtc-fix.patch
chromium-arm-r0.patch
v6-ffmpeg.patch
0001-Demand-for-newer-POSIX-macro.patch
chromium-widevine.patch)
sha256sums=('eba271c210a020dd61b72c940abeecdafc562a1d15fb45615dda72bcb6219f3c'
sha256sums=('e1a4d5fd030842684d69e840d411f45b4e5ccf377d7f131fe37ce1a13439f3b4'
'7f91c81721092d707d7b94e6555a48bc7fd0bc0e1174df4649bdcd745930e52f'
'028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9'
'46daf921ed7eaab175f5a86b09357c69c33a10ffe1d4e7c24476af510c1b28d0'
@ -58,6 +59,7 @@ sha256sums=('eba271c210a020dd61b72c940abeecdafc562a1d15fb45615dda72bcb6219f3c'
'9db0f01517c52e3236ff52e8a664840542a19144a54923ae6aabea3dcfa92c52'
'df4be49770d508b772f98eda9fc5f37fa71d4c0459437e12f7f3db5892aa1611'
'3fbabcbd512494b529e0a0e17560735887acf2291a74653750f9b29f5d45774d'
'd908939b10161efe658f0f82d2c132bf28dff54e08f02c6fed93815c3656f328'
'379b746e187de28f80f5a7cd19edcfa31859656826f802a1ede054fcb6dfb221')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
@ -78,6 +80,9 @@ prepare() {
# https://code.google.com/p/chromium/issues/detail?id=490260
patch -Np1 -i ../0001-Use-the-correct-URL-for-ERR_SSL_WEAK_SERVER_EPHEMERA.patch
# Fix BoringSSL build with glibc 2.22 (FS#45965)
patch -Np1 -d third_party/boringssl/src < ../0001-Demand-for-newer-POSIX-macro.patch
# Enable support for the Widevine CDM plugin
# The actual libraries are not included, but can be copied over from Chrome:
# libwidevinecdmadapter.so