extra/js52 to 52.9.0-4

This commit is contained in:
Kevin Mihelich 2020-02-13 19:36:07 +00:00
parent a19ca7e3e3
commit fcbc92b99b
3 changed files with 4 additions and 40 deletions

View file

@ -5,7 +5,7 @@
pkgname=js52 pkgname=js52
pkgver=52.9.0 pkgver=52.9.0
pkgrel=3 pkgrel=4
pkgdesc="JavaScript interpreter and libraries - Version 52" pkgdesc="JavaScript interpreter and libraries - Version 52"
arch=(x86_64) arch=(x86_64)
url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey" url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey"
@ -16,12 +16,10 @@ _relver=${pkgver}esr
source=(https://archive.mozilla.org/pub/firefox/releases/$_relver/source/firefox-$_relver.source.tar.xz source=(https://archive.mozilla.org/pub/firefox/releases/$_relver/source/firefox-$_relver.source.tar.xz
mozjs52-copy-headers.patch mozjs52-copy-headers.patch
mozjs52-disable-mozglue.patch mozjs52-disable-mozglue.patch
mozjs52-fix-soname.patch mozjs52-disable-wformat.patch)
no-error.diff)
sha256sums=('c01d09658c53c1b3a496e353a24dad03b26b81d3b1d099abc26a06f81c199dd6' sha256sums=('c01d09658c53c1b3a496e353a24dad03b26b81d3b1d099abc26a06f81c199dd6'
'c5b3a88e4d10ef149aba6fc48d431db54ff266323fa22a5d549028fd794423cc' 'c5b3a88e4d10ef149aba6fc48d431db54ff266323fa22a5d549028fd794423cc'
'5a84f02521f37de873991dd360a4c4bfdbdd2fb4a218e11be73f9cbbf02050e8' '5a84f02521f37de873991dd360a4c4bfdbdd2fb4a218e11be73f9cbbf02050e8'
'728456fd9e66b69d6e0688c75e50091dc56735004ecf5f649212a83fe3087df1'
'4c5a1662e36c6a5a11db0263bb264d104ff801789d5b6bc6a6104439457afb90') '4c5a1662e36c6a5a11db0263bb264d104ff801789d5b6bc6a6104439457afb90')
prepare() { prepare() {
@ -29,12 +27,11 @@ prepare() {
mkdir obj mkdir obj
# https://salsa.debian.org/gnome-team/mozjs52/tree/debian/master/debian/patches # https://salsa.debian.org/gnome-team/mozjs52/tree/debian/master/debian/patches
patch -Np1 -i ../mozjs52-fix-soname.patch
patch -Np1 -i ../mozjs52-copy-headers.patch patch -Np1 -i ../mozjs52-copy-headers.patch
patch -Np1 -i ../mozjs52-disable-mozglue.patch patch -Np1 -i ../mozjs52-disable-mozglue.patch
# New errors in test code as of GCC 9 # New errors in test code as of GCC 9
patch -Np1 -i ../no-error.diff patch -Np1 -i ../mozjs52-disable-wformat.patch
} }
build() { build() {
@ -42,6 +39,7 @@ build() {
--prefix=/usr --prefix=/usr
--disable-debug --disable-debug
--disable-debug-symbols --disable-debug-symbols
--disable-jemalloc
--disable-strip --disable-strip
--enable-optimize="-O2" --enable-optimize="-O2"
--enable-pie --enable-pie

View file

@ -1,34 +0,0 @@
diff --git a/config/rules.mk b/config/rules.mk
--- a/config/rules.mk
+++ b/config/rules.mk
@@ -418,7 +418,7 @@ endif # AIX
#
# Linux: add -Bsymbolic flag for components
#
-ifeq ($(OS_ARCH),Linux)
+#ifeq ($(OS_ARCH),Linux)
ifdef IS_COMPONENT
EXTRA_DSO_LDOPTS += -Wl,-Bsymbolic
endif
@@ -426,7 +426,8 @@ ifdef LD_VERSION_SCRIPT
EXTRA_DSO_LDOPTS += -Wl,--version-script,$(LD_VERSION_SCRIPT)
EXTRA_DEPS += $(LD_VERSION_SCRIPT)
endif
-endif
+#endif
+EXTRA_DSO_LDOPTS += -Wl,-soname,lib$(JS_LIBRARY_NAME).so.0
ifdef SYMBOLS_FILE
ifeq ($(OS_TARGET),WINNT)
diff --git a/js/src/Makefile.in b/js/src/Makefile.in
--- a/js/src/Makefile.in
+++ b/js/src/Makefile.in
@@ -222,6 +222,8 @@ ifneq (,$(REAL_LIBRARY))
endif
ifneq (,$(SHARED_LIBRARY))
$(SYSINSTALL) $(SHARED_LIBRARY) $(DESTDIR)$(libdir)
+ mv -f $(DESTDIR)$(libdir)/$(SHARED_LIBRARY) $(DESTDIR)$(libdir)/$(SHARED_LIBRARY).0
+ ln -s $(SHARED_LIBRARY).0 $(DESTDIR)$(libdir)/$(SHARED_LIBRARY)
ifeq ($(OS_ARCH),Darwin)
install_name_tool -id $(abspath $(libdir)/$(SHARED_LIBRARY)) $(DESTDIR)$(libdir)/$(SHARED_LIBRARY)
endif