core/linux-clearfog to 3.10.94-1

This commit is contained in:
moonman 2015-12-29 17:55:03 -07:00
parent 6a1dd31760
commit fd3a0eb2d1
4 changed files with 811 additions and 623 deletions

View file

@ -5,10 +5,10 @@ buildarch=4
pkgbase=linux-clearfog
pkgname=('linux-clearfog' 'linux-headers-clearfog')
# pkgname=linux-custom # Build kernel with a different name
_commit=902739f3353150ac9eb69ad995098f3079d862a3
_commit=68ab517481e943505e871285acba58252247a42b
_srcname=linux-armada38x-${_commit}
_kernelname=${pkgname#linux}
pkgver=3.10.70
pkgver=3.10.94
pkgrel=1
cryptodev_commit=da730106c2558c8e0c8e1b1b1812d32ef9574ab7
bfqver=v7r8
@ -18,39 +18,23 @@ url="http://www.kernel.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'uboot-mkimage' 'git' 'lzop')
options=('!strip')
source=("linux-${_commit}::https://github.com/SolidRun/linux-armada38x/archive/${_commit}.tar.gz"
source=("linux-${_commit}::https://github.com/moonman/linux-armada38x/archive/${_commit}.tar.gz"
"cryptodev-${cryptodev_commit}.tar.gz::https://github.com/cryptodev-linux/cryptodev-linux/archive/${cryptodev_commit}.tar.gz"
'gcc5-use-std89.patch'
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.10.x"
"ftp://teambelgium.net/bfq/patches/${pkgver:0:4}.8+-${bfqver}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-${pkgver:0:4}.8.patch"
"ftp://teambelgium.net/bfq/patches/${pkgver:0:4}.8+-${bfqver}/0002-block-introduce-the-BFQ-${bfqver}-I-O-sched-for-${pkgver:0:4}.8.patch"
"ftp://teambelgium.net/bfq/patches/${pkgver:0:4}.8+-${bfqver}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for-${pkgver:0:4}.8+.patch"
'config')
md5sums=('be3d33d247fbbebab6096c3491ddc93d'
md5sums=('af41ba4dce094288c952d8ca1a29dc2a'
'8fb4d3b7cc970351f3b5078b7893a107'
'407619b134dd00b453ebba9f23dcabf5'
'SKIP'
'003f1554be6b672100d2f2401a574d92'
'12ffe57584b4f2adcc3e184dc6948772'
'9e78f9f5364f8ebb981aeb235dcb7415'
'67cfe1dcae977545ee2d3ceaa775514b')
'b446653b0146fa2f944f7126f8e04020')
prepare() {
cd "${srcdir}/${_srcname}"
patch -Np1 -i ../gcc5-use-std89.patch
msg2 "Copying aufs3 patches into the kernel source tree"
cp -ru "${srcdir}/aufs3-standalone/"{Documentation,fs} "${srcdir}/${_srcname}/"
cp -ru "${srcdir}/aufs3-standalone/include/uapi/linux/aufs_type.h" "${srcdir}/${_srcname}/include/"{linux/,uapi/linux/}
msg2 "Applying aufs3 patches"
patch -Np1 -i ../aufs3-standalone/aufs3-kbuild.patch
patch -Np1 -i ../aufs3-standalone/aufs3-base.patch
patch -Np1 -i ../aufs3-standalone/aufs3-mmap.patch
patch -Np1 -i ../aufs3-standalone/aufs3-standalone.patch
msg2 "Add BFQ patches"
patch -Np1 -i "${srcdir}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-${pkgver:0:4}.8.patch"
patch -Np1 -i "${srcdir}/0002-block-introduce-the-BFQ-${bfqver}-I-O-sched-for-${pkgver:0:4}.8.patch"

File diff suppressed because it is too large Load diff

View file

@ -1,36 +0,0 @@
Signed-off-by: Sasha Levin <sasha.levin at oracle.com>
Singed-off-by: Kirill A. Shutemov <kirill.shutemov at linux.intel.com>
Signed-off-by: Linus Torvalds <torvalds at linux-foundation.org>
[ kamal: backport to 3.13-stable: context ]
Signed-off-by: Kamal Mostafa <kamal at canonical.com>
---
Makefile | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/Makefile b/Makefile
index 1b0c93c..6f16559 100644
--- a/Makefile
+++ b/Makefile
@@ -244,7 +244,7 @@ CONFIG_SHELL := $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
HOSTCC = gcc
HOSTCXX = g++
-HOSTCFLAGS = -Wall -Wmissing-prototypes -Wstrict-prototypes -O2 -fomit-frame-pointer
+HOSTCFLAGS = -Wall -Wmissing-prototypes -Wstrict-prototypes -O2 -fomit-frame-pointer -std=gnu89
HOSTCXXFLAGS = -O2
# Decide whether to build built-in, modular, or both.
@@ -376,7 +376,9 @@ KBUILD_CFLAGS := -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs \
-fno-strict-aliasing -fno-common \
-Werror-implicit-function-declaration \
-Wno-format-security \
- -fno-delete-null-pointer-checks
+ -fno-delete-null-pointer-checks \
+ -std=gnu89
+
KBUILD_AFLAGS_KERNEL :=
KBUILD_CFLAGS_KERNEL :=
KBUILD_AFLAGS := -D__ASSEMBLY__
--
1.9.1

View file

@ -2,7 +2,7 @@
# arg 2: the old package version
KERNEL_NAME=-clearfog
KERNEL_VERSION=3.10.70-1.5-ARCH
KERNEL_VERSION=3.10.94-1-ARCH
post_install () {
# updating module dependencies