community/opencolorio to 2.0.0-2

This commit is contained in:
Kevin Mihelich 2021-04-28 14:11:54 +00:00
parent 87769297b2
commit fd59c6215e
3 changed files with 186 additions and 99 deletions

View file

@ -1,98 +0,0 @@
From 8d48ee8da42de2d878db7b42586db8b3c67f83e1 Mon Sep 17 00:00:00 2001
From: Jonathan Scruggs <j.scruggs@gmail.com>
Date: Fri, 19 Jan 2018 10:17:18 +0000
Subject: [PATCH] Use GNUInstallDirs and fix install location for cmake files
(#501)
GNUInstallDirs is supported on all platforms and variables are set
to the standard GNU locations.
Fix the location where the .cmake files are installed.
Signed-off by: Jonathan Scruggs <j.scruggs@gmail.com>
---
CMakeLists.txt | 9 +++++----
docs/CMakeLists.txt | 4 ++--
export/pkgconfig/OpenColorIO.pc.in | 6 ++----
3 files changed, 9 insertions(+), 10 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a399d57a..473f1b79 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -60,6 +60,7 @@ endif()
include(ParseArguments)
include(OCIOMacros)
include(ExternalProject)
+include(GNUInstallDirs)
enable_language(CXX)
@@ -558,7 +559,7 @@ endif()
configure_file(${CMAKE_SOURCE_DIR}/share/ocio/setup_ocio.sh.in
${CMAKE_CURRENT_BINARY_DIR}/share/ocio/setup_ocio.sh @ONLY)
-INSTALL(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/share/ocio/setup_ocio.sh DESTINATION share/ocio/)
+INSTALL(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/share/ocio/setup_ocio.sh DESTINATION ${CMAKE_INSTALL_DATADIR}/ocio/)
###############################################################################
### CPACK ###
@@ -623,7 +624,7 @@ if(TARGET OpenColorIO_STATIC)
set(OCIO_STATIC_COMPILE_DEFINITIONS )
endif()
endif()
-install(EXPORT OpenColorIO DESTINATION cmake)
+install(EXPORT OpenColorIO DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/OpenColorIO)
file(WRITE "${CMAKE_BINARY_DIR}/OpenColorIOConfig.cmake"
"
get_filename_component(OpenColorIO_DIR \"\${CMAKE_CURRENT_LIST_FILE}\" PATH)
@@ -635,7 +636,7 @@ file(WRITE "${CMAKE_BINARY_DIR}/OpenColorIOConfig.cmake"
## targets libraries + associated definitions
if(NOT TARGET OpenColorIO)
- include(\"\${OpenColorIO_DIR}/cmake/OpenColorIO.cmake\") ## thanks to imported target
+ include(\"\${OpenColorIO_DIR}/${CMAKE_INSTALL_LIBDIR}/cmake/OpenColorIO/OpenColorIO.cmake\") ## thanks to imported target
if(TARGET OpenColorIO AND NOT OpenColorIO_USE_STATIC)
message(STATUS \"shared target OpenColorIO : see OpenColorIO_LIBRARY\")
set(OpenColorIO_LIBRARY OpenColorIO)
@@ -673,4 +674,4 @@ file(WRITE "${CMAKE_BINARY_DIR}/OpenColorIOConfig.cmake"
message(STATUS OPENCOLORIO_FOUND=\${OPENCOLORIO_FOUND})
"
)
-install(FILES "${CMAKE_BINARY_DIR}/OpenColorIOConfig.cmake" DESTINATION .)
+install(FILES "${CMAKE_BINARY_DIR}/OpenColorIOConfig.cmake" DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/OpenColorIO)
diff --git a/docs/CMakeLists.txt b/docs/CMakeLists.txt
index 5970db64..4d97f72c 100644
--- a/docs/CMakeLists.txt
+++ b/docs/CMakeLists.txt
@@ -138,7 +138,7 @@ add_custom_target(doc ALL
add_dependencies(doc Sphinx)
install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/build-html/
- DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/OpenColorIO/html
+ DESTINATION ${CMAKE_INSTALL_DOCDIR}/html
PATTERN .* EXCLUDE
)
@@ -173,6 +173,6 @@ if(PDFLATEX_COMPILER)
add_dependencies(pdf latex)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/build-latex/OpenColorIO.pdf
- DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/OpenColorIO/)
+ DESTINATION ${CMAKE_INSTALL_DOCDIR})
endif()
diff --git a/export/pkgconfig/OpenColorIO.pc.in b/export/pkgconfig/OpenColorIO.pc.in
index 81ab4ce3..c4553a4f 100644
--- a/export/pkgconfig/OpenColorIO.pc.in
+++ b/export/pkgconfig/OpenColorIO.pc.in
@@ -1,7 +1,5 @@
-prefix=@CMAKE_INSTALL_PREFIX@
-exec_prefix=@CMAKE_INSTALL_EXEC_PREFIX@
-includedir=${prefix}/include
-libdir=${exec_prefix}/lib@LIB_SUFFIX@
+libdir=@CMAKE_INSTALL_FULL_LIBDIR@
+includedir=@CMAKE_INSTALL_FULL_INCLUDEDIR@
Name: OpenColorIO
Description: A color management framework for visual effects and animation

View file

@ -6,7 +6,7 @@
pkgname=opencolorio
pkgver=2.0.0
pkgrel=1
pkgrel=2
pkgdesc="A color management framework for visual effects and animation"
arch=('x86_64')
url="https://opencolorio.org"
@ -15,11 +15,14 @@ depends=('freeglut' 'glew' 'lcms2' 'tinyxml' 'yaml-cpp' 'openexr' 'pystring')
makedepends=('boost' 'cmake' 'python' 'pybind11' 'ninja')
optdepends=('python: python bindings')
source=($pkgname-$pkgver.tar.gz::https://github.com/AcademySoftwareFoundation/OpenColorIO/archive/v$pkgver.tar.gz
opencolorio-openexr3.patch
0001-remove-duplicate-ProcessorCache-declaration.patch)
sha512sums=('7110a1a30a5fa64b81d7fc5e33234673aaddbad5e19ce7f21436c590edd7d2ce767650c9a934011a96e53132c030bd0b654fcf93ad79c1bfc8c050762c57f6d0'
'269a86e4020d272b64af631ba01f9b1e644bde119e9bfb1d5ec3fd62579d5d3f7ab31295fb6cffc51d7349c469e2ca6e12f69310317266eda602541e9fcff94f'
'204c51ebf446e5fe83a9fa094b6037f1a5c0bb5240395176bed52f6b9f3082c3df13a4dc2589a924e1084ceea0692af9dd95a01d9461cd7d3bff511c66aba648')
prepare() {
patch -d OpenColorIO-$pkgver -p1 < opencolorio-openexr3.patch
cd OpenColorIO-$pkgver
patch -p1 -i ../0001-remove-duplicate-ProcessorCache-declaration.patch
}

View file

@ -0,0 +1,182 @@
diff --git a/share/cmake/modules/FindExtPackages.cmake b/share/cmake/modules/FindExtPackages.cmake
index c98e0af3..5f685935 100644
--- a/share/cmake/modules/FindExtPackages.cmake
+++ b/share/cmake/modules/FindExtPackages.cmake
@@ -34,7 +34,7 @@ find_package(yaml-cpp 0.6.3 REQUIRED)
# Half (OpenEXR/IlmBase)
# https://github.com/openexr/openexr
-find_package(Half 2.4.0 REQUIRED)
+find_package(Imath 3.0 REQUIRED)
# pystring
# https://github.com/imageworks/pystring
diff --git a/src/OpenColorIO/BitDepthUtils.h b/src/OpenColorIO/BitDepthUtils.h
index a8b3cbd9..bb0163bf 100644
--- a/src/OpenColorIO/BitDepthUtils.h
+++ b/src/OpenColorIO/BitDepthUtils.h
@@ -7,7 +7,7 @@
#include <OpenColorIO/OpenColorIO.h>
-#include "OpenEXR/half.h"
+#include "Imath/half.h"
namespace OCIO_NAMESPACE
diff --git a/src/OpenColorIO/CMakeLists.txt b/src/OpenColorIO/CMakeLists.txt
index 2ce801e6..824f8a98 100755
--- a/src/OpenColorIO/CMakeLists.txt
+++ b/src/OpenColorIO/CMakeLists.txt
@@ -207,7 +207,7 @@ target_link_libraries(OpenColorIO
public_api
PRIVATE
expat::expat
- IlmBase::Half
+ Imath::Imath
pystring::pystring
sampleicc::sampleicc
utils::strings
diff --git a/src/OpenColorIO/MathUtils.h b/src/OpenColorIO/MathUtils.h
index 309c6244..0873d490 100644
--- a/src/OpenColorIO/MathUtils.h
+++ b/src/OpenColorIO/MathUtils.h
@@ -9,7 +9,7 @@
#include <OpenColorIO/OpenColorIO.h>
-#include "OpenEXR/half.h"
+#include "Imath/half.h"
namespace OCIO_NAMESPACE
{
diff --git a/src/OpenColorIO/ops/range/RangeOp.cpp b/src/OpenColorIO/ops/range/RangeOp.cpp
index 9ec863e2..444dac75 100644
--- a/src/OpenColorIO/ops/range/RangeOp.cpp
+++ b/src/OpenColorIO/ops/range/RangeOp.cpp
@@ -7,7 +7,7 @@
#include <OpenColorIO/OpenColorIO.h>
#include "GpuShaderUtils.h"
-#include "OpenEXR/half.h"
+#include "Imath/half.h"
#include "HashUtils.h"
#include "MathUtils.h"
#include "ops/lut1d/Lut1DOpData.h"
diff --git a/src/OpenColorIO/transforms/builtins/ACES.cpp b/src/OpenColorIO/transforms/builtins/ACES.cpp
index 20968c0d..9ee2ac27 100644
--- a/src/OpenColorIO/transforms/builtins/ACES.cpp
+++ b/src/OpenColorIO/transforms/builtins/ACES.cpp
@@ -6,7 +6,7 @@
#include <OpenColorIO/OpenColorIO.h>
-#include "OpenEXR/half.h"
+#include "Imath/half.h"
#include "ops/fixedfunction/FixedFunctionOp.h"
#include "ops/gradingrgbcurve/GradingRGBCurveOp.h"
#include "ops/log/LogOp.h"
diff --git a/src/OpenColorIO/transforms/builtins/OpHelpers.cpp b/src/OpenColorIO/transforms/builtins/OpHelpers.cpp
index 04b8fbd4..288ca566 100644
--- a/src/OpenColorIO/transforms/builtins/OpHelpers.cpp
+++ b/src/OpenColorIO/transforms/builtins/OpHelpers.cpp
@@ -4,7 +4,7 @@
#include <OpenColorIO/OpenColorIO.h>
-#include "OpenEXR/half.h"
+#include "Imath/half.h"
#include "ops/lut1d/Lut1DOp.h"
#include "transforms/builtins/OpHelpers.h"
diff --git a/src/apps/ocioconvert/CMakeLists.txt b/src/apps/ocioconvert/CMakeLists.txt
index 68a5db17..6fea394a 100755
--- a/src/apps/ocioconvert/CMakeLists.txt
+++ b/src/apps/ocioconvert/CMakeLists.txt
@@ -27,7 +27,7 @@ set_target_properties(ocioconvert PROPERTIES
target_link_libraries(ocioconvert
PRIVATE
apputils
- IlmBase::Half
+ Imath::Imath
${OCIO_GL_LIB}
oiiohelpers
OpenColorIO
diff --git a/src/apps/ocioconvert/main.cpp b/src/apps/ocioconvert/main.cpp
index b56d4999..7e8af7d0 100644
--- a/src/apps/ocioconvert/main.cpp
+++ b/src/apps/ocioconvert/main.cpp
@@ -24,7 +24,7 @@ namespace OIIO = OIIO_NAMESPACE;
#endif // OCIO_GPU_ENABLED
#include "oiiohelpers.h"
-#include "OpenEXR/half.h"
+#include "Imath/half.h"
// Array of non OpenColorIO arguments.
diff --git a/src/apps/ocioperf/CMakeLists.txt b/src/apps/ocioperf/CMakeLists.txt
index 69e9ba4c..bcbe47be 100644
--- a/src/apps/ocioperf/CMakeLists.txt
+++ b/src/apps/ocioperf/CMakeLists.txt
@@ -20,7 +20,7 @@ set_target_properties(ocioperf PROPERTIES
target_link_libraries(ocioperf
PRIVATE
apputils
- IlmBase::Half
+ Imath::Imath
oiiohelpers
OpenColorIO
OpenImageIO::OpenImageIO
diff --git a/src/apps/ocioperf/main.cpp b/src/apps/ocioperf/main.cpp
index 6427860d..f6e4a63c 100644
--- a/src/apps/ocioperf/main.cpp
+++ b/src/apps/ocioperf/main.cpp
@@ -11,7 +11,7 @@ namespace OIIO = OIIO_NAMESPACE;
#endif
#include "apputils/argparse.h"
-#include "OpenEXR/half.h"
+#include "Imath/half.h"
#include "oiiohelpers.h"
#include "utils/StringUtils.h"
diff --git a/src/libutils/oiiohelpers/CMakeLists.txt b/src/libutils/oiiohelpers/CMakeLists.txt
index 6ef7c368..5f4a5113 100644
--- a/src/libutils/oiiohelpers/CMakeLists.txt
+++ b/src/libutils/oiiohelpers/CMakeLists.txt
@@ -31,7 +31,7 @@ target_link_libraries(oiiohelpers
PRIVATE
OpenColorIO
- IlmBase::Half
+ Imath::Imath
utils::strings
)
diff --git a/src/libutils/oiiohelpers/oiiohelpers.cpp b/src/libutils/oiiohelpers/oiiohelpers.cpp
index be1a937d..e7db652c 100644
--- a/src/libutils/oiiohelpers/oiiohelpers.cpp
+++ b/src/libutils/oiiohelpers/oiiohelpers.cpp
@@ -5,7 +5,7 @@
#include <OpenColorIO/OpenColorIO.h>
-#include "OpenEXR/half.h"
+#include "Imath/half.h"
#include "oiiohelpers.h"
#include "utils/StringUtils.h"
diff --git a/tests/cpu/CMakeLists.txt b/tests/cpu/CMakeLists.txt
index 67389962..8e8dd900 100755
--- a/tests/cpu/CMakeLists.txt
+++ b/tests/cpu/CMakeLists.txt
@@ -18,7 +18,7 @@ function(add_ocio_test NAME SOURCES PRIVATE_INCLUDES)
public_api
PRIVATE
expat::expat
- IlmBase::Half
+ Imath::Imath
pystring::pystring
sampleicc::sampleicc
unittest_data