From fd7bceeef15e296a8327e1297498a3eb9ee94759 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@plugapps.com>
Date: Tue, 1 Nov 2011 14:57:33 -0400
Subject: [PATCH] core/gcc to 4.6.2-1

---
 core/gcc/PKGBUILD | 22 +++++++++++-----------
 1 file changed, 11 insertions(+), 11 deletions(-)

diff --git a/core/gcc/PKGBUILD b/core/gcc/PKGBUILD
index 968f31e2a..2b6c528fc 100644
--- a/core/gcc/PKGBUILD
+++ b/core/gcc/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 129471 2011-06-28 04:17:45Z allan $
+# $Id: PKGBUILD 141367 2011-10-30 06:46:41Z allan $
 # Maintainer: Allan McRae <allan@archlinux.org>
 
 # toolchain build order: linux-api-headers->glibc->binutils->gcc->binutils->glibc
@@ -14,10 +14,10 @@ plugrel=1
 noautobuild=1
 
 pkgname=('gcc' 'gcc-libs' 'gcc-fortran' 'gcc-objc')
-pkgver=4.6.1
-pkgrel=2
-#_snapshot=4.6-20110603
-_libstdcppmanver=20110201		# Note: check source directory name when updating this
+pkgver=4.6.2
+pkgrel=1
+#_snapshot=4.6-20110819
+_libstdcppmanver=20110814		# Note: check source directory name when updating this
 pkgdesc="The GNU Compiler Collection"
 arch=('i686' 'x86_64')
 license=('GPL' 'LGPL' 'FDL' 'custom')
@@ -30,8 +30,8 @@ source=(ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
 	ftp://gcc.gnu.org/pub/gcc/libstdc++/doxygen/libstdc++-api.${_libstdcppmanver}.man.tar.bz2
 	gcc_pure64.patch
 	gcc-hash-style-both.patch)
-md5sums=('c57a9170c677bf795bdc04ed796ca491'
-         '1e9fd2eaf0ee47ea64e82c48998f1999'
+md5sums=('028115c4fbfb6cfd75d6369f4a90d87e'
+         'ce920d2550ff7e042b9f091d27764d8f'
          '4030ee1c08dd1e843c0225b772360e76'
          '4df25b623799b148a0703eaeec8fdf3f')
 
@@ -76,7 +76,7 @@ build() {
       --with-ppl --enable-cloog-backend=isl \
       --enable-lto --enable-gold --enable-ld=default \
       --enable-plugin --with-plugin-ld=ld.gold \
-      --disable-multilib --disable-libstdcxx-pch \
+      --disable-multilib --disable-libssp --disable-libstdcxx-pch \
       --enable-checking=release $CONFIGFLAG
   make $MAKEFLAG
 }
@@ -102,7 +102,7 @@ package_gcc-libs()
 
   cd gcc-build
   make -j1 -C $CHOST/libgcc DESTDIR=${pkgdir} install-shared
-  for lib in libmudflap libgomp libssp libstdc++-v3/src; do
+  for lib in libmudflap libgomp libstdc++-v3/src; do
     make -j1 -C $CHOST/$lib DESTDIR=${pkgdir} install-toolexeclibLTLIBRARIES
   done
   make -j1 -C $CHOST/libstdc++-v3/po DESTDIR=${pkgdir} install
@@ -134,9 +134,9 @@ package_gcc()
   
   # unfortunately it is much, much easier to install the lot and clean-up the mess...
   make -j1 DESTDIR=${pkgdir} install
-  rm -f $pkgdir/usr/bin/{$CHOST-,}gfortran
+  rm -f $pkgdir/usr/bin/{{$CHOST-,}gfortran}
   rm -f $pkgdir/usr/lib/*.so*
-  rm -f $pkgdir/usr/lib/lib{ffi,gfortran,objc,quadmath}.a
+  rm -f $pkgdir/usr/lib/lib{ffi,gfortran,,objc,quadmath}.a
   rm -f $pkgdir/usr/lib/libgfortran.spec
   rm -f -r $pkgdir/usr/lib/gcc/$CHOST/${pkgver}/{finclude,include/objc}
   rm -f $pkgdir/usr/lib/gcc/$CHOST/${pkgver}/include/{ffi{,target}.h,quadmath{,_weak}.h}