community/polymake to 3.6-2

This commit is contained in:
Kevin Mihelich 2019-12-11 13:48:53 +00:00
parent 23f7879e2a
commit fdac15d864
2 changed files with 21 additions and 3 deletions

View file

@ -11,7 +11,7 @@ _pkgver=3.6
_patchver=
#pkgver=$_pkgver.r$_patchver
pkgver=$_pkgver
pkgrel=1
pkgrel=2
pkgdesc="Open source software for research in polyhedral geometry"
arch=(x86_64)
url="https://polymake.org/"
@ -20,8 +20,15 @@ depends=(normaliz singular ppl lrs perl-xml-writer perl-xml-libxml perl-xml-libx
perl-term-readline-gnu perl-term-readkey perl-json sympol)
makedepends=(ninja cddlib ant boost bliss libnsl jdk8-openjdk permlib)
optdepends=('java-runtime: java module')
source=("https://polymake.org/lib/exe/fetch.php/download/polymake-${_pkgver}-minimal.tar.bz2")
sha256sums=('b3378e0cc108e77894e4f2ec4b2f9e22190a59bba6482716900d741cb6775bab')
source=("https://polymake.org/lib/exe/fetch.php/download/polymake-${_pkgver}-minimal.tar.bz2"
polymake-normaliz-3.8.3.patch)
sha256sums=('b3378e0cc108e77894e4f2ec4b2f9e22190a59bba6482716900d741cb6775bab'
'cbcff6ffd486c4c2ac8dede32c3103b4b3a87d89199c083390ad48b961905776')
prepare() {
cd polymake-$_pkgver
patch -p1 -i ../polymake-normaliz-3.8.3.patch # Fix build against normaliz 3.8.3
}
build() {
cd polymake-$_pkgver

View file

@ -0,0 +1,11 @@
--- polymake-3.6/bundled/libnormaliz/support/configure.pl.orig 2019-12-11 12:29:31.089671103 +0000
+++ polymake-3.6/bundled/libnormaliz/support/configure.pl 2019-12-11 12:29:52.549969615 +0000
@@ -69,7 +69,7 @@
}
if ($nmz_path ne "bundled") {
- my $error=Polymake::Configure::build_test_program(<<'---', LIBS => "-lnormaliz -lgmpxx -lgmp", CXXFLAGS => "$CXXFLAGS", LDFLAGS => "$LDFLAGS");
+ my $error=Polymake::Configure::build_test_program(<<'---', LIBS => "-lnormaliz -lgmpxx -lgmp -leantic", CXXFLAGS => "$CXXFLAGS", LDFLAGS => "$LDFLAGS");
#include <cstddef>
#include <vector>