diff --git a/community/python-autobahn/PKGBUILD b/community/python-autobahn/PKGBUILD
index 979f1e9a2..ff83fc1d2 100644
--- a/community/python-autobahn/PKGBUILD
+++ b/community/python-autobahn/PKGBUILD
@@ -6,7 +6,7 @@
 #  - removed AUTOBAHN_USE_NVX=1 from python build/install commands
 
 pkgname=python-autobahn
-pkgver=20.2.2
+pkgver=20.3.1
 pkgrel=1
 pkgdesc='Real-time framework for Web, Mobile & Internet of Things'
 arch=(x86_64)
@@ -17,7 +17,7 @@ depends=(python-cffi python-twisted python-txaio python-wsaccel
 makedepends=(python-argon2_cffi python-cbor python-flatbuffers
              python-msgpack python-passlib python-pynacl python-pytrie
              python-ubjson)
-checkdepends=(python-mock python-pytest python-pytest-asyncio)
+checkdepends=(python-pytest python-pytest-asyncio)
 optdepends=(
   'python-cbor: CBOR serializer support'
   'python-flatbuffers: FlatBuffers serializer support'
@@ -34,7 +34,7 @@ optdepends=(
 )
 
 source=(https://files.pythonhosted.org/packages/source/a/autobahn/autobahn-$pkgver.tar.gz)
-sha256sums=('8fb9f3e7f6de5b7ee5479a56582873b927cc25d72319d0a86f43d992048d8171')
+sha256sums=('88e150e4b3d284b83daafd8e0b289a5625ee00c633a2c580055bf1be2d391002')
 
 build() {
   cd "$srcdir/autobahn-$pkgver"