mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
xf86-video-armsoc-chromium to r228.1ccf708-1
This commit is contained in:
parent
87f6643d6c
commit
fdf5cb25f8
2 changed files with 21 additions and 26 deletions
|
@ -1,6 +1,6 @@
|
||||||
From 63325d4c75fef68324036c0908c4cb074ac3cf4f Mon Sep 17 00:00:00 2001
|
From afce5d5689b0548767c146dfe3b21bf5f603010f Mon Sep 17 00:00:00 2001
|
||||||
From: Mauro Ribeiro <mauro.ribeiro@hardkernel.com>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Sun, 5 Jan 2014 19:38:10 +0000
|
Date: Fri, 23 May 2014 21:01:56 -0600
|
||||||
Subject: [PATCH] compat for newer xorg
|
Subject: [PATCH] compat for newer xorg
|
||||||
|
|
||||||
---
|
---
|
||||||
|
@ -24,7 +24,7 @@ index fa0f352..b74a582 100644
|
||||||
#define BLOCKHANDLER_ARGS_DECL int arg, pointer blockData, pointer pTimeout, pointer pReadmask
|
#define BLOCKHANDLER_ARGS_DECL int arg, pointer blockData, pointer pTimeout, pointer pReadmask
|
||||||
#define BLOCKHANDLER_ARGS arg, blockData, pTimeout, pReadmask
|
#define BLOCKHANDLER_ARGS arg, blockData, pTimeout, pReadmask
|
||||||
diff --git a/src/drmmode_display.c b/src/drmmode_display.c
|
diff --git a/src/drmmode_display.c b/src/drmmode_display.c
|
||||||
index edc4df4..9fbedb1 100644
|
index 810f694..093fd2e 100644
|
||||||
--- a/src/drmmode_display.c
|
--- a/src/drmmode_display.c
|
||||||
+++ b/src/drmmode_display.c
|
+++ b/src/drmmode_display.c
|
||||||
@@ -58,9 +58,6 @@
|
@@ -58,9 +58,6 @@
|
||||||
|
@ -37,20 +37,20 @@ index edc4df4..9fbedb1 100644
|
||||||
#include "micmap.h"
|
#include "micmap.h"
|
||||||
|
|
||||||
#include "xf86DDC.h"
|
#include "xf86DDC.h"
|
||||||
@@ -1598,8 +1595,6 @@ Bool drmmode_pre_init(ScrnInfoPtr pScrn, int fd, int cpp)
|
@@ -1732,8 +1729,6 @@ Bool drmmode_pre_init(ScrnInfoPtr pScrn, int fd)
|
||||||
|
|
||||||
TRACE_ENTER();
|
TRACE_ENTER();
|
||||||
|
|
||||||
- pScrn->canDoBGNoneRoot = TRUE;
|
- pScrn->canDoBGNoneRoot = TRUE;
|
||||||
-
|
-
|
||||||
drmmode = calloc(1, sizeof *drmmode);
|
xf86CrtcConfigInit(pScrn, &drmmode_xf86crtc_config_funcs);
|
||||||
drmmode->fd = fd;
|
|
||||||
|
|
||||||
|
mode_res = drmModeGetResources(fd);
|
||||||
diff --git a/src/omap_driver.c b/src/omap_driver.c
|
diff --git a/src/omap_driver.c b/src/omap_driver.c
|
||||||
index 8430e2c..1dc4c5a 100644
|
index 65fff85..5223d97 100644
|
||||||
--- a/src/omap_driver.c
|
--- a/src/omap_driver.c
|
||||||
+++ b/src/omap_driver.c
|
+++ b/src/omap_driver.c
|
||||||
@@ -655,7 +655,6 @@ OMAPScreenInit(SCREEN_INIT_ARGS_DECL)
|
@@ -693,7 +693,6 @@ OMAPScreenInit(SCREEN_INIT_ARGS_DECL)
|
||||||
}
|
}
|
||||||
|
|
||||||
/* Initialize backing store: */
|
/* Initialize backing store: */
|
||||||
|
@ -59,7 +59,7 @@ index 8430e2c..1dc4c5a 100644
|
||||||
|
|
||||||
/* Cause the cursor position to be updated by the mouse signal handler: */
|
/* Cause the cursor position to be updated by the mouse signal handler: */
|
||||||
diff --git a/src/omap_driver.h b/src/omap_driver.h
|
diff --git a/src/omap_driver.h b/src/omap_driver.h
|
||||||
index b457985..32a510c 100644
|
index a62255f..a0dcbd6 100644
|
||||||
--- a/src/omap_driver.h
|
--- a/src/omap_driver.h
|
||||||
+++ b/src/omap_driver.h
|
+++ b/src/omap_driver.h
|
||||||
@@ -40,7 +40,6 @@
|
@@ -40,7 +40,6 @@
|
||||||
|
@ -71,5 +71,5 @@ index b457985..32a510c 100644
|
||||||
#include "colormapst.h"
|
#include "colormapst.h"
|
||||||
#include "xf86cmap.h"
|
#include "xf86cmap.h"
|
||||||
--
|
--
|
||||||
1.8.3.2
|
1.9.0
|
||||||
|
|
||||||
|
|
|
@ -3,15 +3,11 @@
|
||||||
# Contributor: Erik Andersson <erik.h.andersson@gmail.com>
|
# Contributor: Erik Andersson <erik.h.andersson@gmail.com>
|
||||||
# Contributor: Mauro Ribeiro <mauro.ribeiro@hardkernel.com>
|
# Contributor: Mauro Ribeiro <mauro.ribeiro@hardkernel.com>
|
||||||
|
|
||||||
# Official upstream is at
|
|
||||||
# http://git.linaro.org/gitweb?p=arm/xorg/driver/xf86-video-armsoc.git;a=summary
|
|
||||||
# https://chromium.googlesource.com/chromiumos/third_party/xf86-video-armsoc
|
|
||||||
|
|
||||||
buildarch=4
|
buildarch=4
|
||||||
|
|
||||||
pkgname=xf86-video-armsoc-chromium
|
pkgname=xf86-video-armsoc-chromium
|
||||||
pkgver=r180.f6d255c
|
pkgver=r228.1ccf708
|
||||||
pkgrel=2
|
pkgrel=1
|
||||||
epoch=1
|
epoch=1
|
||||||
arch=('armv7h')
|
arch=('armv7h')
|
||||||
url="https://chromium.googlesource.com/chromiumos/third_party/xf86-video-armsoc"
|
url="https://chromium.googlesource.com/chromiumos/third_party/xf86-video-armsoc"
|
||||||
|
@ -19,33 +15,32 @@ license=('GPL2')
|
||||||
makedepends=('git' 'pkgconfig' 'xorg-server-devel' 'resourceproto' 'scrnsaverproto')
|
makedepends=('git' 'pkgconfig' 'xorg-server-devel' 'resourceproto' 'scrnsaverproto')
|
||||||
options=('!libtool')
|
options=('!libtool')
|
||||||
conflicts=(xf86-video-armsoc)
|
conflicts=(xf86-video-armsoc)
|
||||||
replaces=(xf86-video-armsoc)
|
|
||||||
provides=(xf86-video-armsoc)
|
provides=(xf86-video-armsoc)
|
||||||
source=("$pkgname::git+https://chromium.googlesource.com/chromiumos/third_party/xf86-video-armsoc"
|
source=("$pkgname::git+https://chromium.googlesource.com/chromiumos/third_party/xf86-video-armsoc"
|
||||||
'0001-compat-for-newer-xorg.patch')
|
'0001-compat-for-newer-xorg.patch')
|
||||||
md5sums=('SKIP'
|
md5sums=('SKIP'
|
||||||
'12361ef14f940d10c471f55104ada39d')
|
'429bc16ad0c7fe308d90c701c1aa97d1')
|
||||||
|
|
||||||
pkgver() {
|
pkgver() {
|
||||||
cd "$srcdir/$pkgname"
|
cd $pkgname
|
||||||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
|
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
|
||||||
}
|
}
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd "$srcdir/$pkgname"
|
cd $pkgname
|
||||||
git apply "$srcdir/0001-compat-for-newer-xorg.patch"
|
git apply ../0001-compat-for-newer-xorg.patch
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "$srcdir/$pkgname"
|
cd $pkgname
|
||||||
|
|
||||||
|
CFLAGS=`echo $CFLAGS | sed -e 's/vfpv3-d16/neon/'` && CXXFLAGS="$CFLAGS"
|
||||||
./autogen.sh --prefix=/usr --with-drmmode=exynos
|
./autogen.sh --prefix=/usr --with-drmmode=exynos
|
||||||
make
|
make
|
||||||
}
|
}
|
||||||
|
|
||||||
package() {
|
package() {
|
||||||
pkgdesc="armsoc framebuffer driver for X from chromium os git"
|
cd $pkgname
|
||||||
|
|
||||||
make -C "$srcdir/$pkgname" DESTDIR="${pkgdir}" install
|
make DESTDIR="${pkgdir}" install
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue