extra/perl-anyevent to 7.14-1

This commit is contained in:
Kevin Mihelich 2017-06-24 15:18:22 +00:00
parent b92ec9be94
commit fdfec48201
2 changed files with 4 additions and 34 deletions

View file

@ -5,8 +5,8 @@
# - patch to replace deprecated SSL_ST_OK state with TLS_ST_OK (1)
pkgname=perl-anyevent
pkgver=7.13
pkgrel=2
pkgver=7.14
pkgrel=1
epoch=4
pkgdesc='The DBI of event loop programming'
arch=('any')
@ -22,16 +22,12 @@ optdepends=('perl-async-interrupt: for fast signal handling'
'perl-net-ssleay: TLS/SSL connections with AnyEvent::Handle')
options=('!emptydirs')
source=("http://search.cpan.org/CPAN/authors/id/M/ML/MLEHMANN/AnyEvent-$pkgver.tar.gz"
issue53923.patch
openssl.patch)
md5sums=('70eea152cf4686f8f351aa8bc96157f9'
'e6e9e44caa1610a1d527c76258270d7a'
'fa31c399ba591a634c3165420a273f33')
sha512sums=('98e7b9e06cf74b99d3407a25b60f3b825fceed3bae43505e1fb90785e24bd88ae25955cff25d29b4cc96957db7f4f5203d19ad2365abb4e3a3227fd91a16fb25'
'a5fb03d07f7ba467a51b802e1d43bf996a99338d0c016c58dc9829600316ad6ad096760455c589b3a6d9cec8a5806f1469fad8aab8c46eee7f5a62f4fe7bc730')
prepare() {
cd AnyEvent-$pkgver
# https://rt.cpan.org/Public/Bug/Display.html?id=118584
patch -p1 -i ../issue53923.patch
patch -p1 -i ../openssl.patch
}

View file

@ -1,26 +0,0 @@
--- AnyEvent/lib/AnyEvent/Handle.pm 2016/10/30 23:03:36 1.248
+++ AnyEvent/lib/AnyEvent/Handle.pm 2016/11/26 03:34:50 1.249
@@ -2195,19 +2195,19 @@
# basically, this is deep magic (because SSL_read should have the same issues)
# but the openssl maintainers basically said: "trust us, it just works".
# (unfortunately, we have to hardcode constants because the abysmally misdesigned
- # and mismaintained ssleay-module doesn't even offer them).
+ # and mismaintained ssleay-module didn't offer them for a decade or so).
# http://www.mail-archive.com/openssl-dev@openssl.org/msg22420.html
#
# in short: this is a mess.
- #
+ #
# note that we do not try to keep the length constant between writes as we are required to do.
# we assume that most (but not all) of this insanity only applies to non-blocking cases,
# and we drive openssl fully in blocking mode here. Or maybe we don't - openssl seems to
# have identity issues in that area.
-# Net::SSLeay::CTX_set_mode ($ssl,
+# Net::SSLeay::set_mode ($ssl,
# (eval { local $SIG{__DIE__}; Net::SSLeay::MODE_ENABLE_PARTIAL_WRITE () } || 1)
# | (eval { local $SIG{__DIE__}; Net::SSLeay::MODE_ACCEPT_MOVING_WRITE_BUFFER () } || 2));
- Net::SSLeay::CTX_set_mode ($tls, 1|2);
+ Net::SSLeay::set_mode ($tls, 1|2);
$self->{_rbio} = Net::SSLeay::BIO_new (Net::SSLeay::BIO_s_mem ());
$self->{_wbio} = Net::SSLeay::BIO_new (Net::SSLeay::BIO_s_mem ());