core/linux-aarch64-rc to 5.5.rc3-1

This commit is contained in:
Kevin Mihelich 2019-12-23 16:33:02 +00:00
parent 5a13d50a62
commit fe05b052cf
6 changed files with 22 additions and 63 deletions

View file

@ -1,7 +1,7 @@
From 1a96b25c17a89d6b6efc79f16e9aad41e75c6991 Mon Sep 17 00:00:00 2001
From e801f0f40fc676ffeecff80d2dfbfd0c26d6cfc1 Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 1/5] net/smsc95xx: Allow mac address to be set as a parameter
Subject: [PATCH 1/4] net/smsc95xx: Allow mac address to be set as a parameter
---
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++
@ -91,5 +91,5 @@ index 355be77f4241..c94a7193e0b9 100644
/* maybe the boot loader passed the MAC address in devicetree */
--
2.23.0
2.24.0

View file

@ -1,7 +1,7 @@
From 110a25d5e289e6254270df2b2fe17d9765f53265 Mon Sep 17 00:00:00 2001
From 146609a19fd2b48730a098d19383226c26794ffb Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Mon, 7 Aug 2017 19:34:57 -0600
Subject: [PATCH 2/5] arm64: dts: rockchip: disable pwm0 on rk3399-firefly
Subject: [PATCH 2/4] arm64: dts: rockchip: disable pwm0 on rk3399-firefly
Workaround for intermittent boot hangs due to pwm0 probe disabling the PWM clock.
---
@ -12,7 +12,7 @@ diff --git a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts b/arch/arm64/boot/d
index c706db0ee9ec..24adeca99711 100644
--- a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
+++ b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
@@ -640,7 +640,7 @@
@@ -640,7 +640,7 @@ diy_led_gpio: diy_led-gpio {
};
&pwm0 {
@ -22,5 +22,5 @@ index c706db0ee9ec..24adeca99711 100644
&pwm2 {
--
2.23.0
2.24.0

View file

@ -1,7 +1,7 @@
From 843ecfaf6d1e5ef8759ae4ed272b5c747a843696 Mon Sep 17 00:00:00 2001
From 9a32f275686f725fa7326a52a47a6e888fa54253 Mon Sep 17 00:00:00 2001
From: William Wu <william.wu@rock-chips.com>
Date: Mon, 4 Dec 2017 10:40:39 +0100
Subject: [PATCH 3/5] arm64: dts: rockchip: add usb3 controller node for RK3328
Subject: [PATCH 3/4] arm64: dts: rockchip: add usb3 controller node for RK3328
SoCs
RK3328 has one USB 3.0 OTG controller which uses DWC_USB3
@ -16,10 +16,10 @@ Signed-off-by: Heiko Stuebner <heiko@sntech.de>
1 file changed, 27 insertions(+)
diff --git a/arch/arm64/boot/dts/rockchip/rk3328.dtsi b/arch/arm64/boot/dts/rockchip/rk3328.dtsi
index 31cc1541f1f5..0feef5ed71b4 100644
index 91306ebed4da..ac4bc0935c86 100644
--- a/arch/arm64/boot/dts/rockchip/rk3328.dtsi
+++ b/arch/arm64/boot/dts/rockchip/rk3328.dtsi
@@ -936,6 +936,33 @@
@@ -968,6 +968,33 @@ usb_host0_ohci: usb@ff5d0000 {
status = "disabled";
};
@ -54,5 +54,5 @@ index 31cc1541f1f5..0feef5ed71b4 100644
compatible = "arm,gic-400";
#interrupt-cells = <3>;
--
2.23.0
2.24.0

View file

@ -1,7 +1,7 @@
From 00bfb3099639e5fde1aba006356af25b1a172eba Mon Sep 17 00:00:00 2001
From 513ab442c8ee60a2c3f785f45cf9aae530e30bc8 Mon Sep 17 00:00:00 2001
From: Heiko Stuebner <heiko@sntech.de>
Date: Mon, 4 Dec 2017 10:40:41 +0100
Subject: [PATCH 4/5] arm64: dts: rockchip: enable usb3 nodes on rk3328-rock64
Subject: [PATCH 4/4] arm64: dts: rockchip: enable usb3 nodes on rk3328-rock64
Enable the nodes to make the usb3 port usable on that board.
@ -14,7 +14,7 @@ diff --git a/arch/arm64/boot/dts/rockchip/rk3328-rock64.dts b/arch/arm64/boot/dt
index 62936b432f9a..c684ca7b7e2d 100644
--- a/arch/arm64/boot/dts/rockchip/rk3328-rock64.dts
+++ b/arch/arm64/boot/dts/rockchip/rk3328-rock64.dts
@@ -391,6 +391,15 @@
@@ -391,6 +391,15 @@ &usb_host0_ohci {
status = "okay";
};
@ -31,5 +31,5 @@ index 62936b432f9a..c684ca7b7e2d 100644
status = "okay";
};
--
2.23.0
2.24.0

View file

@ -1,38 +0,0 @@
From 9d393938a33f304ae2b40a1c4669db48928648cf Mon Sep 17 00:00:00 2001
From: Stefan Wahren <wahrenst@gmx.net>
Date: Sat, 30 Nov 2019 13:31:13 +0100
Subject: [PATCH 5/5] ARM: dts: bcm283x: Fix critical trip point
During definition of the CPU thermal zone of BCM283x SoC family there was
a misunderstanding of the meaning "criticial trip point" and the thermal
throttling range of the VideoCore firmware. The latter one takes effect
when the core temperature is between 80 and 85 degree celsius. So the
current critical trip point doesn't make sense, because the
thermal shutdown appears before the firmware has a chance to throttle the
ARM core(s).
Fix these unwanted shutdowns by increasing the critical trip point
to a value which shouldn't be reached with working thermal throttling.
Fixes: 0fe4d2181cc4 ("ARM: dts: bcm283x: Add CPU thermal zone with 1 trip point")
Signed-off-by: Stefan Wahren <wahrenst@gmx.net>
---
arch/arm/boot/dts/bcm283x.dtsi | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/boot/dts/bcm283x.dtsi b/arch/arm/boot/dts/bcm283x.dtsi
index 2d191fcbc2cc..90125ce19a1b 100644
--- a/arch/arm/boot/dts/bcm283x.dtsi
+++ b/arch/arm/boot/dts/bcm283x.dtsi
@@ -40,7 +40,7 @@
trips {
cpu-crit {
- temperature = <80000>;
+ temperature = <90000>;
hysteresis = <0>;
type = "critical";
};
--
2.23.0

View file

@ -4,7 +4,7 @@
buildarch=8
_rcver=5.5
_rcrel=2
_rcrel=3
pkgbase=linux-aarch64-rc
_srcname=linux-${_rcver}-rc${_rcrel}
@ -22,7 +22,6 @@ source=("https://git.kernel.org/torvalds/t/${_srcname}.tar.gz"
'0002-arm64-dts-rockchip-disable-pwm0-on-rk3399-firefly.patch'
'0003-arm64-dts-rockchip-add-usb3-controller-node-for-RK33.patch'
'0004-arm64-dts-rockchip-enable-usb3-nodes-on-rk3328-rock6.patch'
'0005-ARM-dts-bcm283x-Fix-critical-trip-point.patch'
'config'
'kernel.its'
'kernel.keyblock'
@ -30,12 +29,11 @@ source=("https://git.kernel.org/torvalds/t/${_srcname}.tar.gz"
'linux.preset'
'60-linux.hook'
'90-linux.hook')
md5sums=('9e23bfc0cfb83c9a4e66dff53945fbed'
'f1656e2052c9a25f977b1051136ea85f'
'98bd5a4f6f203d8da94439faf9084dd5'
'4bee45bc09780f8f2b07239ab6594f30'
'0957a4a901282f33c05e1f68390f9ada'
'147b56da6735706dcab3b1bc58b9176e'
md5sums=('696464b1afdab1068e41537c8b3b820a'
'8f50ae936659ff174e292e1164d279c1'
'e85e2b7aa3bc42d7dd6b36c325d29e3f'
'2c36fb143c27ed46f498c4d4633ea0c6'
'2e3fe5b9053d6a2c5327113836409d13'
'cb959f2590cfecb27cf15aac44c156b1'
'7f1a96e24f5150f790df94398e9525a3'
'61c5ff73c136ed07a7aadbf58db3d96a'
@ -52,7 +50,6 @@ prepare() {
git apply ../0002-arm64-dts-rockchip-disable-pwm0-on-rk3399-firefly.patch
git apply ../0003-arm64-dts-rockchip-add-usb3-controller-node-for-RK33.patch
git apply ../0004-arm64-dts-rockchip-enable-usb3-nodes-on-rk3328-rock6.patch
git apply ../0005-ARM-dts-bcm283x-Fix-critical-trip-point.patch
cat "${srcdir}/config" > ./.config