community/jack2: update patch

This commit is contained in:
Kevin Mihelich 2014-08-24 18:28:02 +00:00
parent 480afe57f9
commit fe2a4cd594
2 changed files with 15 additions and 3 deletions

View file

@ -4,7 +4,7 @@
# Contributor: Philipp Überbacher <hollunder at gmx dot at>
# Contributor: Thomas Bahn <thomas-bahn at gmx dot net>
# ALARM: Jaros³aw Rymut <jarymut+github@gmail.com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch for packed structures, arm does not like them
pkgbase=jack2
@ -21,7 +21,7 @@ makedepends=('python2-dbus' 'libffado' 'celt' 'opus' 'libsamplerate')
source=("https://dl.dropbox.com/u/28869550/jack-$pkgver.tar.bz2"
'99-audio.conf'
'40-hpet-permissions.rules'
'https://raw.github.com/AutoStatic/jack-armel/master/jack2_armel.diff')
'arm.patch')
md5sums=('4aeb91d7ae0cabce98355436ed4f217a'
'ae65b7c9ebe0fff6c918ba9d97ae342d'
'471aad533ff56c5d3cbbf65ce32cadef'
@ -49,7 +49,7 @@ prepare() {
cd "$srcdir"
# apply patch for ARM
patch -d $_tarname-$pkgver -p1 -i ../jack2_armel.diff
patch -d $_tarname-$pkgver -p1 -i ../arm.patch
# Some optimisation bug exists for current GCC
# see http://gcc.gnu.org/bugzilla/show_bug.cgi?id=53663

12
community/jack2/arm.patch Normal file
View file

@ -0,0 +1,12 @@
diff -urN a/common/jack/systemdeps.h b/common/jack/systemdeps.h
--- a/common/jack/systemdeps.h 2014-07-18 06:28:12.000000000 -0600
+++ b/common/jack/systemdeps.h 2014-08-24 12:21:17.163543628 -0600
@@ -123,6 +123,8 @@
#if defined(__arm__)
#undef POST_PACKED_STRUCTURE
#define POST_PACKED_STRUCTURE
+ #undef PRE_PACKED_STRUCTURE
+ #define PRE_PACKED_STRUCTURE
#endif /* __arm__ */
#endif /* __jack_systemdeps_h__ */