mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/libvpx to 1.8.1-1
This commit is contained in:
parent
b88f96e5e1
commit
fe680adf3e
2 changed files with 10 additions and 10 deletions
|
@ -1,4 +1,4 @@
|
|||
From 2cc3f6718e1ca9a16007b944032137891b64b51d Mon Sep 17 00:00:00 2001
|
||||
From e26cf640ca99b84c2536a9b9254777e1110af911 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 15 Jan 2017 12:11:57 -0700
|
||||
Subject: [PATCH] ARM fixes
|
||||
|
@ -9,10 +9,10 @@ Subject: [PATCH] ARM fixes
|
|||
2 files changed, 13 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/build/make/configure.sh b/build/make/configure.sh
|
||||
index 00214c9d2e..865c338265 100644
|
||||
index 472e7dea7b..3c0831fce1 100644
|
||||
--- a/build/make/configure.sh
|
||||
+++ b/build/make/configure.sh
|
||||
@@ -740,6 +740,14 @@ process_common_toolchain() {
|
||||
@@ -737,6 +737,14 @@ process_common_toolchain() {
|
||||
aarch64*)
|
||||
tgt_isa=arm64
|
||||
;;
|
||||
|
@ -27,7 +27,7 @@ index 00214c9d2e..865c338265 100644
|
|||
armv7*-hardfloat* | armv7*-gnueabihf | arm-*-gnueabihf)
|
||||
tgt_isa=armv7
|
||||
float_abi=hard
|
||||
@@ -964,7 +972,7 @@ process_common_toolchain() {
|
||||
@@ -961,7 +969,7 @@ process_common_toolchain() {
|
||||
soft_enable neon
|
||||
;;
|
||||
armv7|armv7s)
|
||||
|
@ -36,7 +36,7 @@ index 00214c9d2e..865c338265 100644
|
|||
# Only enable neon_asm when neon is also enabled.
|
||||
enabled neon && soft_enable neon_asm
|
||||
# If someone tries to force it through, die.
|
||||
@@ -984,13 +992,6 @@ process_common_toolchain() {
|
||||
@@ -981,13 +989,6 @@ process_common_toolchain() {
|
||||
arch_int=${arch_int%%te}
|
||||
tune_cflags="-mtune="
|
||||
if [ ${tgt_isa} = "armv7" ] || [ ${tgt_isa} = "armv7s" ]; then
|
||||
|
@ -50,7 +50,7 @@ index 00214c9d2e..865c338265 100644
|
|||
check_add_cflags -march=armv7-a -mfloat-abi=${float_abi}
|
||||
check_add_asflags -march=armv7-a -mfloat-abi=${float_abi}
|
||||
|
||||
@@ -1002,8 +1003,8 @@ EOF
|
||||
@@ -999,8 +1000,8 @@ EOF
|
||||
check_add_cflags -march=armv8-a
|
||||
check_add_asflags -march=armv8-a
|
||||
else
|
||||
|
@ -62,10 +62,10 @@ index 00214c9d2e..865c338265 100644
|
|||
|
||||
enabled debug && add_asflags -g
|
||||
diff --git a/configure b/configure
|
||||
index 6204f10b6c..009fe8cbbe 100755
|
||||
index d29e00ad86..c44ccee5bd 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -103,6 +103,8 @@ all_platforms="${all_platforms} arm64-darwin-gcc"
|
||||
@@ -102,6 +102,8 @@ all_platforms="${all_platforms} arm64-darwin-gcc"
|
||||
all_platforms="${all_platforms} arm64-linux-gcc"
|
||||
all_platforms="${all_platforms} arm64-win64-gcc"
|
||||
all_platforms="${all_platforms} arm64-win64-vs15"
|
||||
|
|
|
@ -7,7 +7,7 @@
|
|||
# - disable neon and neon-asm
|
||||
|
||||
pkgname=libvpx
|
||||
pkgver=1.8.0
|
||||
pkgver=1.8.1
|
||||
pkgrel=1
|
||||
pkgdesc='VP8 and VP9 codec'
|
||||
arch=(x86_64)
|
||||
|
@ -21,7 +21,7 @@ provides=(libvpx.so)
|
|||
source=(git+https://chromium.googlesource.com/webm/libvpx#tag=v${pkgver}
|
||||
0001-ARM-fixes.patch)
|
||||
sha256sums=('SKIP'
|
||||
'c3961bd173bde825221e766bb86d87de126b2e66d5c7b922935e5afcfcc40e62')
|
||||
'91c82653dd9ae1f36d78efd1ae6f9e7a642c6cac68e391ab95460c07988bd885')
|
||||
|
||||
prepare() {
|
||||
cd libvpx
|
||||
|
|
Loading…
Reference in a new issue