mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/qtcreator to 4.10.2-1
This commit is contained in:
parent
ec379658d4
commit
fe909fc719
2 changed files with 5 additions and 21 deletions
|
@ -12,9 +12,9 @@
|
||||||
buildarch=12
|
buildarch=12
|
||||||
|
|
||||||
pkgname=qtcreator
|
pkgname=qtcreator
|
||||||
pkgver=4.10.1
|
pkgver=4.10.2
|
||||||
_clangver=9.0.0
|
_clangver=9.0.0
|
||||||
pkgrel=2
|
pkgrel=1
|
||||||
pkgdesc='Lightweight, cross-platform integrated development environment'
|
pkgdesc='Lightweight, cross-platform integrated development environment'
|
||||||
arch=(x86_64)
|
arch=(x86_64)
|
||||||
url='https://www.qt.io'
|
url='https://www.qt.io'
|
||||||
|
@ -33,11 +33,9 @@ optdepends=('qt5-doc: integrated Qt documentation'
|
||||||
'bzr: bazaar support'
|
'bzr: bazaar support'
|
||||||
'perf: performer analyzer')
|
'perf: performer analyzer')
|
||||||
source=("https://download.qt.io/official_releases/qtcreator/${pkgver%.*}/$pkgver/qt-creator-opensource-src-$pkgver.tar.xz"
|
source=("https://download.qt.io/official_releases/qtcreator/${pkgver%.*}/$pkgver/qt-creator-opensource-src-$pkgver.tar.xz"
|
||||||
qtcreator-preload-plugins.patch
|
qtcreator-preload-plugins.patch)
|
||||||
qtcreator-clang-9.patch)
|
sha256sums=('9add6bdddfe5726bb02535409c2ed788b1afeee082121f54f887281d0e3c449a'
|
||||||
sha256sums=('5098d87027bec3296bd93a7e112588759ccb0511fbfdc5558c1a1e83dff8d2a9'
|
'150c444e76ec969fc8765774b648984037829623300d0ce9d41a915b2afa792d')
|
||||||
'150c444e76ec969fc8765774b648984037829623300d0ce9d41a915b2afa792d'
|
|
||||||
'1d66eb008e84459f6570e6e72acedcf80d2f0bb82650df3b733f7ca0a3f08a3d')
|
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
mkdir -p build
|
mkdir -p build
|
||||||
|
@ -52,8 +50,6 @@ prepare() {
|
||||||
# see http://code.qt.io/cgit/clang/clang.git/commit/?id=7f349701d3ea0c47be3a43e265699dddd3fd55cf
|
# see http://code.qt.io/cgit/clang/clang.git/commit/?id=7f349701d3ea0c47be3a43e265699dddd3fd55cf
|
||||||
# and https://bugs.archlinux.org/task/59492
|
# and https://bugs.archlinux.org/task/59492
|
||||||
patch -p1 -i ../qtcreator-preload-plugins.patch
|
patch -p1 -i ../qtcreator-preload-plugins.patch
|
||||||
# Fix build with clang 9 (Fedora)
|
|
||||||
patch -p1 -i ../qtcreator-clang-9.patch
|
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
|
|
@ -1,12 +0,0 @@
|
||||||
diff -rupN qt-creator-opensource-src-4.10.0/src/plugins/clangformat/clangformatutils.cpp qt-creator-opensource-src-4.10.0-new/src/plugins/clangformat/clangformatutils.cpp
|
|
||||||
--- qt-creator-opensource-src-4.10.0/src/plugins/clangformat/clangformatutils.cpp 2019-09-03 16:36:38.000000000 +0200
|
|
||||||
+++ qt-creator-opensource-src-4.10.0-new/src/plugins/clangformat/clangformatutils.cpp 2019-09-25 13:33:27.230835047 +0200
|
|
||||||
@@ -60,7 +60,7 @@ static clang::format::FormatStyle qtcSty
|
|
||||||
style.AllowShortBlocksOnASingleLine = false;
|
|
||||||
style.AllowShortCaseLabelsOnASingleLine = false;
|
|
||||||
style.AllowShortFunctionsOnASingleLine = FormatStyle::SFS_Inline;
|
|
||||||
- style.AllowShortIfStatementsOnASingleLine = false;
|
|
||||||
+ style.AllowShortIfStatementsOnASingleLine = FormatStyle::SIS_Never;
|
|
||||||
style.AllowShortLoopsOnASingleLine = false;
|
|
||||||
style.AlwaysBreakAfterReturnType = FormatStyle::RTBS_None;
|
|
||||||
style.AlwaysBreakBeforeMultilineStrings = false;
|
|
Loading…
Reference in a new issue