extra/qt6-3d to 6.1.1-1

This commit is contained in:
Kevin Mihelich 2021-06-07 16:26:31 +00:00
parent 70212c81cd
commit feabd4236a
2 changed files with 32 additions and 3 deletions

View file

@ -6,7 +6,7 @@
# - explicitly link v5/v6 with libatomic
pkgname=qt6-3d
_qtver=6.1.0
_qtver=6.1.1
pkgver=${_qtver/-/}
pkgrel=1
arch=(x86_64)
@ -18,8 +18,14 @@ makedepends=(cmake qt6-declarative qt6-shadertools vulkan-headers) # assimp
optdepends=('qt6-shadertools: RHI renderer' 'qt6-declarative: QML bindings')
groups=(qt6)
_pkgfn="${pkgname/6-/}-everywhere-src-$_qtver"
source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
sha256sums=('af48f674883de91a5bcb11caefda0e130b9c8c65dce474c47550dc2fdd3a5660')
source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz
qt6-3d-gcc11.patch)
sha256sums=('66e25fcf0bd965374f9814ef8fb960ff7c0414ec9480dcdc57caad17f23ede08'
'b056d66a24956755c2aaddc4adddd71f5a945ff9795b0cbf9f43ab4d43b4f8f5')
prepare() {
patch -d $_pkgfn -p1 < qt6-3d-gcc11.patch # Fix build with GCC 11
}
build() {
[[ $CARCH == "arm" || $CARCH == "armv6h" ]] && echo "target_link_libraries(3DCore PRIVATE atomic)" >> ${_pkgfn}/src/core/CMakeLists.txt

View file

@ -0,0 +1,23 @@
diff -ru qt3d-everywhere-src-6.1.1.orig/src/3rdparty/assimp/src/include/assimp/Importer.hpp qt3d-everywhere-src-6.1.1/src/3rdparty/assimp/src/include/assimp/Importer.hpp
--- qt3d-everywhere-src-6.1.1.orig/src/3rdparty/assimp/src/include/assimp/Importer.hpp 2021-06-07 08:29:23.902950055 +0000
+++ qt3d-everywhere-src-6.1.1/src/3rdparty/assimp/src/include/assimp/Importer.hpp 2021-06-07 08:30:51.924838527 +0000
@@ -59,6 +59,8 @@
// Public ASSIMP data structures
#include <assimp/types.h>
+#include <exception>
+
namespace Assimp {
// =======================================================================
// Public interface to Assimp
diff -ru qt3d-everywhere-src-6.1.1.orig/src/3rdparty/assimp/src/code/Common/Importer.h qt3d-everywhere-src-6.1.1/src/3rdparty/assimp/src/code/Common/Importer.h
--- qt3d-everywhere-src-6.1.1.orig/src/3rdparty/assimp/src/code/Common/Importer.h 2021-06-07 08:34:37.598230479 +0000
+++ qt3d-everywhere-src-6.1.1/src/3rdparty/assimp/src/code/Common/Importer.h 2021-06-07 08:35:11.893602448 +0000
@@ -47,6 +47,7 @@
#include <map>
#include <vector>
#include <string>
+#include <exception>
#include <assimp/matrix4x4.h>
struct aiScene;