extra/snd to 14.1-2

This commit is contained in:
Kevin Mihelich 2013-11-07 23:21:03 +00:00
parent d39d25fe4c
commit feaf5e3ec1
2 changed files with 16 additions and 24 deletions

View file

@ -8,7 +8,7 @@
pkgname=snd
pkgver=14.1
pkgrel=1
pkgrel=2
pkgdesc="An advanced sound editor"
arch=('i686' 'x86_64')
url="http://ccrma.stanford.edu/software/snd/"
@ -18,16 +18,16 @@ makedepends=('ladspa' 'wavpack' 'flac' 'speex' 'gmp'
'timidity++' 'mpg123' 'vorbis-tools')
optdepends=('wavpack' 'flac' 'speex' 'mpg123'
'timidity++' 'vorbis-tools')
install=$pkgname.install
source=("ftp://ccrma-ftp.stanford.edu/pub/Lisp/$pkgname-$pkgver.tar.gz"
'type_error.patch')
md5sums=('955ca19ca70ac0e4d03cd710516c0174'
'6e96d59346b53a1c73060857f688dbd0')
'9bfea0dccdfb5da1ba81e721672b11cc')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
# work around incomplete type error
# fix incomplete type error
# see http://www.mail-archive.com/cmdist@ccrma.stanford.edu/msg04241.html
patch -Np1 -i "$srcdir/type_error.patch"
}

View file

@ -1,20 +1,12 @@
diff -ur snd-14.1.orig/vct.h snd-14.1/vct.h
--- snd-14.1.orig/vct.h 2013-10-28 02:22:35.073798054 +0800
+++ snd-14.1/vct.h 2013-10-28 02:45:27.166364791 +0800
@@ -1,11 +1,11 @@
#ifndef VCT_H
#define VCT_H
-#if HAVE_SCHEME
- typedef struct s7_cell vct;
-#else
-typedef struct vct vct;
-#endif
+typedef struct {
+ mus_long_t length;
+ mus_float_t *data;
+ bool dont_free;
+} vct;
#ifdef __cplusplus
extern "C" {
diff -bur snd-14.1.orig/snd-ladspa.c snd-14.1/snd-ladspa.c
--- snd-14.1.orig/snd-ladspa.c 2013-10-28 16:07:53.260612114 +0800
+++ snd-14.1/snd-ladspa.c 2013-10-28 16:11:18.792831983 +0800
@@ -1191,7 +1191,7 @@
if (descriptor->connect_port)
descriptor->connect_port(XEN_TO_C_Ladspa_Handle(ptr),
XEN_TO_C_ULONG(port),
- double_to_float(samples->data, samples->length)
+ double_to_float(mus_vct_data(samples), mus_vct_length(samples))
);
return(XEN_FALSE);
}