community/android-tools to 29.0.3-1

This commit is contained in:
Kevin Mihelich 2019-09-12 11:36:23 +00:00
parent 14f9135b27
commit ff5da58d73
3 changed files with 3 additions and 179 deletions

View file

@ -8,8 +8,8 @@
buildarch=28
pkgname=android-tools
pkgver=29.0.2
pkgrel=2
pkgver=29.0.3
pkgrel=1
tag=platform-tools-$pkgver
pkgdesc='Android platform tools'
arch=(x86_64)
@ -31,7 +31,6 @@ source=(git+https://android.googlesource.com/platform/system/core#tag=$tag
git+https://boringssl.googlesource.com/boringssl#commit=$_boringssl_commit
generate_build.rb
fix_build_core.patch
fix_build_e2fsprogs.patch
bash_completion.fastboot)
# Bash completion file was taken from https://github.com/mbrubeck/android-completion
sha1sums=('SKIP'
@ -43,8 +42,7 @@ sha1sums=('SKIP'
'SKIP'
'SKIP'
'afca7974ad8658e52fd028ead12ad0a959d63273'
'99a1618bd93af8ef3ff2cca893e950a0346021fe'
'bcebdf1e706a3c3da175234840c6ee4e13652012'
'e7f02cd6529dad54b4bdfd35e34b2cb9cb70cdd4'
'7004dbd0c193668827174880de6f8434de8ceaee')
prepare() {
@ -53,9 +51,6 @@ prepare() {
cd "$srcdir"/core
patch -p1 < ../fix_build_core.patch
cd "$srcdir"/e2fsprogs
patch -p1 < ../fix_build_e2fsprogs.patch
cd "$srcdir"/avb
sed -i 's|/usr/bin/env python$|/usr/bin/env python2|g' avbtool

View file

@ -43,14 +43,6 @@ diff --git a/adb/client/usb_libusb.cpp b/adb/client/usb_libusb.cpp
index 53f01a0ce5..5be0d91085 100644
--- a/adb/client/usb_libusb.cpp
+++ b/adb/client/usb_libusb.cpp
@@ -22,6 +22,7 @@
#include <stdlib.h>
#include <atomic>
+#include <condition_variable>
#include <chrono>
#include <condition_variable>
#include <memory>
@@ -30,7 +31,7 @@
#include <thread>
#include <unordered_map>
@ -60,90 +52,6 @@ index 53f01a0ce5..5be0d91085 100644
#include <android-base/file.h>
#include <android-base/logging.h>
diff --git a/adb/client/usb_linux.cpp b/adb/client/usb_linux.cpp
index 81b8306436..b4f09caab8 100644
--- a/adb/client/usb_linux.cpp
+++ b/adb/client/usb_linux.cpp
@@ -29,6 +29,7 @@
#include <stdlib.h>
#include <string.h>
#include <sys/ioctl.h>
+#include <sys/sysmacros.h>
#include <sys/time.h>
#include <sys/sysmacros.h>
#include <sys/types.h>
diff --git a/adb/fdevent/fdevent.h b/adb/fdevent/fdevent.h
index ccb0c9221c..2424252f5d 100644
--- a/adb/fdevent/fdevent.h
+++ b/adb/fdevent/fdevent.h
@@ -20,6 +20,7 @@
#include <stddef.h>
#include <stdint.h>
+#include <atomic>
#include <chrono>
#include <deque>
#include <functional>
diff --git a/adb/sysdeps/posix/network.cpp b/adb/sysdeps/posix/network.cpp
index c5c227568f..99686f15fb 100644
--- a/adb/sysdeps/posix/network.cpp
+++ b/adb/sysdeps/posix/network.cpp
@@ -22,6 +22,7 @@
#include <sys/socket.h>
#include <string>
+#include <string.h>
#include <android-base/logging.h>
#include <android-base/stringprintf.h>
diff --git a/adb/types.h b/adb/types.h
index cd1366dfbe..1eb7e4b6d7 100644
--- a/adb/types.h
+++ b/adb/types.h
@@ -22,6 +22,7 @@
#include <type_traits>
#include <utility>
#include <vector>
+#include <cstring>
#include <android-base/logging.h>
diff --git a/base/errors_unix.cpp b/base/errors_unix.cpp
index 296995efe2..48269b6750 100644
--- a/base/errors_unix.cpp
+++ b/base/errors_unix.cpp
@@ -17,6 +17,7 @@
#include "android-base/errors.h"
#include <errno.h>
+#include <string.h>
namespace android {
namespace base {
diff --git a/base/file.cpp b/base/file.cpp
index 3dfcfbb7ec..1b5c0203f0 100644
--- a/base/file.cpp
+++ b/base/file.cpp
@@ -26,6 +26,7 @@
#include <sys/stat.h>
#include <sys/types.h>
#include <unistd.h>
+#include <string.h>
#include <memory>
#include <mutex>
diff --git a/base/logging.cpp b/base/logging.cpp
index f89168c0fc..da522019dc 100644
--- a/base/logging.cpp
+++ b/base/logging.cpp
@@ -24,6 +24,7 @@
#include <inttypes.h>
#include <libgen.h>
#include <time.h>
+#include <string.h>
// For getprogname(3) or program_invocation_short_name.
#if defined(__ANDROID__) || defined(__APPLE__)
diff --git a/fastboot/fastboot.cpp b/fastboot/fastboot.cpp
index 8923f409df..d245a577ff 100644
--- a/fastboot/fastboot.cpp
@ -180,39 +88,3 @@ index 8c0aa6bf4e..3ad5b53568 100644
std::vector<const char*> mke2fs_args = {mke2fs_path.c_str(), "-t", "ext4", "-b"};
std::string block_size_str = std::to_string(block_size);
diff --git a/fs_mgr/liblp/reader.cpp b/fs_mgr/liblp/reader.cpp
index dcee6d2d86..6fcd613ab6 100644
--- a/fs_mgr/liblp/reader.cpp
+++ b/fs_mgr/liblp/reader.cpp
@@ -19,6 +19,7 @@
#include <stddef.h>
#include <stdlib.h>
#include <unistd.h>
+#include <cstring>
#include <functional>
diff --git a/fs_mgr/liblp/writer.cpp b/fs_mgr/liblp/writer.cpp
index bffcb7e6e1..6b36a641a6 100644
--- a/fs_mgr/liblp/writer.cpp
+++ b/fs_mgr/liblp/writer.cpp
@@ -20,6 +20,7 @@
#include <unistd.h>
#include <string>
+#include <cstring>
#include <android-base/file.h>
#include <android-base/unique_fd.h>
diff --git a/libziparchive/zip_archive.cc b/libziparchive/zip_archive.cc
index c95b03542e..ae8ebb93a4 100644
--- a/libziparchive/zip_archive.cc
+++ b/libziparchive/zip_archive.cc
@@ -30,6 +30,7 @@
#include <string.h>
#include <time.h>
#include <unistd.h>
+#include <string_view>
#include <memory>
#include <vector>

View file

@ -1,43 +0,0 @@
diff --git a/contrib/android/perms.c b/contrib/android/perms.c
index 9c5ec05b..865cc907 100644
--- a/contrib/android/perms.c
+++ b/contrib/android/perms.c
@@ -5,6 +5,7 @@
#include "support/nls-enable.h"
#include <time.h>
#include <sys/stat.h>
+#include "private/android_filesystem_capability.h"
#ifndef XATTR_SELINUX_SUFFIX
# define XATTR_SELINUX_SUFFIX "selinux"
diff --git a/lib/ext2fs/bitops.h b/lib/ext2fs/bitops.h
index 505b3c9c..7be5105f 100644
--- a/lib/ext2fs/bitops.h
+++ b/lib/ext2fs/bitops.h
@@ -233,11 +233,11 @@ extern errcode_t ext2fs_find_first_set_generic_bmap(ext2fs_generic_bitmap bitmap
#if (__STDC_VERSION__ >= 199901L)
#define _INLINE_ extern inline
#else
-#define _INLINE_ inline
+#define _INLINE_ static inline
#endif
#else /* !INCLUDE_INLINE FUNCS */
#if (__STDC_VERSION__ >= 199901L)
-#define _INLINE_ inline
+#define _INLINE_ static inline
#else /* not C99 */
#ifdef __GNUC__
#define _INLINE_ extern __inline__
diff --git a/lib/ext2fs/ext2fs.h b/lib/ext2fs/ext2fs.h
index 185be5df..833d9d87 100644
--- a/lib/ext2fs/ext2fs.h
+++ b/lib/ext2fs/ext2fs.h
@@ -1767,7 +1767,7 @@ extern const struct ext2_inode *ext2fs_const_inode(const struct ext2_inode_large
#define _INLINE_ extern
#else
#if (__STDC_VERSION__ >= 199901L)
-#define _INLINE_ inline
+#define _INLINE_ static inline
#else
#ifdef __GNUC__
#define _INLINE_ extern __inline__