mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
alarm/xbmc-cubox-git: build against old commit to fix #394
This commit is contained in:
parent
fc9d495def
commit
ff667a5868
3 changed files with 32 additions and 52 deletions
|
@ -2,7 +2,7 @@
|
|||
buildarch=4
|
||||
|
||||
pkgname="xbmc-cubox-git"
|
||||
pkgver=20121121
|
||||
pkgver=20130315
|
||||
pkgrel=1
|
||||
pkgdesc="A software media player and entertainment hub for digital media for the Cubox"
|
||||
arch=("armv7h")
|
||||
|
@ -12,12 +12,11 @@ depends=("faac" "faad2" "jasper" "hicolor-icon-theme" "libass" "libcdio" \
|
|||
"libgl" "libmad" "libmicrohttpd" "libplist" "libmodplug" "libmpeg2" \
|
||||
"libmysqlclient" "libsamplerate" "libxtst" "lzo2" "python2" \
|
||||
"sdl_image>=1.2.10" "sdl_mixer" "smbclient" "unzip" "wavpack" "mesa-demos" \
|
||||
"xorg-xdpyinfo" "yajl" "glew" "tinyxml" "marvell-libgfx" "marvell-ipp" \
|
||||
"xorg-xdpyinfo" "yajl" "glew" "tinyxml" "xf86-video-dove" "marvell-ipp" \
|
||||
"avahi" "bluez" "libssh" "ffmpeg" "taglib>=1.8" "libnfs" "libdvdcss" \
|
||||
"libbluray" "libdvdread" "libcec-cubox")
|
||||
makedepends=("boost" "cmake" "git" "gperf" "nasm" "zip" "swig" "java-runtime")
|
||||
optdepends=("pulseaudio: pulseaudio support" \
|
||||
"lirc: remote controller support" \
|
||||
optdepends=("lirc: remote controller support" \
|
||||
"udisks: automount external drives" \
|
||||
"upower: used to trigger suspend functionality" \
|
||||
"unrar: access compressed files without unpacking them" \
|
||||
|
@ -26,16 +25,12 @@ conflict=("xbmc" "xbmc-git")
|
|||
provides=("xbmc" "xbmc-git")
|
||||
replaces=("marvell-xbmc-git")
|
||||
source=("https://dl.dropbox.com/u/38673799/XbmcCuBoxPatches-Rev10.tar.xz" \
|
||||
"http://alunamation.com/archlinux/arm/AdditionalXbmcCuBoxPatches-Rev10.1.tar.xz" \
|
||||
"big-buck-bunny-480p-fix.patch" \
|
||||
"Xbmc-git-Python-2.7-2.patch" \
|
||||
"http://alunamation.com/archlinux/arm/AdditionalXbmcCuBoxPatches-Rev10.2.tar.xz" \
|
||||
"xbmc.service" \
|
||||
"xbmc.install")
|
||||
md5sums=("55813f68e1ab05405451f9791e59e68b" \
|
||||
"966deb0b02155153d72445b461b3e952" \
|
||||
"f0a903ed4214654e9ca74f5095ee409e" \
|
||||
"39be26ef917050873e0a98d53204f345" \
|
||||
"6a64783fd2a21a593e091c5d328196eb" \
|
||||
"8d3020d871850176bb8758a914562de2" \
|
||||
"f409bc2f0c817f5ecf7ecceafcd838fb" \
|
||||
"ef0236567e95b462010a5607f76d2b45")
|
||||
install="xbmc.install"
|
||||
|
||||
|
@ -64,12 +59,12 @@ _patches=(
|
|||
"13-Xbmc-Marvell-Dove-force-iwmmxt.patch" \
|
||||
"14-Xbmc-Marvell-Dove-force-iwmmxt-2.patch" \
|
||||
"15-Xbmc-Marvell-Dove-enable-armv5te.patch" \
|
||||
"Xbmc-git-PulseAudio-Updates-20120926.patch" \
|
||||
# "Xbmc-git-PulseAudio-Updates-20120926.patch" \
|
||||
"41-Xbmc-VMETA-Updates-2.patch" \
|
||||
"36-Xbmc-VMETA-use-ffmpeg-for-thumbs.patch" \
|
||||
"Xbmc-git-CJobWorker-THREAD_PRIORITY_LOWEST.patch" \
|
||||
"Xbmc-git-pthread-SetThreadInfo-20120806.patch" \
|
||||
"Xbmc-git-linux-Thread-Name-20120806.patch" \
|
||||
# "Xbmc-git-linux-Thread-Name-20120806.patch" \
|
||||
"xbmc-frodo-433f681-811.12-smoother-page-flip.patch" \
|
||||
"xbmc-frodo-433f681-811.13-change-email-address.patch" \
|
||||
"Xbmc-git-JobManager-Force-exit-after-2.patch" \
|
||||
|
@ -85,8 +80,8 @@ _patches=(
|
|||
"Xbmc-git-WinSystemX11-SDL_CreateRGBSurfaceFrom-no-Dove.patch" \
|
||||
"XbmcPvr-PvrManager-StopUpdateThread.patch" \
|
||||
"Xbmc-git-BandwidthRequester-20120723.patch" \
|
||||
"Xbmc-git-enable-systemd-power-management.patch" \
|
||||
"Xbmc-git-enable-systemd-power-management-2.patch" \
|
||||
# "Xbmc-git-enable-systemd-power-management.patch" \
|
||||
# "Xbmc-git-enable-systemd-power-management-2.patch" \
|
||||
# "Xbmc-git-arm-linux.patch" \
|
||||
# "Xbmc-git-VMETA-TimeStamp.patch" \
|
||||
# "Xbmc-git-VMETA-No-Prebuf.patch" \
|
||||
|
@ -117,18 +112,34 @@ _patches=(
|
|||
)
|
||||
|
||||
build() {
|
||||
|
||||
msg "Connecting to GIT server..."
|
||||
if [ -d $_gitname ]; then
|
||||
cd "${_gitname}"
|
||||
git clean -dxf
|
||||
git reset --hard
|
||||
git pull origin
|
||||
git pull origin master
|
||||
else
|
||||
git clone --depth 1 "${_gitroot}" "${_gitname}"
|
||||
git clone "${_gitroot}" "${_gitname}"
|
||||
cd "${_gitname}"
|
||||
fi
|
||||
msg2 "checkout done or server timeout"
|
||||
|
||||
git checkout 7e6433169c93abd22e28a828fa024cf744fe5e86
|
||||
|
||||
export LDFLAGS="$LDFLAGS -L/opt/marvell-libgfx/lib"
|
||||
export CFLAGS="$CFLAGS -I/opt/marvell-libgfx/include"
|
||||
export CXXFLAGS="$CXXFLAGS -I/opt/marvell-libgfx/include"
|
||||
|
||||
# fix configure: error: Submodule lib/libdvd/libdvdcss failed to configure
|
||||
sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g" \
|
||||
-i lib/libdvd/libdvdcss/configure.ac
|
||||
|
||||
# Java workaround (issue #360).
|
||||
mkdir tmp_lib
|
||||
ln -s /usr/lib/libffi.so.6 tmp_lib/libffi.so.5
|
||||
export LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:${PWD}/tmp_lib"
|
||||
|
||||
# fix lsb_release dependency
|
||||
sed -i -e "s:/usr/bin/lsb_release -d:cat /etc/arch-release:" xbmc/utils/SystemInfo.cpp
|
||||
|
||||
|
@ -137,8 +148,8 @@ build() {
|
|||
patch -p1 -i "${srcdir}/XbmcCuBoxPatches-Rev10/${_patch}"
|
||||
done
|
||||
|
||||
for _patch in "${srcdir}"/AdditionalXbmcCuBoxPatches-Rev10.1/* \
|
||||
"${srcdir}"/{big-buck-bunny-480p-fix.patch,Xbmc-git-Python-2.7-2.patch}; do
|
||||
rm "${srcdir}/AdditionalXbmcCuBoxPatches-Rev10.2/Use-Dove-hardware-graphics-scaler.patch"
|
||||
for _patch in "${srcdir}"/AdditionalXbmcCuBoxPatches-Rev10.2/*; do
|
||||
patch -p1 -i "${_patch}"
|
||||
done
|
||||
|
||||
|
@ -154,9 +165,9 @@ build() {
|
|||
--with-platform=marvell-dove \
|
||||
--enable-external-libraries \
|
||||
--enable-gles \
|
||||
--enable-pulse \
|
||||
--disable-debug \
|
||||
--disable-vaapi \
|
||||
--disable-vdpau \
|
||||
--disable-hal
|
||||
|
||||
msg "make"
|
||||
|
|
|
@ -1,32 +0,0 @@
|
|||
From a7ded663b5a89110a899e130d05364d86940790b Mon Sep 17 00:00:00 2001
|
||||
From: Aldrik Dunbar <aldrik@gmail.com>
|
||||
Date: Wed, 21 Nov 2012 17:47:46 +0100
|
||||
Subject: [PATCH] cubox : fix overlay issue with 480p videos (patch by Rabeeh
|
||||
Khoury)
|
||||
|
||||
---
|
||||
xbmc/cores/VideoRenderers/LinuxRendererDoveOverlay.cpp | 6 ++++++
|
||||
1 file changed, 6 insertions(+)
|
||||
|
||||
diff --git a/xbmc/cores/VideoRenderers/LinuxRendererDoveOverlay.cpp b/xbmc/cores/VideoRenderers/LinuxRendererDoveOverlay.cpp
|
||||
index c1fe0cf..ab96003 100644
|
||||
--- a/xbmc/cores/VideoRenderers/LinuxRendererDoveOverlay.cpp
|
||||
+++ b/xbmc/cores/VideoRenderers/LinuxRendererDoveOverlay.cpp
|
||||
@@ -104,8 +104,14 @@ void CLinuxRendererDoveOverlay::ManageDisplayDove()
|
||||
|
||||
if (m_format == RENDER_FMT_UYVY422)
|
||||
{
|
||||
+ int delta;
|
||||
m_overlaySurface.videoMode = DOVEFB_VMODE_YUV422PACKED_SWAPYUorV;
|
||||
m_overlaySurface.viewPortInfo.ycPitch = (m_sourceRect.x2 - m_sourceRect.x1) * 2;
|
||||
+ /* Align ycPitch to 16 pixels (32 bytes) since vmeta outputs in 16byte alignment per stride */
|
||||
+ /* TODO check of decoded via vmeta or ffmpeg and change accordingly */
|
||||
+ delta = m_overlaySurface.viewPortInfo.ycPitch % 32;
|
||||
+ if (delta)
|
||||
+ m_overlaySurface.viewPortInfo.ycPitch = m_overlaySurface.viewPortInfo.ycPitch - delta + 32;
|
||||
m_overlaySurface.viewPortInfo.uvPitch = 0;
|
||||
}
|
||||
else if (m_format == RENDER_FMT_YUV420P)
|
||||
--
|
||||
1.8.0
|
||||
|
|
@ -1,5 +1,6 @@
|
|||
[Unit]
|
||||
Description = Starts instance of XBMC using xinit
|
||||
Requires = vmeta-clk@667.service
|
||||
After = remote-fs.target
|
||||
|
||||
[Service]
|
||||
|
|
Loading…
Reference in a new issue