community/nodejs to 8.8.1-1.1

This commit is contained in:
Kevin Mihelich 2017-11-15 03:04:37 +00:00
parent 7d0392f4a6
commit ff6e58976d
2 changed files with 14 additions and 105 deletions

View file

@ -1,52 +0,0 @@
From e5071421ad33702cdc2502fc0ce734c0968d8ad6 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 13 Oct 2015 20:45:53 -0600
Subject: [PATCH] arm fixes
---
configure | 5 ++++-
deps/v8/gypfiles/toolchain.gypi | 4 ++--
2 files changed, 6 insertions(+), 3 deletions(-)
diff --git a/configure b/configure
index d926cec..f3fad3e 100755
--- a/configure
+++ b/configure
@@ -738,8 +738,11 @@ def configure_arm(o):
if is_arch_armv7():
arm_fpu = 'vfpv3'
o['variables']['arm_version'] = '7'
+ elif is_arch_armv6():
+ o['variables']['arm_version'] = '6'
else:
- o['variables']['arm_version'] = '6' if is_arch_armv6() else 'default'
+ o['variables']['arm_fpu'] = ''
+ o['variables']['arm_version'] = '5'
o['variables']['arm_thumb'] = 0 # -marm
o['variables']['arm_float_abi'] = arm_float_abi
diff --git a/deps/v8/gypfiles/toolchain.gypi b/deps/v8/gypfiles/toolchain.gypi
index 95eb1d9..6416a1e 100644
--- a/deps/v8/gypfiles/toolchain.gypi
+++ b/deps/v8/gypfiles/toolchain.gypi
@@ -207,7 +207,7 @@
}],
[ 'arm_version==7 or arm_version=="default"', {
'conditions': [
- [ 'arm_fpu!="default"', {
+ [ 'arm_fpu!="default" and arm_fpu!=""', {
'cflags': ['-mfpu=<(arm_fpu)',],
}],
],
@@ -250,7 +250,7 @@
}],
[ 'arm_version==7 or arm_version=="default"', {
'conditions': [
- [ 'arm_fpu!="default"', {
+ [ 'arm_fpu!="default" and arm_fpu!=""', {
'cflags': ['-mfpu=<(arm_fpu)',],
}],
],
--
2.10.2

View file

@ -1,3 +1,4 @@
# $Id$
# Maintainer: Felix Yan <felixonmars@archlinux.org>
# Contributor Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: Thomas Dziedzic < gostrc at gmail >
@ -6,48 +7,28 @@
# Contributor: Dongsheng Cai <dongsheng at moodle dot com>
# Contributor: Masutu Subric <masutu.arch at googlemail dot com>
# Contributor: TIanyi Cui <tianyicui@gmail.com>
# Contributor: Jason Plum <jplum@archlinuxarm.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - set config and gyp flags
buildarch=28
pkgname=nodejs
pkgver=8.8.1
pkgrel=1
pkgrel=1.1
pkgdesc='Evented I/O for V8 javascript'
arch=('i686' 'x86_64')
url='http://nodejs.org/'
license=('MIT')
provides=('nodejs-node-gyp')
depends=('openssl-1.0' 'zlib' 'icu' 'libuv' 'http-parser' 'c-ares') # 'v8')
makedepends=('python2' 'procps-ng')
optdepends=('npm: nodejs package manager')
source=("nodejs-$pkgver.tar.gz::https://github.com/nodejs/node/archive/v$pkgver.tar.gz"
'0001-arm-fixes.patch')
sha512sums=('5bbff8ac1868afddf2a49ba334b048e71797c0c1fe7bfbaf696bd59f475619457a1ea22bfd6645cd2428661664a305243ca820a3d1a9a8710f4a3ec816a7933d'
'4811e1d9bc0e03458072cad6af9284e3ceb6c74005ae00e3407c18d0e6eae0bce2edcbdbe547975ade916c1bcdb2bb53101edce2afeca0bcac84d8807934fc8c')
set_flags_for_arm() {
if [ "$CARCH" == "arm" ]; then
# CXXFLAGS is here to bash it over the head. It has a bad habit.
CONFIG="--with-arm-float-abi=soft"
CXXFLAGS="$CXXFLAGS -march=armv5t -mno-unaligned-access" ;
GYPFLAGS="-Darm_thumb -Darm_float_abi=soft -Darm_version=5 -Darm_fpu= -Darm_test_noprobe=on"
fi
if [ "$CARCH" == "armv6h" ]; then
CONFIG="--with-arm-float-abi=hard"
GYPFLAGS="-Darm_thumb -Darm_float_abi=hard -Darm_version=6 -Darm_fpu=vfpv2"
fi
if [ "$CARCH" == "armv7h" ]; then
CONFIG="--with-arm-float-abi=hard --with-arm-fpu=vfpv3-d16"
GYPFLAGS="-Darm_thumb -Darm_float_abi=hard -Darm_version=7 -Darm_fpu=vfpv3-d16"
fi
export CXXFLAGS
export GYPFLAGS
}
source=("nodejs-$pkgver.tar.gz::https://github.com/nodejs/node/archive/v$pkgver.tar.gz")
sha512sums=('5bbff8ac1868afddf2a49ba334b048e71797c0c1fe7bfbaf696bd59f475619457a1ea22bfd6645cd2428661664a305243ca820a3d1a9a8710f4a3ec816a7933d')
prepare() {
cd node-$pkgver
patch -p1 -i ../0001-arm-fixes.patch
msg 'Fixing for python2 name'
find -type f -exec sed \
-e 's_^#!/usr/bin/env python$_&2_' \
@ -65,37 +46,20 @@ build() {
export PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig
export PYTHON=python2
set_flags_for_arm
# short-cutting python=python2 for GYP, as it will only be used here.
export PYTHON=python2
if [ ! -f "${srcdir}/python" ]; then
ln -s `which python2` ${srcdir}/python ;
fi
PATH="${srcdir}:$PATH";
export PATH ;
# we're going to attept to make use of this example
# https://github.com/joyent/node/issues/2131#issuecomment-3208846
# https://gist.github.com/1574158
[[ "$CARCH" == "armv6h" ]] && export CONFIG="--with-arm-float-abi=hard --with-arm-fpu=vfp" && export GYPFLAGS="-Darm_thumb -Darm_float_abi=hard -Darm_version=6 -Darm_fpu=vfpv2"
[[ "$CARCH" == "armv7h" ]] && export CONFIG="--with-arm-float-abi=hard --with-arm-fpu=vfpv3-d16" && export GYPFLAGS="-Darm_thumb -Darm_float_abi=hard -Darm_version=7 -Darm_fpu=vfpv3-d16"
./configure \
--prefix=/usr \
--with-intl=system-icu \
--without-npm \
--without-snapshot \
--shared-openssl \
--shared-zlib \
--shared-libuv \
--shared-http-parser \
--shared-cares \
${CONFIG}
# --shared-v8 \
# --shared-v8-libpath=/usr/lib \
# --shared-v8-includes=/usr/include
[ "$CARCH" == "arm" ] && sed -i 's/vfpv3//' config.gypi
[ "$CARCH" == "armv6h" ] && sed -i 's/vfpv3/vfp/' config.gypi
# --shared-v8
make
}
@ -109,13 +73,10 @@ check() {
package() {
cd node-$pkgver
# suppress re-compile(with out customized flags) by 'make install'.
set_flags_for_arm
make DESTDIR=${pkgdir} install
make DESTDIR="$pkgdir" install
install -D -m644 LICENSE \
${pkgdir}/usr/share/licenses/nodejs/LICENSE
"$pkgdir"/usr/share/licenses/nodejs/LICENSE
}
# vim:set ts=2 sw=2 et: