mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
extra/pulseaudio to 8.0-3
This commit is contained in:
parent
27091422f1
commit
ff9e39ff85
4 changed files with 111 additions and 17 deletions
|
@ -1,8 +1,8 @@
|
|||
From 343a86252241c591114b064a3340f7beb2d1ff44 Mon Sep 17 00:00:00 2001
|
||||
From d36e55c2d416ac95715d27b2155c3b548ba59c7a Mon Sep 17 00:00:00 2001
|
||||
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
||||
Date: Sun, 21 Feb 2016 12:59:50 +0100
|
||||
Subject: [PATCH] Revert "module-switch-on-port-available: Route to preferred
|
||||
profile"
|
||||
Date: Fri, 26 Feb 2016 20:29:00 +0100
|
||||
Subject: [PATCH 1/2] Revert "module-switch-on-port-available: Route to
|
||||
preferred profile"
|
||||
|
||||
This reverts commit e87100d41ef6d14f8dc7f803582191d9f8d8f183.
|
||||
---
|
||||
|
|
|
@ -0,0 +1,86 @@
|
|||
From 8a7423fb4b4ca9e2825251d734217df8d982ea32 Mon Sep 17 00:00:00 2001
|
||||
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
||||
Date: Fri, 26 Feb 2016 20:29:24 +0100
|
||||
Subject: [PATCH 2/2] Revert "module-alsa-card: Report available ports before
|
||||
unavailable ones"
|
||||
|
||||
This reverts commit 91313e60a81e96ce976f24c522656c57b4ab94ca.
|
||||
---
|
||||
src/modules/alsa/module-alsa-card.c | 31 ++++++-------------------------
|
||||
1 file changed, 6 insertions(+), 25 deletions(-)
|
||||
|
||||
diff --git a/src/modules/alsa/module-alsa-card.c b/src/modules/alsa/module-alsa-card.c
|
||||
index 286cfc9..a88a83f 100644
|
||||
--- a/src/modules/alsa/module-alsa-card.c
|
||||
+++ b/src/modules/alsa/module-alsa-card.c
|
||||
@@ -306,7 +306,7 @@ static void init_profile(struct userdata *u) {
|
||||
am->source = pa_alsa_source_new(u->module, u->modargs, __FILE__, u->card, am);
|
||||
}
|
||||
|
||||
-static pa_available_t calc_port_state(pa_device_port *p, struct userdata *u) {
|
||||
+static void report_port_state(pa_device_port *p, struct userdata *u) {
|
||||
void *state;
|
||||
pa_alsa_jack *jack;
|
||||
pa_available_t pa = PA_AVAILABLE_UNKNOWN;
|
||||
@@ -350,13 +350,9 @@ static pa_available_t calc_port_state(pa_device_port *p, struct userdata *u) {
|
||||
pa = cpa;
|
||||
}
|
||||
}
|
||||
- return pa;
|
||||
-}
|
||||
|
||||
-struct temp_port_avail {
|
||||
- pa_device_port *port;
|
||||
- pa_available_t avail;
|
||||
-};
|
||||
+ pa_device_port_set_available(p, pa);
|
||||
+}
|
||||
|
||||
static int report_jack_state(snd_mixer_elem_t *melem, unsigned int mask) {
|
||||
struct userdata *u = snd_mixer_elem_get_callback_private(melem);
|
||||
@@ -365,7 +361,7 @@ static int report_jack_state(snd_mixer_elem_t *melem, unsigned int mask) {
|
||||
bool plugged_in;
|
||||
void *state;
|
||||
pa_alsa_jack *jack;
|
||||
- struct temp_port_avail *tp, *tports;
|
||||
+ pa_device_port *port;
|
||||
|
||||
pa_assert(u);
|
||||
|
||||
@@ -382,8 +378,6 @@ static int report_jack_state(snd_mixer_elem_t *melem, unsigned int mask) {
|
||||
|
||||
pa_log_debug("Jack '%s' is now %s", pa_strnull(snd_hctl_elem_get_name(elem)), plugged_in ? "plugged in" : "unplugged");
|
||||
|
||||
- tports = tp = pa_xnew0(struct temp_port_avail, pa_hashmap_size(u->jacks)+1);
|
||||
-
|
||||
PA_HASHMAP_FOREACH(jack, u->jacks, state)
|
||||
if (jack->melem == melem) {
|
||||
pa_alsa_jack_set_plugged_in(jack, plugged_in);
|
||||
@@ -396,22 +390,9 @@ static int report_jack_state(snd_mixer_elem_t *melem, unsigned int mask) {
|
||||
|
||||
/* When not using UCM, we have to do the jack state -> port
|
||||
* availability mapping ourselves. */
|
||||
- pa_assert_se(tp->port = jack->path->port);
|
||||
- tp->avail = calc_port_state(tp->port, u);
|
||||
- tp++;
|
||||
+ pa_assert_se(port = jack->path->port);
|
||||
+ report_port_state(port, u);
|
||||
}
|
||||
-
|
||||
- /* Report available ports before unavailable ones: in case port 1 becomes available when port 2 becomes unavailable,
|
||||
- this prevents an unnecessary switch port 1 -> port 3 -> port 2 */
|
||||
-
|
||||
- for (tp = tports; tp->port; tp++)
|
||||
- if (tp->avail != PA_AVAILABLE_NO)
|
||||
- pa_device_port_set_available(tp->port, tp->avail);
|
||||
- for (tp = tports; tp->port; tp++)
|
||||
- if (tp->avail == PA_AVAILABLE_NO)
|
||||
- pa_device_port_set_available(tp->port, tp->avail);
|
||||
-
|
||||
- pa_xfree(tports);
|
||||
return 0;
|
||||
}
|
||||
|
||||
--
|
||||
2.7.1
|
||||
|
|
@ -12,7 +12,7 @@ pkgbase=pulseaudio
|
|||
pkgname=(pulseaudio libpulse pulseaudio-{gconf,zeroconf,lirc,jack,bluetooth,equalizer})
|
||||
pkgdesc="A featureful, general-purpose sound server"
|
||||
pkgver=8.0
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
arch=(i686 x86_64)
|
||||
url="http://www.freedesktop.org/wiki/Software/PulseAudio"
|
||||
license=(LGPL)
|
||||
|
@ -23,15 +23,21 @@ makedepends=(libasyncns libcap attr libxtst libsm libsndfile libtool rtkit libso
|
|||
options=(!emptydirs)
|
||||
source=(http://freedesktop.org/software/$pkgbase/releases/$pkgbase-$pkgver.tar.xz
|
||||
0001-Revert-module-switch-on-port-available-Route-to-pref.patch
|
||||
0002-Revert-module-alsa-card-Report-available-ports-befor.patch
|
||||
padsp-lib32.patch)
|
||||
sha256sums=('690eefe28633466cfd1ab9d85ebfa9376f6b622deec6bfee5091ac9737cd1989'
|
||||
'a1dba5ee625d08cd44bed7fb656a572f76e35751ca7fe450380800cba0cfa394'
|
||||
'4db15e8a696809acafc8a0a4e6c7cc64d34870e2566012618e9953ab65629174'
|
||||
'52fbf7c69132d852e9f6dfd3c16fde78c6931333d2ca12bb1d97091e657da725'
|
||||
'7832fc59df76538ff10aedd297c03cb7ff117235da8bfad26082994bb5b84332')
|
||||
|
||||
prepare() {
|
||||
cd $pkgbase-$pkgver
|
||||
|
||||
# https://bugs.freedesktop.org/show_bug.cgi?id=93946
|
||||
patch -Np1 -i ../0001-Revert-module-switch-on-port-available-Route-to-pref.patch
|
||||
|
||||
# https://bugs.archlinux.org/task/48306
|
||||
patch -Np1 -i ../0002-Revert-module-alsa-card-Report-available-ports-befor.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -97,10 +103,6 @@ package_pulseaudio() {
|
|||
|
||||
rm etc/dbus-1/system.d/pulseaudio-system.conf
|
||||
|
||||
mkdir usr/lib/systemd/user/sockets.target.wants
|
||||
ln -s ../pulseaudio.socket \
|
||||
usr/lib/systemd/user/sockets.target.wants/pulseaudio.socket
|
||||
|
||||
### Split libpulse
|
||||
|
||||
mkdir -p "$srcdir"/libpulse/{etc/pulse,usr/{bin,lib/pulseaudio,share/man/man{1,5}}}
|
||||
|
|
|
@ -1,8 +1,14 @@
|
|||
post_upgrade() {
|
||||
(( $(vercmp $2 6.0-2) < 0 )) && cat <<MSG
|
||||
>>> Many PulseAudio modules with additional dependencies have been split into
|
||||
separate packages. Please check the pulseaudio-* packages and reinstall
|
||||
what you need.
|
||||
MSG
|
||||
true
|
||||
post_install() {
|
||||
# Enable socket by default
|
||||
systemctl --global enable pulseaudio.socket
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
if (( $(vercmp $2 8.0-3) < 0)); then
|
||||
systemctl --global enable pulseaudio.socket
|
||||
fi
|
||||
}
|
||||
|
||||
pre_remove() {
|
||||
systemctl --global disable pulseaudio.socket
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue