core/linux-raspberrypi to 5.10.63-6

This commit is contained in:
graysky 2021-09-14 13:49:40 -04:00
parent b45f10a6dd
commit ff9e47c1e3
2 changed files with 3 additions and 32 deletions

View file

@ -1,27 +0,0 @@
From 46cce667db4dd477556d30137515c839f4efb0b1 Mon Sep 17 00:00:00 2001
From: graysky <graysky@archlinux.us>
Date: Sat, 11 Sep 2021 13:29:39 -0400
Subject: [PATCH] Revert "drm/vc4: hdmi: Remove the DDC probing for status
detection"
This reverts commit 17a554471341cabeb583feb02f04eb785d7d9bf8.
---
drivers/gpu/drm/vc4/vc4_hdmi.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/drivers/gpu/drm/vc4/vc4_hdmi.c b/drivers/gpu/drm/vc4/vc4_hdmi.c
index cc1a05df6195..9e86970d5afc 100644
--- a/drivers/gpu/drm/vc4/vc4_hdmi.c
+++ b/drivers/gpu/drm/vc4/vc4_hdmi.c
@@ -185,6 +185,8 @@ vc4_hdmi_connector_detect(struct drm_connector *connector, bool force)
if (gpio_get_value_cansleep(vc4_hdmi->hpd_gpio) ^
vc4_hdmi->hpd_active_low)
connected = true;
+ } else if (drm_probe_ddc(vc4_hdmi->ddc)) {
+ connected = true;
} else if (HDMI_READ(HDMI_HOTPLUG) & VC4_HDMI_HOTPLUG_CONNECTED) {
connected = true;
}
--
2.33.0

View file

@ -6,12 +6,12 @@
buildarch=20
pkgbase=linux-raspberrypi
_commit=c5def0766084c8fce65a90205fcb61f976b74cf1
_commit=3cae59f7aeffaf19313022eac4a92cb6cf3081ee
_srcname=linux-${_commit}
_kernelname=${pkgbase#linux}
_desc="Raspberry Pi 4"
pkgver=5.10.63
pkgrel=5
pkgrel=6
arch=('armv6h' 'armv7h')
url="http://www.kernel.org/"
license=('GPL2')
@ -22,15 +22,13 @@ source=("https://github.com/raspberrypi/linux/archive/${_commit}.tar.gz"
'linux.preset'
'config.txt'
'config'
'0001-Revert-drm-vc4-hdmi-Remove-the-DDC-probing-for-statu.patch'
'60-linux.hook'
'90-linux.hook')
md5sums=('1abaa165b23a65ba7153cdc681eea89f'
md5sums=('d04a2506080bb4580b8e412988320b72'
'31c02f4518d46deb5f0c2ad1f8b083cd'
'86d4a35722b5410e3b29fc92dae15d4b'
'9669d916a5929a2eedbd64477f83d99e'
'4e77a3c2e7dbf645f60fcc9217587dc6'
'051ba07146602eab77484b99e3b3294b'
'ce6c81ad1ad1f8b333fd6077d47abdaf'
'69e1db90d78f691dc446fe2ab94727eb')