diff --git a/documentation/CMakeLists.txt b/documentation/CMakeLists.txt
index 32b12a3d..581159ca 100644
--- a/documentation/CMakeLists.txt
+++ b/documentation/CMakeLists.txt
@@ -54,7 +54,7 @@ else()
endif()
-find_package(PythonInterp 2.6)
+find_package(PythonInterp 3.8)
# ReST - HTML documentation
if (DOCUTILS_FOUND AND PYTHONINTERP_FOUND)
diff --git a/documentation/processHtml.py b/documentation/processHtml.py
index 1a81df59..5e610ea8 100755
--- a/documentation/processHtml.py
+++ b/documentation/processHtml.py
@@ -25,9 +25,8 @@
import os
import sys
-import string
import re
-import HTMLParser
+import html.parser as HTMLParser
class HtmlToTextParser(HTMLParser.HTMLParser):
def __init__(self):
@@ -89,10 +88,10 @@ def ReadNavigationTemplate( filePath ):
try:
navFile = open( filePath, "r")
except IOError:
- print "Could not open file \'"+filePath+"\'"
+ print("Could not open file \'"+filePath+"\'")
with navFile:
- print "Navigation template: \'"+filePath+"\'"
+ print("Navigation template: \'"+filePath+"\'")
navHtml = navFile.read()
navHtml = StripHTMLComments(navHtml)
navFile.close()
@@ -109,7 +108,7 @@ def WriteIndexFile( outputFile, content ):
except:
pass
- print "Creating Search-Index File : \""+outputFile+"\""
+ print("Creating Search-Index File : \""+outputFile+"\"")
f = open(outputFile, "w")
f.write(content)
@@ -117,7 +116,7 @@ def WriteIndexFile( outputFile, content ):
#-------------------------------------------------------------------------------
def Usage():
- print str(sys.argv[0])+"