From: =?utf-8?q?David_Pr=C3=A9vot?= <taffit@debian.org>
Date: Thu, 2 Apr 2020 16:51:48 -1000
Subject: Protect asm("int3") if defined(LOGGING)

This hopefully fixes FTBFS on non Intel arch.
---
 src/plugins/contrib/dragscroll/dragscrollcfg.h | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/src/plugins/contrib/dragscroll/dragscrollcfg.h b/src/plugins/contrib/dragscroll/dragscrollcfg.h
index 7fc28be..fbff8a8 100644
--- a/src/plugins/contrib/dragscroll/dragscrollcfg.h
+++ b/src/plugins/contrib/dragscroll/dragscrollcfg.h
@@ -35,7 +35,9 @@ class cbDragScrollCfg: public cbConfigurationPanel
         wxString GetBitmapBaseName() const;
         void OnApply();
         void OnCancel(){}
+#if defined(LOGGING)
         virtual void InitDialog(){ asm("int3");} /*trap*/
+#endif
 
         // pointer to owner of the configuration diaglog needed to
         // complete the OnApply/OnCancel EndModal() logic