From 8c739f6a9c89e27a41846090600c247abf9ca4a5 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 20 Feb 2021 10:02:34 -0700
Subject: [PATCH 1/3] use gzip for compression by default

---
 man/mkinitcpio.conf.5.adoc | 2 +-
 mkinitcpio                 | 2 +-
 mkinitcpio.conf            | 2 +-
 3 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/man/mkinitcpio.conf.5.adoc b/man/mkinitcpio.conf.5.adoc
index 3029811..1bd60c5 100644
--- a/man/mkinitcpio.conf.5.adoc
+++ b/man/mkinitcpio.conf.5.adoc
@@ -56,7 +56,7 @@ override the main configuration file.
     Defines a program to filter the generated image through. The kernel
     understands the compression formats yielded by the *zstd*(1), *gzip*(1),
     *bzip2*(1), *lz4*(1), *lzop*(1), *lzma*(1), and *xz*(1) compressors. If
-    unspecified, this setting defaults to _zstd_ compression for Linux ≥ 5.9 and
+    unspecified, this setting defaults to _gzip_ compression for Linux ≥ 5.9 and
     gzip compression for Linux < 5.9. In order to create an uncompressed image,
     define this variable as _cat_.
      +
diff --git a/mkinitcpio b/mkinitcpio
index df8ead5..17eae23 100755
--- a/mkinitcpio
+++ b/mkinitcpio
@@ -413,7 +413,7 @@ build_image() {
 }
 
 validate_compression() {
-    local major minor compression_fallback='zstd'
+    local major minor compression_fallback='gzip'
 
     if [[ -z "$_optcompress" && -v COMPRESSION_OPTIONS && ! -v COMPRESSION ]]; then
         warning 'COMPRESSION_OPTIONS is set without also setting COMPRESSION. Configure COMPRESSION explicitly!'
diff --git a/mkinitcpio.conf b/mkinitcpio.conf
index c07aa9e..4c0c571 100644
--- a/mkinitcpio.conf
+++ b/mkinitcpio.conf
@@ -55,7 +55,7 @@ FILES=()
 HOOKS=(base udev autodetect microcode modconf kms keyboard keymap consolefont block filesystems fsck)
 
 # COMPRESSION
-# Use this to compress the initramfs image. By default, zstd compression
+# Use this to compress the initramfs image. By default, gzip compression
 # is used for Linux ≥ 5.9 and gzip compression is used for Linux < 5.9.
 # Use 'cat' to create an uncompressed image.
 #COMPRESSION="zstd"
-- 
2.36.1