From 05d4a444d7e05312cdb2f3c820db6fb7011bb3b7 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 14 Jun 2018 11:59:02 -0600
Subject: [PATCH] Initialize XRandR before EnterVT

---
 src/armsoc_driver.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/src/armsoc_driver.c b/src/armsoc_driver.c
index b183788..1eb00f3 100644
--- a/src/armsoc_driver.c
+++ b/src/armsoc_driver.c
@@ -1093,6 +1093,9 @@ ARMSOCScreenInit(SCREEN_INIT_ARGS_DECL)
 	 */
 	pScrn->vtSema = TRUE;
 
+	/* Do some XRandR initialization. Return value is not useful */
+	(void)xf86CrtcScreenInit(pScreen);
+
 	/* Take over the virtual terminal from the console, set the
 	 * desired mode, etc.:
 	 */
@@ -1103,9 +1106,6 @@ ARMSOCScreenInit(SCREEN_INIT_ARGS_DECL)
 		}
 	}
 
-	/* Do some XRandR initialization. Return value is not useful */
-	(void)xf86CrtcScreenInit(pScreen);
-
 	if (!miCreateDefColormap(pScreen)) {
 		ERROR_MSG("Cannot create colormap!");
 		goto fail7;
-- 
2.17.1