From 53e15da95d23324ec42c247b0d42b71b6005b0ab Mon Sep 17 00:00:00 2001
From: Jeroen Hofstee <jeroen@myspectrum.nl>
Date: Thu, 26 Jun 2014 20:18:31 +0200
Subject: [PATCH 10/11] common: main.c: make show_boot_progress __weak

This not only looks a bit better it also prevents a
warning with W=1 (no previous prototype).

Signed-off-by: Jeroen Hofstee <jeroen@myspectrum.nl>
Acked-by: Simon Glass <sjg@chromium.org>
---
 common/main.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/common/main.c b/common/main.c
index 5312e7d..115c985 100644
--- a/common/main.c
+++ b/common/main.c
@@ -63,8 +63,7 @@ extern int __g_nTStep_4BC722B3__;
 /*
  * Board-specific Platform code can reimplement show_boot_progress () if needed
  */
-void inline __show_boot_progress (int val) {}
-void show_boot_progress (int val) __attribute__((weak, alias("__show_boot_progress")));
+__attribute__((weak)) void show_boot_progress(int val) {}
 
 #if defined(CONFIG_UPDATE_TFTP)
 void update_tftp (void);
-- 
2.10.2