Description: Add missing link of GraphBLAS to libatomic
 Needed for at least armel, mipsel, m68k and powerpc.
Author: Sébastien Villemot <sebastien@debian.org>
Bug: https://github.com/DrTimothyAldenDavis/SuiteSparse/issues/21
Last-Update: 2020-02-28
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/GraphBLAS/CMakeLists.txt
+++ b/GraphBLAS/CMakeLists.txt
@@ -294,6 +294,7 @@ SET_TARGET_PROPERTIES ( graphblas PROPER
     C_STANDARD_REQUIRED 11
     PUBLIC_HEADER "Include/GraphBLAS.h" )
 set_property ( TARGET graphblas PROPERTY C_STANDARD 11 )
+target_link_libraries(graphblas atomic)
 
 #-------------------------------------------------------------------------------
 # static graphblas library properties
@@ -308,6 +309,7 @@ if ( BUILD_GRB_STATIC_LIBRARY )
        C_STANDARD_REQUIRED 11
        PUBLIC_HEADER "Include/GraphBLAS.h" )
    set_property ( TARGET graphblas_static PROPERTY C_STANDARD 11 )
+   target_link_libraries(graphblas_static atomic)
 endif ( )
 
 #-------------------------------------------------------------------------------