diff -urN a/build.xml b/build.xml
--- a/build.xml	2015-03-13 14:08:21.000000000 -0600
+++ b/build.xml	2015-03-18 10:47:44.169521550 -0600
@@ -251,7 +251,7 @@
   </target>
 
   <target name="maven-compile" depends="compile-boot,process-classes" description="compiles Maven using the bootstrap Maven, skipping automated tests">
-    <java fork="${maven-compile.fork}" classname="org.apache.maven.cli.MavenCli" failonerror="true" timeout="600000"  maxmemory="${maven-compile.maxmemory}">
+    <java fork="${maven-compile.fork}" classname="org.apache.maven.cli.MavenCli" failonerror="true" timeout="6000000"  maxmemory="${maven-compile.maxmemory}">
       <!--jvmarg line="-Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,server=y,suspend=y,address=8000"/-->
       <!--jvmarg value="${maven-compile.jvmargs}"/-->
       <classpath refid="maven.classpath" />