mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
f7a95b30ec
Fix an issue where u-boot would hang whenever a device (for example the GPS hat from Adafruit) is connected to the RPi's GPIO header. These devices usually output something to the serial console during the startup phase of u-boot, making u-boot think it has to interrupt its boot sequence because somebody is trying to interrupt its startup. Closes #2053 Run-tested: RPi4B
36 lines
1.1 KiB
Diff
36 lines
1.1 KiB
Diff
From 3ced0f1608d6ded3d8474ea4a98aec00ae67fe9e Mon Sep 17 00:00:00 2001
|
|
From: Maulik Patel <maulikp163@gmail.com>
|
|
Date: Mon, 10 Jun 2024 18:32:25 +0530
|
|
Subject: [PATCH] disable uart for u-boot
|
|
|
|
---
|
|
board/raspberrypi/rpi/rpi.env | 2 ++
|
|
configs/rpi_4_defconfig | 5 +++++
|
|
2 files changed, 7 insertions(+)
|
|
|
|
diff --git a/board/raspberrypi/rpi/rpi.env b/board/raspberrypi/rpi/rpi.env
|
|
index 30228285ed..44a427512c 100644
|
|
--- a/board/raspberrypi/rpi/rpi.env
|
|
+++ b/board/raspberrypi/rpi/rpi.env
|
|
@@ -3,6 +3,8 @@
|
|
/* environment for Raspberry Pi boards */
|
|
|
|
dhcpuboot=usb start; dhcp u-boot.uimg; bootm
|
|
+bootdelay=-2
|
|
+silent=1
|
|
|
|
/* Environment */
|
|
stdin=serial,usbkbd
|
|
diff --git a/configs/rpi_4_defconfig b/configs/rpi_4_defconfig
|
|
index 2541b83a3d..a5dc879d6a 100644
|
|
--- a/configs/rpi_4_defconfig
|
|
+++ b/configs/rpi_4_defconfig
|
|
@@ -65,3 +65,8 @@ CONFIG_SYS_WHITE_ON_BLACK=y
|
|
CONFIG_VIDEO_BCM2835=y
|
|
CONFIG_CONSOLE_SCROLL_LINES=10
|
|
CONFIG_PHYS_TO_BUS=y
|
|
+CONFIG_BOOTDELAY=-2
|
|
+CONFIG_SILENT_CONSOLE=y
|
|
+CONFIG_SYS_DEVICE_NULLDEV=y
|
|
+CONFIG_SILENT_CONSOLE_UPDATE_ON_SET=y
|
|
+CONFIG_SILENT_U_BOOT_ONLY=y
|