mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
69 lines
2.2 KiB
Bash
69 lines
2.2 KiB
Bash
# Maintainer: kpcyrd <kpcyrd[at]archlinux[dot]org>
|
||
# Maintainer: Caleb Maclennan <caleb@alerque.com>
|
||
# Maintainer: Orhun Parmaksız <orhun@archlinux.org>
|
||
|
||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||
# - remove makedepend on pandoc, don't build/install manpages
|
||
|
||
pkgname=eza
|
||
pkgver=0.20.7
|
||
pkgrel=1
|
||
pkgdesc="A modern replacement for ls (community fork of exa)"
|
||
url="https://github.com/eza-community/eza"
|
||
arch=(x86_64)
|
||
license=(EUPL-1.2)
|
||
provides=(exa)
|
||
replaces=(exa)
|
||
conflicts=(exa)
|
||
depends=(gcc-libs # libgcc_s.so
|
||
glibc # libc.so libm.so
|
||
libgit2)
|
||
makedepends=(cargo)
|
||
source=("$url/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
|
||
sha256sums=('981af52e7a0d5ab374ed2a58b0bb9542acc81235ff479bb1f08d61941f65b18b')
|
||
b2sums=('f62320513ca9526c89b5cbdc7af7607245e72f23ddeb3612f9084179a8c62c4cbb3e96de3c96a8839b509c420d5d1f49d5a86ec9d42ade8303d3f18b6518a0d7')
|
||
|
||
prepare() {
|
||
cd "${pkgname}-${pkgver}"
|
||
cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
|
||
}
|
||
|
||
build() {
|
||
cd "${pkgname}-${pkgver}"
|
||
# Make sure the build fails if our system libgit2 is out
|
||
# of range rather than silently starting to vendor it.
|
||
export LIBGIT2_NO_VENDOR=1
|
||
CFLAGS+=' -ffat-lto-objects'
|
||
cargo build --frozen --release
|
||
mkdir -p target/man
|
||
#for manpage in eza.1 eza_colors.5 eza_colors-explanation.5; do
|
||
# pandoc --standalone -f markdown -t man "man/${manpage}.md" > "target/man/${manpage}"
|
||
#done
|
||
}
|
||
|
||
check() {
|
||
cd "${pkgname}-${pkgver}"
|
||
cargo test --frozen
|
||
target/release/eza -la
|
||
}
|
||
|
||
|
||
package() {
|
||
depends+=(libgit2.so)
|
||
cd "${pkgname}-${pkgver}"
|
||
install -Dm755 "target/release/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
|
||
ln -s eza "${pkgdir}/usr/bin/exa"
|
||
|
||
# install completions
|
||
install -Dm644 "completions/bash/${pkgname}" -t "${pkgdir}/usr/share/bash-completion/completions"
|
||
install -Dm644 "completions/zsh/_${pkgname}" -t "${pkgdir}/usr/share/zsh/site-functions/"
|
||
install -Dm644 "completions/fish/${pkgname}.fish" -t "${pkgdir}/usr/share/fish/vendor_completions.d"
|
||
|
||
# install man pages
|
||
#install -Dm644 target/man/*.1 -t "${pkgdir}/usr/share/man/man1"
|
||
#install -Dm644 target/man/*.5 -t "${pkgdir}/usr/share/man/man5"
|
||
|
||
install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}/" LICENSE.txt
|
||
}
|
||
|
||
# vim: ts=2 sw=2 et:
|