mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
133 lines
3.6 KiB
Bash
133 lines
3.6 KiB
Bash
# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
|
|
# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
|
|
# Contributor: Anatol Pomozov <anatol dot pomozov at gmail>
|
|
|
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
# - disable lto in arch-meson
|
|
|
|
pkgname=meson
|
|
pkgver=1.6.0
|
|
pkgrel=1
|
|
pkgdesc="High productivity build system"
|
|
url="https://mesonbuild.com/"
|
|
arch=(any)
|
|
license=(Apache-2.0)
|
|
depends=(
|
|
bash
|
|
ninja
|
|
python
|
|
python-tqdm
|
|
)
|
|
makedepends=(
|
|
python-build
|
|
python-installer
|
|
python-setuptools
|
|
python-wheel
|
|
)
|
|
checkdepends=(
|
|
boost
|
|
clang
|
|
cmake
|
|
cuda
|
|
cython
|
|
doxygen
|
|
gcc-fortran
|
|
gcc-objc
|
|
git
|
|
glib2-devel
|
|
glibc-locales
|
|
gmock
|
|
gnustep-base
|
|
gobject-introspection
|
|
graphviz
|
|
gtest
|
|
gtk-doc
|
|
gtk-sharp-2
|
|
gtk3
|
|
gtkmm3
|
|
hotdoc
|
|
itstool
|
|
java-environment=8
|
|
ldc
|
|
libelf
|
|
libwmf
|
|
llvm
|
|
mercurial
|
|
mono
|
|
nasm
|
|
netcdf-fortran
|
|
openmpi
|
|
openssh
|
|
protobuf
|
|
python-gobject
|
|
python-pytest-xdist
|
|
qt5-base
|
|
qt5-tools
|
|
rust
|
|
rust-bindgen
|
|
sdl2
|
|
vala
|
|
valgrind
|
|
vulkan-validation-layers
|
|
wayland-protocols
|
|
wxgtk3
|
|
)
|
|
source=(
|
|
https://github.com/mesonbuild/meson/releases/download/$pkgver/meson-$pkgver.tar.gz{,.asc}
|
|
meson-reference-$pkgver.3::https://github.com/mesonbuild/meson/releases/download/$pkgver/meson-reference.3
|
|
meson-reference-$pkgver.json::https://github.com/mesonbuild/meson/releases/download/$pkgver/reference_manual.json
|
|
arch-meson
|
|
cross-lib32
|
|
native-clang
|
|
0001-Skip-broken-tests.patch
|
|
)
|
|
b2sums=('c1d8f143b17fab90c6128a721ac45b9ed6b85d67272149058e74ab827822b6f2c84ebdc261290585e6af38ab5dca52ca013de9b7be70922c96260fc5ee708893'
|
|
'SKIP'
|
|
'18704b557298da2ea1f3edb4ed6c421bff3f973a215e56b340de2e78b1330e13eb00830cf44c3a8d04fd685ec6f8e6d078a4b9f03cf5b9e5413cbbfce55a22dd'
|
|
'4d3bbf98706fd5c1e80da562ea2e737625db455e2eea30d1457a78862afa0b51456d5368abe19542cd524bd96d14d5cb33a22909d988be17e6ecb26929c49bb2'
|
|
'70f042a7603d1139f6cef33aec028da087cacabe278fd47375e1b2315befbfde1c0501ad1ecc63d04d31b232a04f08c735d61ce59d7244521f3d270e417fb5af'
|
|
'9b16477aa77a706492e26fb3ad42e90674b8f0dfe657dd3bd9ba044f921be12ceabeb0050a50a15caee4d999e1ec33ed857bd3bed9e4444d73bb4a4f06381081'
|
|
'7d88929d5a3b49d91c5c9969f19d9b47f3151706526b889515acaeda0141257d5115875ac84832e9ea46f83a7700d673adcc5db84b331cd798c70ae6e90eac1e'
|
|
'f23df4324b30b81f1756a9b443dd35185c4e8717b31fafcd2479071b6f38a8ee0776e97a3cd21a7921a6da892685a45632f6f8282007123b2dd5745492768f54')
|
|
validpgpkeys=(
|
|
19E2D6D9B46D8DAA6288F877C24E631BABB1FE70 # Jussi Pakkanen <jpakkane@gmail.com>
|
|
)
|
|
|
|
prepare() {
|
|
cd $pkgname-$pkgver
|
|
|
|
# Pass tests
|
|
patch -Np1 -i ../0001-Skip-broken-tests.patch
|
|
}
|
|
|
|
build() {
|
|
cd $pkgname-$pkgver
|
|
python -m build --wheel --no-isolation
|
|
}
|
|
|
|
check() (
|
|
cd $pkgname-$pkgver
|
|
export LC_CTYPE=en_US.UTF-8 CPPFLAGS= CFLAGS= CXXFLAGS= LDFLAGS=
|
|
./run_tests.py --failfast
|
|
)
|
|
|
|
package() {
|
|
cd $pkgname-$pkgver
|
|
python -m installer --destdir="$pkgdir" dist/*.whl
|
|
|
|
install -d "$pkgdir/usr/share/vim/vimfiles"
|
|
cp -rt "$pkgdir/usr/share/vim/vimfiles" data/syntax-highlighting/vim/*/
|
|
|
|
install -Dm644 data/shell-completions/bash/* -t "$pkgdir/usr/share/bash-completion/completions"
|
|
install -Dm644 data/shell-completions/zsh/* -t "$pkgdir/usr/share/zsh/site-functions"
|
|
|
|
install -Dm644 ../meson-reference-$pkgver.3 "$pkgdir/usr/share/man/man3/meson-reference.3"
|
|
install -Dm644 ../meson-reference-$pkgver.json "$pkgdir/usr/share/doc/$pkgname/reference_manual.json"
|
|
|
|
install -D ../arch-meson -t "$pkgdir/usr/bin"
|
|
|
|
install -Dm644 ../cross-lib32 "$pkgdir/usr/share/meson/cross/lib32"
|
|
install -Dm644 ../native-clang "$pkgdir/usr/share/meson/native/clang"
|
|
}
|
|
|
|
# vim:set sw=2 sts=-1 et:
|