PKGBUILDs/extra/meson/arch-meson
2023-07-18 02:04:08 +00:00

15 lines
359 B
Bash
Executable file

#!/bin/bash -ex
# Highly opinionated wrapper for Arch Linux packaging
exec meson setup \
--prefix /usr \
--libexecdir lib \
--sbindir bin \
--buildtype plain \
--auto-features enabled \
--wrap-mode nodownload \
-D b_lto=false \
-D b_pie=true \
-D python.bytecompile=1 \
"$@"