PKGBUILDs/extra/openexr/PKGBUILD
2024-11-13 00:23:36 +00:00

33 lines
918 B
Bash

# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - build v7 with vfpv3, neon is broken
pkgname=openexr
pkgver=3.3.2
pkgrel=1
pkgdesc='A high dynamic-range image file format library'
url='https://www.openexr.com/'
arch=(x86_64)
license=(BSD-3-Clause)
depends=(gcc-libs
glibc
imath
libdeflate)
makedepends=(cmake
git)
source=(git+https://github.com/openexr/openexr#tag=v$pkgver)
sha256sums=('549c95f71f36f7e6164828f6646b1ec1c4efff6994431416d9a7884345c5ab55')
build() {
[[ $CARCH == "armv7h" ]] && CFLAGS=`echo $CFLAGS | sed -e 's/neon/vfpv3/'` && CXXFLAGS="$CFLAGS"
cmake -B build -S $pkgname \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=None
cmake --build build
}
package() {
DESTDIR="$pkgdir" cmake --install build
install -Dm644 $pkgname/LICENSE.md -t "$pkgdir"/usr/share/licenses/$pkgname
}