PKGBUILDs/extra/python-protobuf/PKGBUILD
2024-10-14 12:07:22 -04:00

29 lines
933 B
Bash

# ALARM: BrainDamage <braindamage@archlinux.org>
# - use pypi tarball as source
# - use normal python toolchain to build
pkgname=python-protobuf
_basename=protobuf
pkgver=28.2
_ver=5
pkgrel=3
pkgdesc="Protocol Buffers - Google's data interchange format"
arch=('aarch64' 'armv7h')
url='https://developers.google.com/protocol-buffers/'
license=('BSD-3-Clause')
depends=('python' "protobuf=${pkgver}")
makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_basename::1}/${_basename}/${_basename}-${_ver}.${pkgver}.tar.gz")
sha256sums=('59379674ff119717404f7454647913787034f03fe7049cbef1d74a97bb4593f0')
build() {
cd "${_basename}-${_ver}.${pkgver}"
export PYTHONHASHSEED=0
python -m build --wheel --no-isolation
}
package() {
cd "${_basename}-${_ver}.${pkgver}"
python -m installer --compile-bytecode 1 --destdir="${pkgdir}" dist/*.whl
}