PKGBUILDs/extra/xfce4-whiskermenu-plugin/PKGBUILD
2025-02-25 11:17:46 +00:00

36 lines
1.1 KiB
Bash

# Maintainer: Robin Candau <antiz@archlinux.org>
# Contributor: Brad Fanella <cesura@archlinux.org>
# Contributor: Alexander F Rødseth <xyproto@archlinux.org>
# Contributor: Graeme Gott <graeme@gottcode.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - cmake with -DENABLE_LINK_TIME_OPTIMIZATION=off
pkgname=xfce4-whiskermenu-plugin
pkgver=2.9.2
pkgrel=2
pkgdesc='Menu for Xfce4'
arch=('x86_64')
url='https://docs.xfce.org/panel-plugins/xfce4-whiskermenu-plugin/start'
license=('GPL-2.0-or-later')
groups=('xfce4-goodies')
depends=('accountsservice' 'garcon' 'gtk3' 'gtk-layer-shell' 'xfce4-panel')
makedepends=('cmake' 'git' 'ninja')
optdepends=('mugshot: Update user details')
source=("git+https://gitlab.xfce.org/panel-plugins/xfce4-whiskermenu-plugin.git#tag=v${pkgver}")
sha256sums=('c81107cb2d6a3358da225ce62771f5f8d7400d2c896accfbd92846098a09de15')
build() {
cmake -B build -S "${pkgname}" \
-DCMAKE_BUILD_TYPE='None' \
-DCMAKE_INSTALL_PREFIX='/usr' \
-DCMAKE_INSTALL_LIBDIR='lib' \
-DENABLE_LINK_TIME_OPTIMIZATION=off \
-GNinja \
-Wno-dev
cmake --build build
}
package() {
DESTDIR="${pkgdir}" cmake --install build
}