mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
33 lines
911 B
Bash
33 lines
911 B
Bash
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
|
|
# Contributor: Fabien Dubosson <fabien.dubosson@gmail.com>
|
|
# Contributor: Konstantin Gizdov <arch@kge.com>
|
|
|
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
# - set DISPATCH=0, x86 only
|
|
|
|
pkgname=xxhash
|
|
pkgver=0.8.3
|
|
pkgrel=1
|
|
pkgdesc='Extremely fast non-cryptographic hash algorithm'
|
|
arch=(x86_64)
|
|
url=https://cyan4973.github.io/xxHash/
|
|
license=(
|
|
GPL2
|
|
BSD
|
|
)
|
|
depends=(glibc)
|
|
makedepends=(git)
|
|
provides=(libxxhash.so)
|
|
source=(git+https://github.com/Cyan4973/xxHash.git#tag=v${pkgver})
|
|
b2sums=('e8c03ae30da955a0399bbbdee866dcc3f999bd1f780373d28119972a89a6ef3b266097024379c779d4c02ae3ca218728d4843c6085487ec76c5e7e1b393e1ea2')
|
|
|
|
build() {
|
|
make PREFIX=/usr DISPATCH=0 -C xxHash
|
|
}
|
|
|
|
package() {
|
|
make PREFIX=/usr DISPATCH=0 DESTDIR="${pkgdir}" -C xxHash install
|
|
install -Dm 644 xxHash/LICENSE -t "${pkgdir}"/usr/share/licenses/xxhash
|
|
}
|
|
|
|
# vim: ts=2 sw=2 et:
|