mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
22 lines
932 B
Diff
22 lines
932 B
Diff
diff '--color=auto' -rupN soundtouch.orig/CMakeLists.txt soundtouch/CMakeLists.txt
|
|
--- soundtouch.orig/CMakeLists.txt 2021-08-26 13:11:17.958981063 +0200
|
|
+++ soundtouch/CMakeLists.txt 2021-08-26 13:16:35.308990428 +0200
|
|
@@ -34,6 +34,7 @@ target_include_directories(SoundTouch PU
|
|
$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/include>
|
|
$<INSTALL_INTERFACE:${CMAKE_INSTALL_INCLUDEDIR}>
|
|
)
|
|
+set_target_properties(SoundTouch PROPERTIES VERSION 1.0.0 SOVERSION 1)
|
|
|
|
target_compile_definitions(SoundTouch PRIVATE ${COMPILE_DEFINITIONS})
|
|
target_compile_options(SoundTouch PRIVATE ${COMPILE_OPTIONS})
|
|
@@ -121,6 +122,10 @@ endif()
|
|
|
|
########################
|
|
|
|
+# autotools
|
|
+install(FILES include/soundtouch_config.h DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}/soundtouch")
|
|
+install(FILES soundtouch.m4 DESTINATION "${CMAKE_INSTALL_DATADIR}/aclocal")
|
|
+
|
|
# pkgconfig
|
|
set(prefix "${CMAKE_INSTALL_PREFIX}")
|
|
set(execprefix "\${prefix}")
|