mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
111 lines
3.9 KiB
Diff
111 lines
3.9 KiB
Diff
From 20bd9add2fb4d96de28c28d25c2971e6ca011a33 Mon Sep 17 00:00:00 2001
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
Date: Mon, 18 Nov 2019 20:41:03 -0700
|
|
Subject: [PATCH] 32-bit fixes
|
|
|
|
---
|
|
utils/nfsdcld/nfsdcld.c | 14 +++++++-------
|
|
utils/nfsdcld/sqlite.c | 6 +++---
|
|
2 files changed, 10 insertions(+), 10 deletions(-)
|
|
|
|
diff --git a/utils/nfsdcld/nfsdcld.c b/utils/nfsdcld/nfsdcld.c
|
|
index b064336d..6d8f502d 100644
|
|
--- a/utils/nfsdcld/nfsdcld.c
|
|
+++ b/utils/nfsdcld/nfsdcld.c
|
|
@@ -378,7 +378,7 @@ cld_not_implemented(struct cld_client *clnt)
|
|
bsize = cld_message_size(cmsg);
|
|
wsize = atomicio((void *)write, clnt->cl_fd, cmsg, bsize);
|
|
if (wsize != bsize)
|
|
- xlog(L_ERROR, "%s: problem writing to cld pipe (%ld): %m",
|
|
+ xlog(L_ERROR, "%s: problem writing to cld pipe (%d): %m",
|
|
__func__, wsize);
|
|
|
|
/* reopen pipe, just to be sure */
|
|
@@ -409,7 +409,7 @@ cld_get_version(struct cld_client *clnt)
|
|
xlog(D_GENERAL, "Doing downcall with status %d", cmsg->cm_status);
|
|
wsize = atomicio((void *)write, clnt->cl_fd, cmsg, bsize);
|
|
if (wsize != bsize) {
|
|
- xlog(L_ERROR, "%s: problem writing to cld pipe (%ld): %m",
|
|
+ xlog(L_ERROR, "%s: problem writing to cld pipe (%d): %m",
|
|
__func__, wsize);
|
|
ret = cld_pipe_open(clnt);
|
|
if (ret) {
|
|
@@ -459,7 +459,7 @@ reply:
|
|
xlog(D_GENERAL, "Doing downcall with status %d", cmsg->cm_status);
|
|
wsize = atomicio((void *)write, clnt->cl_fd, cmsg, bsize);
|
|
if (wsize != bsize) {
|
|
- xlog(L_ERROR, "%s: problem writing to cld pipe (%ld): %m",
|
|
+ xlog(L_ERROR, "%s: problem writing to cld pipe (%d): %m",
|
|
__func__, wsize);
|
|
ret = cld_pipe_open(clnt);
|
|
if (ret) {
|
|
@@ -498,7 +498,7 @@ reply:
|
|
cmsg->cm_status);
|
|
wsize = atomicio((void *)write, clnt->cl_fd, cmsg, bsize);
|
|
if (wsize != bsize) {
|
|
- xlog(L_ERROR, "%s: problem writing to cld pipe (%ld): %m",
|
|
+ xlog(L_ERROR, "%s: problem writing to cld pipe (%d): %m",
|
|
__func__, wsize);
|
|
ret = cld_pipe_open(clnt);
|
|
if (ret) {
|
|
@@ -548,7 +548,7 @@ reply:
|
|
cmsg->cm_status);
|
|
wsize = atomicio((void *)write, clnt->cl_fd, cmsg, bsize);
|
|
if (wsize != bsize) {
|
|
- xlog(L_ERROR, "%s: problem writing to cld pipe (%ld): %m",
|
|
+ xlog(L_ERROR, "%s: problem writing to cld pipe (%d): %m",
|
|
__func__, wsize);
|
|
ret = cld_pipe_open(clnt);
|
|
if (ret) {
|
|
@@ -607,7 +607,7 @@ reply:
|
|
xlog(D_GENERAL, "Doing downcall with status %d", cmsg->cm_status);
|
|
wsize = atomicio((void *)write, clnt->cl_fd, cmsg, bsize);
|
|
if (wsize != bsize) {
|
|
- xlog(L_ERROR, "%s: problem writing to cld pipe (%ld): %m",
|
|
+ xlog(L_ERROR, "%s: problem writing to cld pipe (%d): %m",
|
|
__func__, wsize);
|
|
ret = cld_pipe_open(clnt);
|
|
if (ret) {
|
|
@@ -667,7 +667,7 @@ reply:
|
|
xlog(D_GENERAL, "Doing downcall with status %d", cmsg->cm_status);
|
|
wsize = atomicio((void *)write, clnt->cl_fd, cmsg, bsize);
|
|
if (wsize != bsize) {
|
|
- xlog(L_ERROR, "%s: problem writing to cld pipe (%ld): %m",
|
|
+ xlog(L_ERROR, "%s: problem writing to cld pipe (%d): %m",
|
|
__func__, wsize);
|
|
ret = cld_pipe_open(clnt);
|
|
if (ret) {
|
|
diff --git a/utils/nfsdcld/sqlite.c b/utils/nfsdcld/sqlite.c
|
|
index 23be7971..ec60a056 100644
|
|
--- a/utils/nfsdcld/sqlite.c
|
|
+++ b/utils/nfsdcld/sqlite.c
|
|
@@ -512,7 +512,7 @@ sqlite_startup_query_grace(void)
|
|
current_epoch = tcur;
|
|
recovery_epoch = trec;
|
|
ret = 0;
|
|
- xlog(D_GENERAL, "%s: current_epoch=%lu recovery_epoch=%lu",
|
|
+ xlog(D_GENERAL, "%s: current_epoch=%llu recovery_epoch=%llu",
|
|
__func__, current_epoch, recovery_epoch);
|
|
out:
|
|
sqlite3_finalize(stmt);
|
|
@@ -1223,7 +1223,7 @@ sqlite_grace_start(void)
|
|
|
|
current_epoch = tcur;
|
|
recovery_epoch = trec;
|
|
- xlog(D_GENERAL, "%s: current_epoch=%lu recovery_epoch=%lu",
|
|
+ xlog(D_GENERAL, "%s: current_epoch=%llu recovery_epoch=%llu",
|
|
__func__, current_epoch, recovery_epoch);
|
|
|
|
out:
|
|
@@ -1282,7 +1282,7 @@ sqlite_grace_done(void)
|
|
}
|
|
|
|
recovery_epoch = 0;
|
|
- xlog(D_GENERAL, "%s: current_epoch=%lu recovery_epoch=%lu",
|
|
+ xlog(D_GENERAL, "%s: current_epoch=%llu recovery_epoch=%llu",
|
|
__func__, current_epoch, recovery_epoch);
|
|
|
|
out:
|
|
--
|
|
2.23.0
|
|
|