mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
34 lines
1.1 KiB
Diff
34 lines
1.1 KiB
Diff
From 606c1e88afb03aecc90b0d37ec093d687ed797e5 Mon Sep 17 00:00:00 2001
|
|
From: Jelle van der Waa <jelle@vdwaa.nl>
|
|
Date: Tue, 4 Apr 2017 23:59:49 +0200
|
|
Subject: [PATCH 2/3] rsa: Fix deprecated warnings for OpenSSL 1.1.x
|
|
|
|
ERR_remove_thread_state is deprecated in OpenSSL 1.1.x and does not do
|
|
anything anymore. Thread initialisation and deinitialisation is now
|
|
handled by the OpenSSL library.
|
|
|
|
Signed-off-by: Jelle van der Waa <jelle@vdwaa.nl>
|
|
Reviewed-by: Simon Glass <sjg@chromium.org>
|
|
---
|
|
lib/rsa/rsa-sign.c | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/lib/rsa/rsa-sign.c b/lib/rsa/rsa-sign.c
|
|
index 5b7022d428..711501741a 100644
|
|
--- a/lib/rsa/rsa-sign.c
|
|
+++ b/lib/rsa/rsa-sign.c
|
|
@@ -357,9 +357,9 @@ static void rsa_remove(void)
|
|
{
|
|
CRYPTO_cleanup_all_ex_data();
|
|
ERR_free_strings();
|
|
-#ifdef HAVE_ERR_REMOVE_THREAD_STATE
|
|
+#if OPENSSL_VERSION_NUMBER >= 0x10000000L && OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
|
|
ERR_remove_thread_state(NULL);
|
|
-#else
|
|
+#elif OPENSSL_VERSION_NUMBER < 0x10000000L
|
|
ERR_remove_state(0);
|
|
#endif
|
|
EVP_cleanup();
|
|
--
|
|
2.12.2
|
|
|