mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
41 lines
1.2 KiB
Diff
41 lines
1.2 KiB
Diff
From c93756c8f066a1e35fa2f46b231771d78e292600 Mon Sep 17 00:00:00 2001
|
|
Message-Id: <c93756c8f066a1e35fa2f46b231771d78e292600.1509419562.git.jan.steffens@gmail.com>
|
|
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
|
Date: Tue, 31 Oct 2017 04:11:42 +0100
|
|
Subject: [PATCH] meson: Fix libmount support
|
|
|
|
The define was still missing.
|
|
---
|
|
config.h.meson | 3 +++
|
|
meson.build | 1 +
|
|
2 files changed, 4 insertions(+)
|
|
|
|
diff --git a/config.h.meson b/config.h.meson
|
|
index c67e1792f4af1ada..3f310b3c960fcb29 100644
|
|
--- a/config.h.meson
|
|
+++ b/config.h.meson
|
|
@@ -247,6 +247,9 @@
|
|
/* Define if libelf is available */
|
|
#mesondefine HAVE_LIBELF
|
|
|
|
+/* Define if libmount is available */
|
|
+#mesondefine HAVE_LIBMOUNT
|
|
+
|
|
/* Define to 1 if you have the <linux/magic.h> header file. */
|
|
#mesondefine HAVE_LINUX_MAGIC_H
|
|
|
|
diff --git a/meson.build b/meson.build
|
|
index 208c23087627de1e..cd9cbf2ce10595c2 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -1535,6 +1535,7 @@ if use_system_pcre
|
|
endif
|
|
if libmount_dep.length() == 1 and libmount_dep[0].found()
|
|
glib_conf.set('LIBMOUNT_LIBS', '-lmount')
|
|
+ glib_conf.set('HAVE_LIBMOUNT', 1)
|
|
endif
|
|
glib_conf.set('GIO_MODULE_DIR', '${libdir}/gio/modules')
|
|
# FIXME: Missing:
|
|
--
|
|
2.15.0
|
|
|