mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
34 lines
1.2 KiB
Diff
34 lines
1.2 KiB
Diff
|
|
# HG changeset patch
|
|
# User Jean-Yves Avenard <jyavenard@mozilla.com>
|
|
# Date 1450657258 -39600
|
|
# Node ID 8b0ced62c1957f6da6028af686c32ada1ccb570c
|
|
# Parent e1a98377eb38679bda820456ee6d20bdc17eaa8e
|
|
Bug 1233340: [ffmpeg] Support YUV420J pixel format. r=kentuckyfriedtakahe
|
|
|
|
YUV420J is 12bpp YUV420P.
|
|
|
|
|
|
diff --git a/dom/media/platforms/ffmpeg/FFmpegDataDecoder.cpp b/dom/media/platforms/ffmpeg/FFmpegDataDecoder.cpp
|
|
--- a/dom/media/platforms/ffmpeg/FFmpegDataDecoder.cpp
|
|
+++ b/dom/media/platforms/ffmpeg/FFmpegDataDecoder.cpp
|
|
@@ -52,17 +52,17 @@ FFmpegDataDecoder<LIBAV_VER>::~FFmpegDat
|
|
* For now, we just look for YUV420P as it is the only non-HW accelerated format
|
|
* supported by FFmpeg's H264 decoder.
|
|
*/
|
|
static PixelFormat
|
|
ChoosePixelFormat(AVCodecContext* aCodecContext, const PixelFormat* aFormats)
|
|
{
|
|
FFMPEG_LOG("Choosing FFmpeg pixel format for video decoding.");
|
|
for (; *aFormats > -1; aFormats++) {
|
|
- if (*aFormats == PIX_FMT_YUV420P) {
|
|
+ if (*aFormats == PIX_FMT_YUV420P || *aFormats == PIX_FMT_YUVJ420P) {
|
|
FFMPEG_LOG("Requesting pixel format YUV420P.");
|
|
return PIX_FMT_YUV420P;
|
|
}
|
|
}
|
|
|
|
NS_WARNING("FFmpeg does not share any supported pixel formats.");
|
|
return PIX_FMT_NONE;
|
|
}
|
|
|