mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
52 lines
1.3 KiB
Diff
52 lines
1.3 KiB
Diff
--- usr/lib/oss/build/install.sh.orig 2008-09-25 11:41:47.180167692 -0300
|
|
+++ usr/lib/oss/build/install.sh 2008-09-25 11:41:47.180167692 -0300
|
|
@@ -290,38 +290,6 @@
|
|
echo
|
|
fi
|
|
|
|
-if ! test -d /etc/init.d
|
|
-then
|
|
- mkdir /etc/init.d
|
|
-fi
|
|
-
|
|
-rm -f /etc/init.d/oss /etc/rc.d/rc3.d/S89oss /etc/rc3.d/S89oss
|
|
-cp -f $OSSLIBDIR/etc/S89oss /etc/init.d/oss
|
|
-
|
|
-chmod 744 /etc/init.d/oss
|
|
-
|
|
-if test -x /sbin/chkconfig
|
|
-then
|
|
- /sbin/chkconfig oss on > /dev/null 2>&1
|
|
-else
|
|
- if test -x /usr/sbin/update-rc.d
|
|
- then
|
|
- /usr/sbin/update-rc.d oss defaults > /dev/null 2>&1
|
|
- else
|
|
- if test -d etc/rc.d/rc3.d
|
|
- then
|
|
- rm -f /etc/rc.d/rc3.d/S89oss
|
|
- ln -s /etc/init.d/oss /etc/rc.d/rc3.d/S89oss
|
|
- else
|
|
- if test -d /etc/rc3.d
|
|
- then
|
|
- rm -f /etc/rc3.d/S89oss
|
|
- ln -s /etc/init.d/oss /etc/rc3.d/S89oss
|
|
- fi
|
|
- fi
|
|
- fi
|
|
-fi
|
|
-
|
|
# Install ALSA interface module (Cuckoo)
|
|
#(cd $OSSLIBDIR/cuckoo && make clean) > /dev/null 2>&1
|
|
#if (cd $OSSLIBDIR/cuckoo && make install) > /var/log/cuckoo.log 2>&1
|
|
--- usr/lib/oss/scripts/restore_drv.sh.orig 2008-09-25 11:41:47.210168487 -0300
|
|
+++ usr/lib/oss/scripts/restore_drv.sh 2008-09-25 11:41:47.210168487 -0300
|
|
@@ -18,8 +18,6 @@
|
|
fi
|
|
fi
|
|
|
|
-rm -f /etc/init.d/oss
|
|
-
|
|
if ! test -d /lib/modules/`uname -r`/kernel/sound
|
|
then
|
|
if test -f /lib/modules/`uname -r`/sound-preoss.tar.bz2
|