PKGBUILDs/alarm/uboot-sunxi/0001-arch-linux-arm-modifications.patch
2015-10-29 02:37:35 +00:00

39 lines
1.2 KiB
Diff

From 6b2f5de6ad3b427b3149d142b74d0667e5fbe8cb Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 2 Jan 2015 20:16:57 -0700
Subject: [PATCH] arch linux arm modifications
---
include/config_distro_defaults.h | 3 +++
include/configs/sunxi-common.h | 2 +-
2 files changed, 4 insertions(+), 1 deletion(-)
diff --git a/include/config_distro_defaults.h b/include/config_distro_defaults.h
index 9d1de55..b75c454 100644
--- a/include/config_distro_defaults.h
+++ b/include/config_distro_defaults.h
@@ -67,4 +67,7 @@
#define CONFIG_SUPPORT_RAW_INITRD
#define CONFIG_SYS_HUSH_PARSER
+#define CONFIG_CMD_PART
+#define CONFIG_PARTITION_UUIDS
+
#endif /* _CONFIG_CMD_DISTRO_DEFAULTS_H */
diff --git a/include/configs/sunxi-common.h b/include/configs/sunxi-common.h
index f5db4d3..1cdba92 100644
--- a/include/configs/sunxi-common.h
+++ b/include/configs/sunxi-common.h
@@ -176,7 +176,7 @@
#define CONFIG_SYS_NO_FLASH
#define CONFIG_SYS_MONITOR_LEN (768 << 10) /* 768 KiB */
-#define CONFIG_IDENT_STRING " Allwinner Technology"
+#define CONFIG_IDENT_STRING " Arch Linux ARM"
#define CONFIG_ENV_OFFSET (544 << 10) /* (8 + 24 + 512) KiB */
#define CONFIG_ENV_SIZE (128 << 10) /* 128 KiB */
--
2.6.1